DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th July 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default libgio 2

Okay.

Been trying to build a load of my want list Kopete, nvidia-settings etc. but quite often when I make the port I see:

/usr/bin/ld: cannot find -lgio-2.0

fair enough, so that is basically (as I understand) a problem with myglib. However I have glib installed, although not the most recent version. I did try the force package option with the new one, although this worried me.

What should I be looking at now?
Reply With Quote
  #2   (View Single Post)  
Old 17th July 2008
deemon's Avatar
deemon deemon is offline
Fdisk Soldier
 
Join Date: May 2008
Location: Estonia
Posts: 50
Thanked 6 Times in 5 Posts
Default

That problem has bugged a lot of people lately..
I solved the problem by updating my glib (devel/glib20) to 2.16.3
__________________
Fhtagn nagh Yog-Sothoth
Reply With Quote
  #3   (View Single Post)  
Old 17th July 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

reinstall worked. Was previously doing uninstall then install.
Reply With Quote
  #4   (View Single Post)  
Old 17th July 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

No good. I've tried a deinstall/reinstall:

===> Installing for glib-2.16.4
===> glib-2.16.4 depends on file: /usr/local/bin/python2.5 - found
===> glib-2.16.4 depends on file: /usr/local/bin/perl5.8.8 - found
===> glib-2.16.4 depends on executable: pkg-config - found
===> Generating temporary packing list
===> Checking if devel/glib20 already installed
===> glib-2.16.4 is already installed
You may wish to ``make deinstall'' and install this port again
by ``make reinstall'' to upgrade it properly.
If you really wish to overwrite the old port of devel/glib20
without deleting it first, set the variable "FORCE_PKG_REGISTER"
in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/devel/glib20.
*** Error code 1

Stop in /usr/ports/devel/glib20.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick