DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 26th December 2008
delboy's Avatar
delboy delboy is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 63
Thanked 0 Times in 0 Posts
Default No access to virtual terminals from X.

No access when in the Gnome desktop environment,everything o/k otherwise.
FreeBSD FAQ extract.
Code:
11.11. How do I access the virtual consoles from X?

Use Ctrl+Alt+Fn to switch back to a virtual console. Ctrl+Alt+F1 would return you to the first virtual console.

Once you are back to a text console, you can then use Alt+Fn as normal to move between them.
I dont have an Fn key,but I have tried Ctrl+Alt+F(all Fkeys) and Alt+F keys.
But nothing seems to work.Apart from sending my /etc/ttys and /etc/X11/xorg.conf I dont know what else I can do.



Code:
ttyv0   "/usr/libexec/getty Pc"         cons25  on  secure
# Virtual terminals
ttyv1   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv2   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv3   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv4   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv5   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv6   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv7   "/usr/libexec/getty Pc"         cons25  on  secure
ttyv8   "/usr/local/sbin/gdm -nodaemon" xterm   off secure

Code:
Section "InputDevice"
 	Identifier  "Keyboard0"
	Driver      "kbd"
        Option      "XkbLayout" "uk"
        Option      "XkbModel"  "pc105"
Reply With Quote
  #2   (View Single Post)  
Old 26th December 2008
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

It doesn't mean the Fn key (as found on a number of laptops), but an Fn function key, i.e. F1, F2, F3, F4, F5, F6, F7, or F8, and depending on your keyboard even possible is quite a number more of function keys lol.

ctrl+alt+f1 = go to vtty0 (system console)
ctl+alt+f2 = go to vtty1
ctl+alt+f3 = go to vtty2

and so on.

The X windows system runs on a vtty of it's own, so you get back to X with an ctl+alt+Fn key sequence; which one depends on how you've got X starting up. (Probably F8, F9, or F5)
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #3   (View Single Post)  
Old 26th December 2008
delboy's Avatar
delboy delboy is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 63
Thanked 0 Times in 0 Posts
Default

TerryP wrote

Quote:
ctrl+alt+f1 = go to vtty0 (system console)
ctl+alt+f2 = go to vtty1
ctl+alt+f3 = go to vtty2
I have tried all of these and up to f9, but still no virtual terminals.
I have checked the FreeBSD Handbook,could find nothing about my problem,been googling best part of the day and found nothing relevant.
Im using FreeBSD 7.1-rc1-amd64
It seems like my keyboard and v/ts cannot find each other.
Reply With Quote
  #4   (View Single Post)  
Old 26th December 2008
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,068
Thanked 198 Times in 156 Posts
Default

You can disable CTRL+ALT+Fn switching with the Option "DontVTSwitch" in xorg.conf(5) (ServerFlags section), maybe this option is set?

The easiest way to check is with grep(1):
% grep -i dontvtswitch /etc/X11/xorg.conf
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #5   (View Single Post)  
Old 26th December 2008
delboy's Avatar
delboy delboy is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 63
Thanked 0 Times in 0 Posts
Default

Carpetsmoker wrote

Quote:
You can disable CTRL+ALT+Fn switching with the Option "DontVTSwitch" in xorg.conf(5) (ServerFlags section), maybe this option is set?

The easiest way to check is with grep(1):
% grep -i dontvtswitch /etc/X11/xorg.conf
No response from that command.
Reply With Quote
  #6   (View Single Post)  
Old 26th December 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

There is also the "DontZap" option which may interfere as well.

Hold down both the control and the alt keys, and press "F1". X will disappear, and a text console will appear. That is what it is talking about. In text consoles, alt plus a function key switches between 10 or so terminals. One of them is running X, and will return you to gnome
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
  #7   (View Single Post)  
Old 27th December 2008
delboy's Avatar
delboy delboy is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 63
Thanked 0 Times in 0 Posts
Default

Thank you for your help guys.but I think we are talking at cross purposes.
It does not matter which CTRL+ALT+F1,2,3etc,I use, nothing happens.
I cannot exit GUI into any v/ts.
I may have thrown you off course with my misunderstanding of the Fn key,I really didnt know it stood for function,thought it was some special key,thanks to TerryP for explanation.
I do know how to use CTRL+ALT+F1,2,3,etc,I read about that in the handbook(my bible)it just dosent say what to do when those keystrokes do not work.
Reply With Quote
  #8   (View Single Post)  
Old 27th December 2008
delboy's Avatar
delboy delboy is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 63
Thanked 0 Times in 0 Posts
Default

Problem solved,googled around and found this.

http://pigeonsnest.co.uk/stuff/sarge/vtswitch.html

Changed "uk" to "gb" in /etc/X11/xorg.conf and everything is fine.
Reply With Quote
  #9   (View Single Post)  
Old 28th December 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Great to hear!

It seems like the wrong keyboard mapping meant that either your control, alt or function keys were not working.

One possibility: Some keyboard mappings (especially European ones) use one or both Alt keys as 'AltGr' (Alternate Graphics). This allows you to type characters like *, ç and ê. That would prevent [ctrl][alt][fn] from working.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
X - Virtual screen too big for memory backrow OpenBSD General 1 4th July 2009 07:22 PM
Networking on virtual machine satimis General software and network 4 29th November 2008 02:16 PM
USB support in virtual machine? Sunnz OpenBSD Packages and Ports 2 16th November 2008 04:00 AM
highly secure virtual machine uptonm OpenBSD Security 26 28th July 2008 10:10 PM
Virtual serial port motorollin Other BSD and UNIX/UNIX-like 7 31st May 2008 01:27 PM


All times are GMT. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick