DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st December 2008
bogd bogd is offline
New User
 
Join Date: Dec 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default temperature readings

Hi

I'm trying to display the temperatures of my laptop's motherboard, cpu1 and cpu2 but I don't understand the output of sysctl hw.sensors:

hw.sensors.acpitz0.temp0=58.05 degC (zone temperature)
hw.sensors.acpitz1.temp0=61.05 degC (zone temperature)
hw.sensors.acpiac0.indicator0=On (power supply)
hw.sensors.kate0.temp0=59.50 degC
hw.sensors.kate0.temp1=59.00 degC
hw.sensors.kate0.temp2=62.50 degC
hw.sensors.kate0.temp3=57.75 degC

which one is which?

thank you and happy new year
Reply With Quote
  #2   (View Single Post)  
Old 1st January 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

While it certainly looks confusing, the related man pages document this information.

Quote:
Originally Posted by kate(4)
Each core may have two temperature sensors, and there may be up to two cores per package.

Multiprocessor systems would have one instance of kate per each chip. In each instance, temp0 and temp1 sensors correspond to the temperature sensors on the first core, whereas temp2 and temp3 correspond to the temperature sensors on the second core. As such, single core chips may have two sensors, and dual-core dual-processor systems may have as many as 8 temperature sensors in total.
As for acpitz{0,1}, that's a little trickier.. they are extracted from ACPI tables, what they represent is a bit unclear; but I presume it's simply acpitz0==cpu0 and acpitz1==cpu1.

Please post a dmesg in [code][/code] blocks, not for any specific reason.. just for my benefit. (I like dmesg's..)

Hope that helps..
Reply With Quote
  #3   (View Single Post)  
Old 1st January 2009
bogd bogd is offline
New User
 
Join Date: Dec 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default

Hi BSDfan666

Thank you. I'm new to BSD and I'm not used to look into the manual pages for obscure stuff like this.

Code:
OpenBSD 4.4 (GENERIC.MP) #1812: Tue Aug 12 17:22:53 MDT 2008
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 3341381632 (3186MB)
avail mem = 3241144320 (3090MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.4 @ 0xdc010 (27 entries)
bios0: vendor Hewlett-Packard version "F.21" date 02/28/2008
bios0: Hewlett-Packard HP Pavilion dv2700 Notebook PC
acpi0 at bios0: rev 3
acpi0: tables DSDT FACP SLIC WDAT SRAT MCFG HPET APIC BOOT SSDT
acpi0: wakeup devices LID0(S3) SLPB(S3) MAC0(S5) P2P0(S5) MCEB(S4) DVDB(S4) QPWB
(S4) PICB(S4) VDOB(S4) LTVB(S4) MUSB(S4) KBD0(S3) PS2M(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 25000000 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD Turion(tm) 64 X2 TL-60, 2000.53 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CF
LUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 1
6-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: apic clock running at 200MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD Turion(tm) 64 X2 TL-60, 2000.19 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CF
LUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 1
6-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu1: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
ioapic0 at mainbus0 apid 2 pa 0xfec00000, version 11, 24 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (P2P0)
acpiprt2 at acpi0: bus 255 (XVR0)
acpiprt3 at acpi0: bus 6 (XVR1)
acpiprt4 at acpi0: bus 4 (XVR2)
acpiec0 at acpi0
acpitz0 at acpi0: critical temperature 120 degC
acpitz1 at acpi0: critical temperature 120 degC
acpicpu0 at acpi0: PSS
acpicpu1 at acpi0: PSS
acpibtn0 at acpi0: LID0
acpibtn1 at acpi0: SLPB
acpibtn2 at acpi0: PWRB
acpibat0 at acpi0: BAT0 not present
acpiac0 at acpi0: AC unit online
acpivideo at acpi0 not configured
cpu0: PowerNow! K8 2000 MHz: speeds: 2000 1800 1600 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1
"NVIDIA MCP67 Memory" rev 0xa2 at pci0 dev 0 function 0 not configured
pcib0 at pci0 dev 1 function 0 "NVIDIA MCP67 Host" rev 0xa2
nviic0 at pci0 dev 1 function 1 "NVIDIA MCP67 SMBus" rev 0xa2
iic0 at nviic0
iic1 at nviic0
spdmem0 at iic1 addr 0x50: 2GB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
spdmem1 at iic1 addr 0x51: 2GB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
"NVIDIA MCP67 Memory" rev 0xa2 at pci0 dev 1 function 2 not configured
vendor "NVIDIA", unknown product 0x0543 (class processor subclass Co-processor, 
rev 0xa2) at pci0 dev 1 function 3 not configured
ohci0 at pci0 dev 2 function 0 "NVIDIA MCP67 USB" rev 0xa2: apic 2 int 11 (irq 1
1), version 1.0, legacy support
ehci0 at pci0 dev 2 function 1 "NVIDIA MCP67 USB" rev 0xa2: apic 2 int 7 (irq 7)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "NVIDIA EHCI root hub" rev 2.00/1.00 addr 1
ohci1 at pci0 dev 4 function 0 "NVIDIA MCP67 USB" rev 0xa2: apic 2 int 10 (irq 1
0), version 1.0, legacy support
ehci1 at pci0 dev 4 function 1 "NVIDIA MCP67 USB" rev 0xa2: apic 2 int 11 (irq 1
1)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "NVIDIA EHCI root hub" rev 2.00/1.00 addr 1
pciide0 at pci0 dev 6 function 0 "NVIDIA MCP67 IDE" rev 0xa1: DMA, channel 0 con
figured to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets, initiator 7
cd0 at scsibus0 targ 0 lun 0: <Slimtype, DVD A DS8A1H, WH66> ATAPI 5/cdrom remov
able
cd0(pciide0:0:0): using PIO mode 4, DMA mode 2
pciide0: channel 1 ignored (disabled)
azalia0 at pci0 dev 7 function 0 "NVIDIA MCP67 HD Audio" rev 0xa1: apic 2 int 10
 (irq 10)
azalia0: codec[s]: Conexant/0x5051
audio0 at azalia0
ppb0 at pci0 dev 8 function 0 "NVIDIA MCP67 PCI" rev 0xa2
pci1 at ppb0 bus 1
"Ricoh 5C832 Firewire" rev 0x05 at pci1 dev 9 function 0 not configured
sdhc0 at pci1 dev 9 function 1 "Ricoh 5C822 SD/MMC" rev 0x22: apic 2 int 10 (irq
 11)
sdmmc0 at sdhc0
"Ricoh 5C843 MMC" rev 0x12 at pci1 dev 9 function 2 not configured
"Ricoh 5C592 Memory Stick" rev 0x12 at pci1 dev 9 function 3 not configured
"Ricoh 5C852 xD" rev 0x12 at pci1 dev 9 function 4 not configured
pciide1 at pci0 dev 9 function 0 "NVIDIA MCP67 SATA" rev 0xa2: DMA
pciide1: using apic 2 int 5 (irq 5) for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <FUJITSU MHY2250BH>
wd0: 16-sector PIO, LBA48, 238475MB, 488397168 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
nfe0 at pci0 dev 10 function 0 "NVIDIA MCP67 LAN" rev 0xa2: apic 2 int 11 (irq 1
1), address 00:1d:72:56:d4:09
eephy0 at nfe0 phy 1: Marvell 88E1118 Gigabit PHY, rev. 0
ppb1 at pci0 dev 12 function 0 "NVIDIA MCP67 PCIE" rev 0xa2
pci2 at ppb1 bus 6
ppb2 at pci0 dev 13 function 0 "NVIDIA MCP67 PCIE" rev 0xa2
pci3 at ppb2 bus 4
"Broadcom BCM4328" rev 0x03 at pci3 dev 0 function 0 not configured
vga1 at pci0 dev 18 function 0 vendor "NVIDIA", unknown product 0x0531 rev 0xa2
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
drm at vga1 unsupported
pchb0 at pci0 dev 24 function 0 "AMD AMD64 0Fh HyperTransport" rev 0x00
pchb1 at pci0 dev 24 function 1 "AMD AMD64 0Fh Address Map" rev 0x00
pchb2 at pci0 dev 24 function 2 "AMD AMD64 0Fh DRAM Cfg" rev 0x00
kate0 at pci0 dev 24 function 3 "AMD AMD64 0Fh Misc Cfg" rev 0x00: core rev BH-G
2
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
usb2 at ohci0: USB revision 1.0
uhub2 at usb2 "NVIDIA OHCI root hub" rev 1.00/1.00 addr 1
usb3 at ohci1: USB revision 1.0
uhub3 at usb3 "NVIDIA OHCI root hub" rev 1.00/1.00 addr 1
mtrr: Pentium Pro MTRR support
uhidev0 at uhub2 port 1 configuration 1 interface 0 "Logitech Optical USB Mouse"
 rev 2.00/3.40 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse1 at ums0 mux 0
uvideo0 at uhub2 port 4 configuration 1 interface 0 "Chicony Electronics Co., Lt
d. HP Webcam" rev 2.00/6.04 addr 3
video0 at uvideo0
softraid0 at root
root on wd0a swap on wd0b dump on wd0b
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sysctl and cpu information and temperature neurosis FreeBSD General 11 22nd October 2008 09:16 PM
Why does smartctl show my temperature threshold is 0? PeterSteele FreeBSD General 0 25th August 2008 03:33 PM


All times are GMT. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick