DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 28th January 2009
Petrocelli08 Petrocelli08 is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Default Bind-9.5

Hi All
Does anyone know how to enable gssapi in bind 9.5? This is what I'm seeing in config.log
configure:6359: checking for GSSAPI library
configure:6385: result: disabled

I've tried --with-gssapi=true in the Makefile but no go.
Reply With Quote
  #2   (View Single Post)  
Old 28th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

I think that command line option needs a path, so something like

--with-gssapi=/some/path

Not sure what it should point to. On my server, I have:

Code:
/usr/include/dst/gssapi.h
/usr/include/gssapi
/usr/include/gssapi/gssapi.h
/usr/include/gssapi.h
/usr/lib/libgssapi.a
/usr/lib/libgssapi.so
/usr/lib/libgssapi.so.9
/usr/lib/libgssapi_krb5.a
/usr/lib/libgssapi_krb5.so
/usr/lib/libgssapi_krb5.so.9
/usr/lib/libgssapi_krb5_p.a
/usr/lib/libgssapi_p.a
/usr/local/lib/compat/libgssapi.so.7
So whether it's /usr/include or /usr/include/gssapi or /usr/lib or /usr/local/lib .. don't know.
Reply With Quote
  #3   (View Single Post)  
Old 28th January 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

--with-gssapi=/usr perhaps?
Reply With Quote
  #4   (View Single Post)  
Old 28th January 2009
Petrocelli08 Petrocelli08 is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Default

Well this is my second day of searching. I've searched google, been on the bind forums and no go so far. I'm going to try an earlier suggestion here though and see. Thanks so far.
Reply With Quote
  #5   (View Single Post)  
Old 28th January 2009
Petrocelli08 Petrocelli08 is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Unhappy

The files are in /usr/include so I used --with-gssapi=/usr/include as a configure argument in the Makefile for bind-9.5 and compiled, but still seeing the message below in config.log.

configure:6359: checking for GSSAPI library
configure:6385: result: disabled

I'm soo stumped.
Reply With Quote
  #6   (View Single Post)  
Old 28th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Try --with-gssapi=/usr as suggested earlier, and also referenced here:
https://lists.isc.org/pipermail/bind...er/074311.html
Reply With Quote
  #7   (View Single Post)  
Old 29th January 2009
Petrocelli08 Petrocelli08 is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Default

Tried that but same error. I'm going to try the tar file on the bind site instead of the BSD one in ports and see what happens
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help secure old BIND on FreeBSD 5.4 andrewk FreeBSD Security 2 22nd July 2008 08:12 PM
squid bind problem samile Other BSD and UNIX/UNIX-like 0 11th July 2008 02:13 PM
BIND as secondary for Windows DNS? cwhitmore FreeBSD Installation and Upgrading 7 16th May 2008 01:13 PM


All times are GMT. The time now is 02:35 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick