DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default perl 5.8.9 install problem

Hello,

I had perl 5.8.8 and i think also 5.8.9 installed. And I installed and deinstall some ports, and suddenly they stop working (ports that depend on perl5.8.8 i think). It has probably something to changing with /etc/make.conf and changing the port perl5.8.9.

Anyway, when I try to make install clean (tried also make deinstall first) in /usr/ports/lang/perl5.8 , I get the following error:
Code:
Extracting defsubs.h...
../../miniperl "-I../../lib" "-I../../lib" ../../lib/ExtUtils/xsubpp  -typemap ../../lib/ExtUtils/typemap -typemap typemap  B.xs > B.xsc && mv B.xsc B.c
cc -c    -DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.9/BSDPAN" -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include -O2 -fno-strict-aliasing -pipe    -DVERSION=\"1.19\"  -DXS_VERSION=\"1.19\" -DPIC -fPIC "-I../.."   B.c
Running Mkbootstrap for B ()
chmod 644 B.bs
rm -f ../../lib/auto/B/B.so
cc  -shared  -L/usr/local/lib B.o  -o ../../lib/auto/B/B.so
chmod 755 ../../lib/auto/B/B.so
cp B.bs ../../lib/auto/B/B.bs
chmod 644 ../../lib/auto/B/B.bs
make: cannot open Makefile.
*** Error code 2

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/B.
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
tried pkgdb -F, I tried portupgrade -ra , etc. didn't work.
I need some clamav and spamassassing packages that depend on some p5* packages that depend on perl.

Can you please give me a clue ?

Thank you
Stefan
Reply With Quote
  #2   (View Single Post)  
Old 30th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Why don't you read /usr/ports/UPDATING like you're supposed to?
Reply With Quote
  #3   (View Single Post)  
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default

I didn't know about that file, thanks. Anyway, I read what said about perl5.8.9
I ran: portupgrade -o lang/perl5.8 -f perl-5.6.1_15
and then
portupgrade -f p5-\*
...
and now it tries infinitely to install p5 packages, and then perl5.8.9 and gets the same error.
I broke something, but I can't figure how to repair.
Reply With Quote
  #4   (View Single Post)  
Old 30th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Don't be afraid of pkgdb -F and/or portsdb -Fu. What does pkg_info | grep -i ^perl come up with? If you see more than perl-5.8.9 installed, pkg_delete -f the competition. If problems keep popping up, try something more drastic like portupgrade -rf perl-5.8.9.
Reply With Quote
  #5   (View Single Post)  
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default perl

pkg_info grep perl gave me perl5.6.2.2. i deleted i tried all commands provided by you. same error
thanks.
Reply With Quote
  #6   (View Single Post)  
Old 30th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Well, as a last resort, try pkg_add -r perl-5.8.9 and then portupgrade -rf perl-5.8.9. This should replace the package with the port, and rebuild all that depends on it.
Reply With Quote
  #7   (View Single Post)  
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default

I only used ports.... and tried to use only ports, but I don't know if it's good or not to use also packages...
Anyway, I tried pkg_add -r perl-5.8.9 and I got
Quote:
Error: FTP Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/po...erl-5.8.9.tbz: File unavailable (e.g., file not found, no access)
pkg_add: unable to fetch 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-7.0-release/Latest/perl-5.8.9.tbz' by URL
so... what can I do ?
Reply With Quote
  #8   (View Single Post)  
Old 30th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Using ports and packages together is not a problem, and you can upgrade a package to a port with portupgrade without a problem. Unfortunately, you're stuck on 7.0-RELEASE, so no newer Perl package will be available. I have no idea what's wrong with your Perl environment. You could try rm /var/db/portsnap/tag && portsnap fetch extract to start with a fresh ports tree.
Reply With Quote
  #9   (View Single Post)  
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default

im doing it now.
please tell me, where can I read more about ports, packages and other freebsd/unix stuff.... in an organized manner... like a book, a course or a larger tutorial... from simple stuff to more complex... with full details ?
Reply With Quote
Old 30th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Quote:
Originally Posted by softexp23 View Post
im doing it now.
please tell me, where can I read more about ports, packages and other freebsd/unix stuff.... in an organized manner... like a book, a course or a larger tutorial... from simple stuff to more complex... with full details ?
The definitive handbook: http://www.freebsd.org/doc/en_US.ISO...ooks/handbook/
Ports & Packages: http://www.freebsd.org/doc/en_US.ISO...ook/ports.html
Reply With Quote
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default

done:
rm /var/db/portsnap/tag
and then
portsnap fetch extract
.... it updated the ports tree:
then
cd /usr/ports/lang/perl5.8
make clean install.... and the same:

Running Mkbootstrap for B ()
chmod 644 B.bs
rm -f ../../lib/auto/B/B.so
cc -shared -L/usr/local/lib B.o -o ../../lib/auto/B/B.so
chmod 755 ../../lib/auto/B/B.so
cp B.bs ../../lib/auto/B/B.bs
chmod 644 ../../lib/auto/B/B.bs
make: cannot open Makefile.
*** Error code 2

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/B.
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
Reply With Quote
Old 30th January 2009
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Quote:
Originally Posted by softexp23 View Post
B.bs
make: cannot open Makefile.
*** Error code 2

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/B.
I have no idea why your /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/B/Makefile keeps disappearing. Do you have anything weird in /etc/make.conf?
Reply With Quote
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default

I have nothing in /etc/make.conf
I tried to install perl5.6.2 it works, but is not new enough for some ports I need.
How can I install 5.8.8 ? Maybe that will work ... or other 5.8.... version ?
Reply With Quote
Old 30th January 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default

Or, how can I debug this problem ? What would a unix guru do ? I am stucked here for several days...
Reply With Quote
Old 1st February 2009
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,074
Thanked 198 Times in 156 Posts
Default

Try:

Code:
# pkg_delete -f perl\* p5-\*
# cd /usr/ports/lang/perl5.8
# make clean distclean build install
# rehash (If you're running tcsh)
# perl-after-upgrade
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Old 8th February 2009
softexp23 softexp23 is offline
New User
 
Join Date: Jan 2009
Posts: 9
Thanked 0 Times in 0 Posts
Default same problem

Hello,
I ran the commands you said (until rehash).
I got the same:
Running Mkbootstrap for B ()
chmod 644 B.bs
rm -f ../../lib/auto/B/B.so
cc -shared -L/usr/local/lib B.o -o ../../lib/auto/B/B.so
chmod 755 ../../lib/auto/B/B.so
cp B.bs ../../lib/auto/B/B.bs
chmod 644 ../../lib/auto/B/B.bs
make: cannot open Makefile.
*** Error code 2

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/B.
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
Reply With Quote
Old 9th February 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Which OPTIONS are you using? Please post the output of: $ cd /usr/ports/lang/perl5.8 && make showconfig
Reply With Quote
Old 9th February 2009
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

To remempasise part of Carpetsmokers post:
Quote:

20090113:
AFFECTS: users of lang/perl5.8
AUTHOR: skv@FreeBSD.org

lang/perl5.8 has been updated to 5.8.9. You should update everything
depending on perl. The easiest way to do that is to use
perl-after-upgrade script supplied with lang/perl5.8. Please see
its manual page for details.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
perl module install issues drievisjen OpenBSD Installation and Upgrading 2 3rd September 2009 10:55 PM
Problem setting up perl modules badguy OpenBSD Installation and Upgrading 4 10th August 2009 09:46 PM
perl/tk bsdnewbie999 OpenBSD Packages and Ports 4 8th August 2008 12:34 AM
Perl Script c0mrade Programming 1 26th June 2008 05:04 AM
Problem at the install with a pc gateway mastersabin FreeBSD Installation and Upgrading 1 4th June 2008 07:47 PM


All times are GMT. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick