DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th April 2009
sniper007's Avatar
sniper007 sniper007 is offline
Real Name: Jurif
Fdisk Soldier
 
Join Date: Jun 2008
Location: Slovenia
Posts: 50
Thanked 0 Times in 0 Posts
Default Xorg + Xfce4 resolution problem

Hi!

When i set in xorg.conf resolution 1280x1024 displey don't show whole desktop. 1280x1024 is native resolution for my LCD Prestigion P171.

It look like




If i set resolution 1024x768 then show whole desktob but fonts and panel beacome blur (not clear).

Using Xorg 7.4_1 and Xfce 4.6.0

Here is my xorg.conf

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection


Section "Files"
	ModulePath   "/usr/local/lib/xorg/modules"
	FontPath     "/usr/local/lib/X11/fonts/misc/"
	FontPath     "/usr/local/lib/X11/fonts/TTF/"
	FontPath     "/usr/local/lib/X11/fonts/OTF"
	FontPath     "/usr/local/lib/X11/fonts/Type1/"
	FontPath     "/usr/local/lib/X11/fonts/100dpi/"
	FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
	Load  "extmod"
	Load  "record"
	Load  "dbe"
	Load  "glx"
	Load  "dri"
	Load  "dri2"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/sysmouse"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	#DisplaySize	  330   270	# mm
	Identifier   "Monitor0"
	VendorName   "ASB"
	ModelName    " P171"
        HorizSync    31.5 - 80.0
        VertRefresh  60.0 - 60.0
	Option	    "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
        #Option     "DualHead"           	# [<bool>]
	Identifier  "Card0"
	Driver      "nv"
	VendorName  "nVidia Corporation"
	BoardName   "NV11 [GeForce2 MX/MX 400]"
	BusID       "PCI:1:0:0"
EndSection


Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
#        SubSection "Display"
#                Viewport   0 0
#                Depth     1
#		 Modes     "1280x1024"
#        EndSubSection
#        SubSection "Display"
#                Viewport   0 0
#                Depth     4
#		 Modes     "1280x1024"
#        EndSubSection
#        SubSection "Display"
#                Viewport   0 0
#                Depth     8
#		 Modes     "1280x1024"
#        EndSubSection
#        SubSection "Display"
#                Viewport   0 0
#                Depth     15
#		Modes     "1280x1024"
#        EndSubSection
#        SubSection "Display"
#                Viewport   0 0
#                Depth     16
#		Modes     "1280x1024"
#        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
		Modes     "1280x1024"
        EndSubSection
EndSection


Thanks for any advice



Note: at 1280x1024 fonts are clear!
__________________
If anything can go wrong, it will. If it can't, it will anyway
Reply With Quote
  #2   (View Single Post)  
Old 19th April 2009
fbsduser fbsduser is offline
Shell Scout
 
Join Date: Aug 2008
Posts: 107
Thanked 4 Times in 4 Posts
Default

Maybe you can try moving it with the front panel controls in the monitor itself.
Reply With Quote
  #3   (View Single Post)  
Old 19th April 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

fbsduser is probably right, you can see the brightness on the right side of the screen.. you might need to manually tweak the display settings.

Also, I would remove the HorizSync/VertRefresh lines.. let Xorg get the display settings itself.
Reply With Quote
  #4   (View Single Post)  
Old 19th April 2009
ephemera's Avatar
ephemera ephemera is offline
Knuth's homeboy
 
Join Date: Apr 2008
Posts: 537
Thanked 49 Times in 43 Posts
Default

you can try using xvidtune to move the image left, but the photo it looks like the horz. align. is pretty screwed so it may or may not work.
you might want to your xorg.conf settings. start by removing the horz. and vert. refresh rates as already suggested and using 24 bit colour (Depth).
Reply With Quote
  #5   (View Single Post)  
Old 30th April 2009
tangram's Avatar
tangram tangram is offline
Real Name: Ricardo Jesus
Port Guard
 
Join Date: May 2008
Location: Portugal
Posts: 36
Thanked 2 Times in 2 Posts
Default

Judging from the picture it sure does look like you've messed with the physical monitor setting.

Anyways check the output of /var/log/Xorg.0.log as it provides loads od precious info for troubleshooting.
__________________
BSD and Linux tips and tutorials: Blog Linux/BSD: sharing experiences
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution problem.. PCBSD3000 FreeBSD General 5 13th April 2009 07:56 PM
4.4 on macmini ppc xorg problem gosha OpenBSD Installation and Upgrading 27 14th February 2009 10:06 PM
Console Resolution Problem kienjakenobi FreeBSD General 19 12th September 2008 12:20 PM
Xfce4 and desktop update [gamin problem] daemonFromHeaven FreeBSD Ports and Packages 7 7th September 2008 08:20 AM
Xorg very slow (problem with DRI?) Hihihi OpenBSD General 6 18th July 2008 06:21 PM


All times are GMT. The time now is 04:16 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick