DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Package System (pkgsrc)

NetBSD Package System (pkgsrc) Installation and upgrading of packages on NetBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st October 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 612
Thanked 9 Times in 9 Posts
Default KDE4 Modular Xorg 1.6 starting KDE4

I have a working twm without hal. My xorg.conf was copied from the successful /var/log/Xorg.0.log.

I appeared to have a successful install of KDE4 from nyftp binaries of pkgsrc_2009Q3 - I did not watch the whole install but it completed without trailing errror messages.

What my problem is that startkde does not complete kdeinit. I see an error message in X about libXcursor.so.1 missing.

I have rpcbind, dbus and famd starting in rc.conf and tried hal (hal just locked up twm). The mouse works fine in twm.

Ideally, I would like to boot to kdm. I have found FreeBSD instructions for kdm4 but nothing for NetBSD. Anyone done this?
Reply With Quote
  #2   (View Single Post)  
Old 1st November 2009
Pjoter's Avatar
Pjoter Pjoter is offline
Shell Scout
 
Join Date: Sep 2008
Posts: 92
Thanked 7 Times in 7 Posts
Default

Hi,

which version of NetBSD do you have? I managed to run KDE4 but I compiled that myself some time ago- and I use Xorg from pkgsrc. I am worried I cannot help you too much.

Piotr.
Reply With Quote
  #3   (View Single Post)  
Old 1st November 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 612
Thanked 9 Times in 9 Posts
Default

Thanks for the reply.

I'm running 5.0.1 i386.

I've done a little more looking and wonder if I need xf86-video-evdev for Xorg 1.6 /hal? It seems to be needed in Linux.

It will be a day or so before I get back to the machine. I'll report back if the problem was evdev.
Reply With Quote
  #4   (View Single Post)  
Old 1st November 2009
Pjoter's Avatar
Pjoter Pjoter is offline
Shell Scout
 
Join Date: Sep 2008
Posts: 92
Thanked 7 Times in 7 Posts
Default

Hi,

ok- keep posted. I think we do not have *-eved
Reply With Quote
  #5   (View Single Post)  
Old 16th November 2009
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 612
Thanked 9 Times in 9 Posts
Default

Therer is not an xf86-video-evdev package in NetBSD and it not needed. The mouse/keyboard works fine with hal and dbus in 5.0.1.

The KDE4 desktop did not work that well so I reinstalled xfce4-4.6.1 which works great.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kde4 bsdnewbie999 OpenBSD General 3 19th March 2009 06:01 PM
KDE4 buildind... lumiwa FreeBSD Ports and Packages 11 27th October 2008 05:18 AM
KDE4 uses a lot of memory... mdh FreeBSD General 6 21st October 2008 06:21 AM
How do I start kde4? PatrickBaer FreeBSD General 5 26th September 2008 08:18 PM
Kde4 & other help needed.. Mr-Biscuit FreeBSD General 4 21st September 2008 05:40 PM


All times are GMT. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick