DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5th June 2010
trombel trombel is offline
New User
 
Join Date: Jan 2009
Posts: 5
Thanked 0 Times in 0 Posts
Default Samsung syncmaster 933sn xorg.conf

Would anyone be kind enough to post a working xorg.conf file for a Samsung syncmaster 933SN. My s3 savage ix/mx video card does not work in freebsd 8.0.
I intend to use my spare Samsung video instead.
Reply With Quote
  #2   (View Single Post)  
Old 5th June 2010
Beastie Beastie is offline
Daemonology student
 
Join Date: Jan 2009
Location: /dev/earth0
Posts: 270
Thanked 23 Times in 23 Posts
Default

What is the link between a monitor and a video card? Adding monitor-related settings in xorg.conf will not replace a failing video card driver.

If you get your driver to work, use these settings:
Code:
Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    DefaultDepth  24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes   "1920x1080"
    EndSubSection
EndSection
I got the Modes from here. Change it if it's wrong.

If the driver doesn't work, you may want to install the vesa driver and use Driver "vesa" instead of the S3 driver.
__________________
May the source be with you!
Reply With Quote
  #3   (View Single Post)  
Old 6th June 2010
trombel trombel is offline
New User
 
Join Date: Jan 2009
Posts: 5
Thanked 0 Times in 0 Posts
Default Samsung syncmaster 933sn xorg.conf

As a matter of fact, everytime a tried the command Xorg -configure, the driver used in xorg.conf.new is always vesa, not s3.
My video card does not support 1920x1080 resolution. It has only 8Mb.
I substituted vesa for s3. I changed the Hsync and Vrefresh for both drivers.
When you try the command Xorg -configure and then Xorg -config xorg.conf.new, I get a nicely configured screen, but when I copy the xorg.conf.new to /etc/xorg.conf, X will not startx. "illegal extended x86 opcode!" error appears. I searched in several sites and forums unsuccessfully for an answer to solve this kind of error.
As to " Adding monitor-related settings in xorg.conf will not replace a failing video card driver.", you are right.
Reply With Quote
  #4   (View Single Post)  
Old 6th June 2010
Beastie Beastie is offline
Daemonology student
 
Join Date: Jan 2009
Location: /dev/earth0
Posts: 270
Thanked 23 Times in 23 Posts
Default

Is the S3 driver installed for sure?

I don't know if it's a typo, but xorg.conf should be in /etc/X11/xorg.conf.
__________________
May the source be with you!
Reply With Quote
  #5   (View Single Post)  
Old 6th June 2010
trombel trombel is offline
New User
 
Join Date: Jan 2009
Posts: 5
Thanked 0 Times in 0 Posts
Default Sansung syncmaster 933sn xorg.conf

Yes, it was a typo. I copied the file to /etc/X11/xorg.conf.
I am not sure that the s3 driver is loaded. I tried the command kldload s3 and went to loader.conf and added: load_s3="YES" and rebooted.
I removed the xorg.conf.new file and tried again Xorg -configure.
A message appeared: list of drivers: ati, radeon, intel,mach64,nv,openchrome,r128,radeonhd, vesa.
When you type kldstat, the s3 driver is not present (not loaded). I installed the xorg drivers using the sysinstall utility. I thought all the drivers would be present in my system. I think I am wrong. Should I go to /usr/ports/x11-drivers and do a make install clean? Is it xf86 or a xorg port anyway? Or should I remove xorg using sysinstall before proceeeding? How many doubts!!
The error " illegal extended x86 opcode!" keeps on showing.
Thanks for your help.
Reply With Quote
  #6   (View Single Post)  
Old 6th June 2010
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,080
Thanked 198 Times in 156 Posts
Default

Quote:
I don't know if it's a typo, but xorg.conf should be in /etc/X11/xorg.conf.
It doesn't matter, both /etc/xorg.conf and /etc/X11/xorg.conf will work.

Quote:
I am not sure that the s3 driver is loaded. I tried the command kldload s3 and went to loader.conf and added: load_s3="YES" and rebooted.
You don't need to load a kernel module for the s3 driver, but you will need to install the Xorg driver:
x11-drivers/xf86-video-s3
x11-drivers/xf86-video-s3virge

You didn't mention which card you have, you can find which card is supported by which driver in their manpages:
s3(4)
s3virge(4)
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #7   (View Single Post)  
Old 7th June 2010
trombel trombel is offline
New User
 
Join Date: Jan 2009
Posts: 5
Thanked 0 Times in 0 Posts
Default Samsung syncmaster 933sn xorg.conf

My video card is a s3 savage/IX-MX 6c270-294. The correct driver is in xf86-video-savage.
I installed this driver and when you do X -configure, the resulting xorg.conf.new recognizes my video card and uses the savage driver. But I still have a problem. When I try Xorg -config xorg.conf.new, an error occurs: "Insufficient Videoram available for 3d -- Try a lower depth or smaller desktop." And still another error: " DRI isn't enabled."
I do not know how to disable 3d . I am not interested in 3d . Besides my video card has only 8 Mb. Any ideas?
Reply With Quote
  #8   (View Single Post)  
Old 7th June 2010
Beastie Beastie is offline
Daemonology student
 
Join Date: Jan 2009
Location: /dev/earth0
Posts: 270
Thanked 23 Times in 23 Posts
Default

You probably should load the dri/2 module(s).
Code:
Section "Module"
    [...]
    Load  "dri"
    Load  "dri2"
    [...]
EndSection
And then, in the graphic card Device section, you may have to enable DRI:
Code:
Section "Device"
    [...]
    Option "DRI" "TRUE"
    Driver "S3????"
    [...]
EndSection
__________________
May the source be with you!
Reply With Quote
  #9   (View Single Post)  
Old 8th June 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

The S3's "Savage" family is indeed a different driver, I have a system with a 32MB PCI Savage4 card.

Getting mode-setting to work requires the UseBIOS option to be disabled, this will allow the card to set a mode as indicated by DDC/EDID information from your monitor.

So, generate an xorg.conf file using Xorg -configure, copy said file to /etc/{X11,}/xorg.conf and add Option "UseBIOS" "false" to the Device section.

Good luck.
Reply With Quote
Old 8th June 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Read the manual page, a list of valid driver options are typically placed into generated xorg.conf files, disabling DRI is an option, but it should be done automatically.. it's not a fatal error.
Reply With Quote
Old 8th June 2010
trombel trombel is offline
New User
 
Join Date: Jan 2009
Posts: 5
Thanked 0 Times in 0 Posts
Default Samsung syncmaster 933sn xorg.conf

BSDfan666, I tried your suggestions with no luck. The same errors do appear. I know that the error "DRI ins't enabled" is not important. Anyway, I just can get my video card to work.
I can get, after an X -configure and a Xorg -config xorg.conf.new, a fine X screen.
But when I copy this file to /etc/X11/xorg.conf and try with the commnad X ( I type X because when I type startx the system says : Command not found ( I don't know why), I cannot get a valid screen configuration. I will keep trying anyway. Thanks for your help.
Reply With Quote
Old 8th June 2010
Beastie Beastie is offline
Daemonology student
 
Join Date: Jan 2009
Location: /dev/earth0
Posts: 270
Thanked 23 Times in 23 Posts
Default

Try % xinit.
__________________
May the source be with you!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf overriden? delboy FreeBSD General 4 3rd February 2010 10:37 AM
NetBSD on Samsung 2410.... nmohture NetBSD General 1 23rd July 2009 11:08 AM
Xorg & i810 graphics / loader.conf / kldstat OgreNaut FreeBSD Installation and Upgrading 26 7th November 2008 02:27 PM
Generate xorg.conf.new and black screen aleunix OpenBSD Packages and Ports 2 4th June 2008 10:49 AM
Xorg.conf w/Matrox g550 agp WeakSauceIII OpenBSD General 4 20th May 2008 08:27 AM


All times are GMT. The time now is 12:24 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick