DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 30th August 2010
map7 map7 is offline
Fdisk Soldier
 
Join Date: Jun 2008
Posts: 75
Thanked 3 Times in 3 Posts
Default libstdc++.so.6 not found

I'm using FreeBSD 7.0 p6 and recently my fluxbox has stopped working. I get the error in my .xessions-errors file as follows:

Code:
(process:15499): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
/usr/local/etc/gdm/Xsession: Beginning session setup...
/usr/local/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- startfluxbox
/libexec/ld-elf.so.1: /usr/local/lib/compat/pkg/libstdc++.so.6: version GLIBCXX_3.4.9 required by /usr/local/bin/fbsetroot not found
/usr/local/bin/view_cam:8: warning: Insecure world writable dir /usr/sbin in PATH, mode 040777
Couldn't resolve name for AF_INET6: proxy
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
Shared memory error,disabling ( seg id error )
Shared memory error,disabling ( seg id error )
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
/libexec/ld-elf.so.1: /usr/local/lib/compat/pkg/libstdc++.so.6: version GLIBCXX_3.4.9 required by /usr/local/bin/fluxbox not found
Which package do I need to reinstall to get libstdc++.so.6?
Reply With Quote
  #2   (View Single Post)  
Old 30th August 2010
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,064
Thanked 198 Times in 156 Posts
Default

Right now the system is trying to use:
Quote:
/usr/local/lib/compat/pkg/libstdc++.so.6
Which is in the compat directory, this is for legacy libraries to run binaries fro previous releases (FreeBSD 5, 4, etc.).
Maybe the original went missing?

Quote:
Which package do I need to reinstall to get libstdc++.so.6?
It's part of the FreeBSD OS, you don't install it with a package.

Also take note of:
Quote:
warning: Insecure world writable dir /usr/sbin in PATH, mode 040777

Is this the same machine that crashed and the save-entropy problems? If so, there seem to be some filesystem issues.
I would:
- fsck all filesystems.
- Use smartmontools to make sure the disks are fine.
- If there are still problems, reinstall the FreeBSD base and packages to make sure any missing files are reinstalled. (You can use pkg_info -g, see pkg_info(1)).
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wd0 not found at install shep OpenBSD Installation and Upgrading 8 15th June 2010 02:41 AM
mk.conf not found mtm0 NetBSD Package System (pkgsrc) 2 4th September 2009 04:42 PM
kernel not found isamu FreeBSD Installation and Upgrading 13 24th October 2008 12:24 AM
I finally found it!!! crayoxide FreeBSD General 8 23rd July 2008 05:41 AM
pkg-get command not found whispersGhost Solaris 2 11th June 2008 01:06 PM


All times are GMT. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick