DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default Intalling Samba On OpenBSD

Im trying to install samba on my openbsd box.

I copied the latest samba from
http://mirrors.24-7-solutions.net/pu...ba-3.5.4p3.tgz

then copied it to a flash drive and moved it to /usr/ports/samba

then I tried a pkg_add samba-3.5.4p3.tgz and i get 'Can't find samba-3.5.4p3.tgz'

I did a ls -l and it is there.


So then I tried a make install and got 'make: don't know how to make install. Stop in /usr/ports/samba.'

What am i doing wrong?

Sorry for the noob questions, im learning. Thanks in advance for the help.
Reply With Quote
  #2   (View Single Post)  
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
I copied the latest samba from
http://mirrors.24-7-solutions.net/pu...ba-3.5.4p3.tgz

then copied it to a flash drive and moved it to /usr/ports/samba
You have not specified which version of OpenBSD you have installed. If you are using the Samba package for OpenBSD 4.8, you must be running OpenBSD 4.8 -release or -stable.

There is also no need to do all this work. Just set PKG_PATH as described in Section 15.2.2 of the FAQ.

Studying all of Section 15 will save you significant aggravation (both currently & in the future...).
Reply With Quote
  #3   (View Single Post)  
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ocicat View Post
You have not specified which version of OpenBSD you have installed. If you are using the Samba package for OpenBSD 4.8, you must be running OpenBSD 4.8 -release or -stable.

There is also no need to do all this work. Just set PKG_PATH as described in Section 15.2.2 of the FAQ.

Studying all of Section 15 will save you significant aggravation (both currently & in the future...).
i installed http://mirrors.24-7-solutions.net/pu.../install48.iso

im not sure if thats release/stable.

ill read the section now
Reply With Quote
  #4   (View Single Post)  
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
im not sure if thats release/stable.
The ISO specified is for -release. The distinction between OpenBSD's flavors, -release, -stable, & -current, is discussed in Section 5.1 of the FAQ.

This also is information every OpenBSD user should understand.
Reply With Quote
  #5   (View Single Post)  
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

i typed
"export PKG_PATH=/mnt/cdrom/4.8/packages/`machine -a`/"
pkg_add samba-3.5.4p3.tgz

and it tells me
--- samba-3.5.4.p3 --------------
Can't install samba-3.5.4p3: not found
Reply With Quote
  #6   (View Single Post)  
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
Can't install samba-3.5.4p3: not found
Is the file found on the specified path?

You can also point PKG_PATH to any mirror.
Reply With Quote
  #7   (View Single Post)  
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

i dont see samba any where on that iso image i burned

im looking at /mnt/4.8/i386 and its just the base install files
Reply With Quote
  #8   (View Single Post)  
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

i already have the samba-3.5.4p3.tgz
any idea why it tells me that samba-3.5.4p3.tgz does not exist when i try to run pkg_add?

do i need to do a changemod on the file? im logged in as root
Reply With Quote
  #9   (View Single Post)  
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
any idea why it tells me that samba-3.5.4p3.tgz does not exist when i try to run pkg_add?
pkg_add(1) requires the pathname to the package. If the package is not on the path specified, pkg_add will balk.

pkg_add will also balk if the file is not in the expected format. If you downloaded the package, did you specify binary transfer?
Reply With Quote
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

i got it to install but now im getting errors that says it cant find the following files
popt-1.7p1
tbd-1.2.1
libtalloc-2.0.1
libexecinfo-1.1p2
libiconv-1.13p1

Last edited by EverydayDiesel; 14th November 2010 at 08:31 AM.
Reply With Quote
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
i downloaded the file...
If you downloaded via ftp(1), you must specify binary transfer. If you didn't, anything resembling a newline will be incorrectly modified.

Compare the file size to that on the mirror used.
Reply With Quote
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
i got it to install but now im getting errors that says it cant find the following files
popt-1.7p1
tbd-1.2.1
libtalloc-2.0.1
libexecinfo-1.1p2
libiconv-1.13p1
This is not surprising as pkg_add(1) is trying to install dependencies from the information it was given, & the path supplied only contains a single package (given the limited information provided...).

If you change PKG_PATH as specified in Section 15 to point to a mirror, it will find all related dependencies.
Reply With Quote
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

during system installation i told that i didnt want to run X windows
according to part 15 this would be the reason why im getting the lib not found errors?
Reply With Quote
Old 14th November 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,831
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by EverydayDiesel View Post
...according to part 15 this would be the reason why im getting the lib not found errors?
No. Samba does not have any dependencies on X:
Code:
$ cd /usr/ports/net/samba
$ make print-run-depends
This port requires package(s) "libtalloc-2.0.1 libiconv-1.13p1 tdb-1.2.1 popt-1.7p1 libexecinfo-1.1p2" to run.
$
The above -current output can only be duplicated if the ports tree is installed. Since most users should be installing packages directly, there is little reason to install the ports tree. I simply provide this output to show Samba's dependencies.

More information can be found on the ports(7) manpage.
Reply With Quote
Old 14th November 2010
EverydayDiesel EverydayDiesel is offline
Fdisk Soldier
 
Join Date: Jan 2009
Posts: 67
Thanked 0 Times in 0 Posts
Default

cool, i finally got it by downloading all of those files on the usb drive.

i cannot thank you enough for all your patients and help!
Reply With Quote
Old 14th November 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,429
Thanked 214 Times in 189 Posts
Default

Save yourself some time, trouble, effort, and confusion.

Read the FAQ. Live the FAQ. Be the FAQ.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ACL, Samba ACL, FTP acl da1 FreeBSD General 3 3rd April 2009 10:14 PM
samba and OpenBSD 4.4 mfaridi OpenBSD Packages and Ports 5 24th November 2008 09:46 PM
Samba + acl bichumo General software and network 0 30th June 2008 09:49 AM
samba problem sniper007 FreeBSD Ports and Packages 3 22nd June 2008 05:59 PM
Samba NOT STARTING pcfxer FreeBSD General 11 13th May 2008 09:29 AM


All times are GMT. The time now is 07:26 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick