DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 23rd May 2012
kpedersen kpedersen is offline
Port Guard
 
Join Date: Nov 2009
Posts: 20
Thanked 0 Times in 0 Posts
Default OpenBSD 5.1 Mono Fonts

Hi all,

Has anyone tried out the version of Mono provided by OpenBSD 5.1 (release packages)?

It seems that the fonts are broken when using System.Windows.Forms. For example, the window needs to be moved around or the text selected to make the text visible. Also, when I select the text, the selection rectangle is the wrong size compared to the text suggesting that the font metrics are also incorrect.

I have tried installing all the font packages I could find but that didn't seem to help. Has anyone else run into this?

Best Regards,

Karsten
Reply With Quote
  #2   (View Single Post)  
Old 23rd May 2012
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,879
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by kpedersen View Post
It seems that the fonts are broken when using System.Windows.Forms.
Not that I know what packages & ports each & every site member uses, but I don't recall anyone mentioning that they use Mono. I would not recommend setting your expectations high about getting a useful answer.

My suggestion would be to contact the port's maintainer as mentioned on OpenPort's lang/mono Webpage.
Reply With Quote
  #3   (View Single Post)  
Old 23rd May 2012
kpedersen kpedersen is offline
Port Guard
 
Join Date: Nov 2009
Posts: 20
Thanked 0 Times in 0 Posts
Default

Fair enough. I thought I should just check if others have experienced similar before contacting the maintainer since robert@ has quite a few ports (including libreoffice and chromium) so I imagine he is quite busy.

Cheers,
Reply With Quote
  #4   (View Single Post)  
Old 25th May 2012
kpedersen kpedersen is offline
Port Guard
 
Join Date: Nov 2009
Posts: 20
Thanked 0 Times in 0 Posts
Default

For the record. I managed to get it working by modifying the libgdiplus port and removing the line

Code:
  --with-pango
This means it is now using the internal "toy" implementation of font rendering which probably isn't ideal in the long term but it is working fine for now.

So it seems that the issue is obviously with libgdiplus rather than mono itself.
Reply With Quote
  #5   (View Single Post)  
Old 10th December 2012
jjennings089 jjennings089 is offline
Port Guard
 
Join Date: Mar 2012
Posts: 12
Thanked 0 Times in 0 Posts
Default

Has anyone found a better solution to this yet?
Reply With Quote
  #6   (View Single Post)  
Old 10th December 2012
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,879
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by jjennings089 View Post
Has anyone found a better solution to this yet?
I would suggest contacting the port's maintainer.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ten... mono laser printers J65nko News 0 30th October 2011 01:40 AM
Have nice fonts in OpenBSD 4.6 mfaridi OpenBSD General 10 11th April 2010 01:38 PM
Console Fonts JMJ_coder General software and network 6 10th September 2008 09:57 PM
ImageMagick 6.3.6.10 on OpenBSD 4.3 ... ghostscript and fonts... superslot OpenBSD Packages and Ports 9 28th July 2008 09:36 AM
Mono development On FreeBSD roddierod Programming 5 8th May 2008 09:13 PM


All times are GMT. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick