DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 19th July 2008
edhunter's Avatar
edhunter edhunter is offline
Real Name: Georgi Iovchev
Port Guard
 
Join Date: May 2008
Location: Sofia, Bulgaria
Posts: 41
Thanked 0 Times in 0 Posts
Default apache error .. vhosts and access

Hello guys
I have a little problem with apache 2.2

I just added a vhost and i access it corectly with www browser, but I dont understand why everytime i open it I got error logged in httpd-error.log
Code:
[Sat Jul 19 03:53:19 2008] [error] [client ip.add.re.ss] client denied by server configuration: /usr/home/ed/wwwgeo/.htaccess
my httpd.conf is almost default, I have only changed default options -indexes, real servername, listen port ... and such things... no vhosts in main file.
For vhosts I have one file in /usr/local/etc/Includes/. Here it is.
Code:
NameVirtualHost *:88

### <--- main virtual host!

<VirtualHost *:88>
ServerName test.pulsar.bg
    DocumentRoot /usr/local/www/pulsar/
    <Directory /usr/local/www/pulsar/>
        allow from all
        allowoverride all
        ###Options +FollowSymLinks -indexes
    </Directory>
    php_admin_flag register_globals on
    php_admin_flag allow_url_fopen off
    php_flag magic_quotes_gpc on
    php_flag display_errors off
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   !^test.pulsar.bg [NC]
    RewriteCond %{HTTP_HOST}   !^$
    RewriteRule ^/(.*)         http://test.pulsar.bg:88/$1 [L,R]
    LogLevel emerg
#    CustomLog /usr/local/www/log/httpd-pulsar-access.log "combined"
    php_value post_max_size 100M
    php_value upload_max_filesize 100M

    Alias /geo /home/ed/wwwgeo
    <Directory /home/ed/wwwgeo>
        AllowOverride All
        Order Allow,deny
        Allow from all
    </Directory>
</VirtualHost>

#### end of main virtual host! --->

<VirtualHost *:88>
ServerName pulsartest.game-host.org
    DocumentRoot /usr/home/ed/wwwgeo
    <Directory "/usr/home/ed/wwwgeo">
        Allow from all
        AllowOverride All
    </Directory>
</VirtualHost>
here is file that makes wwwgeo "indexable" /usr/home/ed/wwwgeo/.htaccess
Code:
Options +Indexes
Actually when i open in my browser http://pulsartest.game-host.org:88 directory is visible (thats what i want) but error is logged. It is not a big pain but it is annoying.
After a few hours of reading and experimentig I dont see where i am wrong. Need help.
10x in advance
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
error while installing apache Nk2Network OpenBSD Packages and Ports 4 13th April 2009 08:45 PM
Upgrade Apache 1.3 mod_ssl to Apache 2.2 beandip FreeBSD Ports and Packages 11 26th March 2009 09:12 PM
Apache 2.2 + vhosts DNAeon FreeBSD Ports and Packages 12 16th February 2009 06:02 PM
pf allow ftp access ijk FreeBSD Security 9 25th August 2008 04:12 AM
CD Access in KDE Scott FreeBSD General 10 13th May 2008 05:48 AM


All times are GMT. The time now is 05:01 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick