DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd July 2008
Braveheart_BSD Braveheart_BSD is offline
Real Name: William Wallis
New User
 
Join Date: Jul 2008
Location: Melbourne, Au
Posts: 5
Thanked 0 Times in 0 Posts
Default 2 Video Cards, 2 Monitors

Hi Guys

Didn't do to good on the FreeBSD Mailing list with this issue, will see how I go here.

This system has 2 x 8600GT video cards (non sli), from the testing I've done, it appears that FreeBSD will only correctly identify the first video card, the second video card is set as a default VGA.

This info is from pciconf -lv:
Nvidia 8600GT on PCI 1:0:0, Unknown VGA on PCI 2:0:0

When X is run, I get no device instance for PCI 2:0:0, and the corresponding Screen section is discarded.
Xorg log shows the cards being identified as follows:
(--) PCI:*(1:0:0) nVidia Corporation GeForce 8600 GT rev 161, Mem @ 0xd6000000/24, 0xb0000000/28, 0xd4000000/25, I/O @ 0x8000/7, BIOS @ 0xd7000000/17
(--) PCI: (2:0:0) nVidia Corporation unknown chipset (0x0401) rev 161, Mem @ 0xd2000000/24, 0xc0000000/28, 0xd0000000/25, I/O @ 0x9000/7

Only thing in common with the 2 cards is that they both use IRQ 19, would this be the problem ?

Any idea's ?
Is this possible under FreeBSD ? ....... OpenSUSE Live DVD picks up both cards and offers a dual head configuration.

XP just works ....... no problems anywhere

xorg.conf is fine, been running dual heads for years, both cards work fine when used as a single card.

My experience with FreeBSD is fairly good too, been using it since 4.3, home server is a FreeBSD 7.0 system

Any help appreciated.

Thanks

Braveheart
Reply With Quote
  #2   (View Single Post)  
Old 22nd July 2008
roddierod's Avatar
roddierod roddierod is offline
Real Name: Rod Person
VPN Cryptographer
 
Join Date: Apr 2008
Location: Pittsburgh, Pa
Posts: 383
Thanked 13 Times in 13 Posts
Default

Are you using the Nvidia driver or the Xorg driver?

If your using the Nvidia driver did you try running nvidia-settings and see if that displays anything?
__________________
"The basic tool for the manipulation of reality is the manipulation of words. If you can control the meaning of words, you can control the people who must use the words." -Philip K. Dick
Reply With Quote
  #3   (View Single Post)  
Old 23rd July 2008
Braveheart_BSD Braveheart_BSD is offline
Real Name: William Wallis
New User
 
Join Date: Jul 2008
Location: Melbourne, Au
Posts: 5
Thanked 0 Times in 0 Posts
Default 2 Video Cards

Hi

Card is not identified on boot up, not running Xorg when the issue is presented.

When I do run Xorg, it is the latest driver from Nvidia.
Fooled about with using a vga driver on the second card, failed dreadfully, had to restart the thing, and it made a 200 meg Xorg log file.

Nvidia guys (irc.freenode.net) have gone over the relevent files, and suggested a few things (load int10 module, a sysctl boot loader option) all failed

Kind of points to a FreeBSD hardware issue, and it has me beat at this time.

Thanks
Braveheart
Reply With Quote
  #4   (View Single Post)  
Old 23rd July 2008
Braveheart_BSD Braveheart_BSD is offline
Real Name: William Wallis
New User
 
Join Date: Jul 2008
Location: Melbourne, Au
Posts: 5
Thanked 0 Times in 0 Posts
Default Fixed: 2 video Cards, 2 Monitors

Hi Guys

This issue is now rectified ........ works fine.

xorg.conf file was the issue all the time ......... Screen was listed in the device section, not applicable to 2 seperate video cards, only required with a single card as dual head.

Obscure maybe ...... took a while to find .........

Thanks

Braveheart
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
radeonhd with two monitors DraconianTimes Solaris 9 8th February 2009 12:35 AM
OpenBSD and ATI cards h5n1 OpenBSD General 3 29th October 2008 12:46 PM
recommended 802.11a/b/g/n wireless cards hamba General Hardware 3 27th October 2008 07:43 PM
Guide: Atheros ar5007 wifi cards in freebsd7 Dazhelpwiz FreeBSD Installation and Upgrading 3 16th June 2008 02:23 AM
Dual ath cards with WPA2 in hostapd? Malinda FreeBSD Security 4 8th June 2008 08:34 PM


All times are GMT. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick