DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th July 2008
twisted_steel twisted_steel is offline
Port Guard
 
Join Date: May 2008
Posts: 12
Thanked 0 Times in 0 Posts
Default Properly sending dmesg to dmesg@

I recently sent my dmesg to dmesg@ and it looks like I missed part of the FAQ for sending via a different email client . It was text-formatted at least, so I managed to get 1/4 correct. Here are the rules from the FAQ that I missed and would like to fix for the next time:
  • Turn off any forced line break feature. Many email clients are configured to insert line breaks at 72 columns (the norm for mailing lists).
  • Make sure your email client does not reformat messages into "text-flow" nonsense.
  • Do not send the dmesg output as file attachment. Put the dmesg output into the body of the message.
I looked around in my email client's settings (Evolution 2.22.3.1) that I used to send from another box. I can't find any option to remove the breaks at line 72 and even found some post on a mailing list suggesting that this was a hard-coded value that could not be changed. I have no idea what "text-flow" means. Lastly, I did attach the dmesg, which in this case might be better as it was not wrapped. I believe fixing the line wrapping would make adding the dmesg inline work properly.

Is it possible to disable wrapping in Evolution? Can anyone confirm that just sending an email as plain text from Gmail.com works properly? If not, what email client should I be using?
Reply With Quote
  #2   (View Single Post)  
Old 27th July 2008
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,068
Thanked 198 Times in 156 Posts
Default

Did you try mail(1)? You can't get much simpler than that and it's what the FAQ recommends...
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #3   (View Single Post)  
Old 27th July 2008
twisted_steel twisted_steel is offline
Port Guard
 
Join Date: May 2008
Posts: 12
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Carpetsmoker View Post
Did you try mail(1)? You can't get much simpler than that and it's what the FAQ recommends...
I did not because I thought I needed to send it from a working address. Should I just include my email address in the message body and send it from the openbsd box?

The part of the FAQ that prompted me to go this route: "Make sure you send email from an account that is able to also receive email ..."

Last edited by twisted_steel; 27th July 2008 at 01:39 PM.
Reply With Quote
  #4   (View Single Post)  
Old 27th July 2008
twisted_steel twisted_steel is offline
Port Guard
 
Join Date: May 2008
Posts: 12
Thanked 0 Times in 0 Posts
Default

I just tried the other suggested method of sending the email to my other address with "dmesg | mail your-account@yourmail.dom" and it did not work. Yes, I changed the address . It doesn't look like Gmail accepts messages from unroutable boxen.
Reply With Quote
  #5   (View Single Post)  
Old 27th July 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

It does work, but it will not work from a non-root account... it isn't send immediately either, there is a ~6 minute queue period.

Look in /var/log/maillog, you'll see a line right after you send the mail with mail(1), few minutes later it will relay it to your mail account.

Sending the email directly from your OpenBSD box may not be a good idea, send it to that mail account then forward it... but if you absolutely had to, setting a "Reply-To:" header might at least allow the developers to contact you.

Last edited by BSDfan666; 27th July 2008 at 02:09 PM.
Reply With Quote
  #6   (View Single Post)  
Old 27th July 2008
twisted_steel twisted_steel is offline
Port Guard
 
Join Date: May 2008
Posts: 12
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BSDfan666 View Post
It does work, but it will not work from a non-root account... it isn't send immediately either, there is a ~6 minute queue period.

Look in /var/log/maillog, you'll see a line right after you send the mail with mail(1), few minutes later it will relay it to your mail account.

Sending the email directly from your OpenBSD box may not be a good idea, send it to that mail account then forward it... but if you absolutely had to, setting a "Reply-To:" header might at least allow the developers to contact you.
Thanks. I did see the messages sitting in the queue, but it looks like it just had a problem delivering them. Now I at least know what to do for next time.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to: DMESG Monitoring damien-NF FreeBSD Installation and Upgrading 2 4th August 2009 11:30 PM
strange dmesg output gosha OpenBSD General 4 11th March 2009 01:10 PM
ACPI - dmesg lumiwa FreeBSD General 3 10th July 2008 03:55 AM
/etc/rc.* files isn't read properly? mathias OpenBSD General 4 1st June 2008 06:35 PM
CF, as wd0, 4.3 dmesg "DMA error" s2scott OpenBSD Installation and Upgrading 11 10th May 2008 08:21 AM


All times are GMT. The time now is 08:21 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick