DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 2nd August 2008
Kilo1 Kilo1 is offline
New User
 
Join Date: Aug 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default Problem with x11/gnome+libcaca in ports

Hello guys, just installed OpenBSD 4.3 from the CD-ROM today on my laptop, so far everything is going very good except a few hitches which I have tried to sort out, and still trying but this issue leaves me stuck. I have tried to google the answer but didn't find anything that would adress my problem

The problem is when I try to "make install" from x11/gnome in the /usr/ports. This is the output:

Code:
# make install
===> x11/gnome/alacarte
===> x11/gnome/applets2
===> x11/gnome/at-spi
===> x11/gnome/audio
===> x11/gnome/backgrounds
===> x11/gnome/build
===> x11/gnome/controlcenter2
===>  control-center2-2.20.3p0 depends on: gstreamer-esd-* - not found
===>  Verifying install for gstreamer-esd-* in multimedia/gstreamer-0.10/plugins-good
===>  Checking files for gst-plugins-good-0.10.5
`/usr/ports/distfiles/gst-plugins-good-0.10.5.tar.bz2' is up to date.
>> (SHA256) gst-plugins-good-0.10.5.tar.bz2: OK
===>  gstreamer-esd-0.10.5p1 depends on: libcaca-* - not found
===>  Verifying install for libcaca-* in graphics/libcaca
===>  Checking files for libcaca-0.9p3
>> libcaca-0.9.tar.gz doesn't seem to exist on this system.
>> Fetch http://libcaca.zoy.org/files/libcaca-0.9.tar.gz.
100% |******************************************************************************************************************|  3531       00:00    
>> Size does not match for /usr/ports/distfiles/libcaca-0.9.tar.gz
>> Fetch ftp://ftp.openbsd.org/pub/OpenBSD/distfiles//libcaca-0.9.tar.gz.
100% |******************************************************************************************************************|   210 KB    00:03    
>> Size does not match for /usr/ports/distfiles/libcaca-0.9.tar.gz
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 2262 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1714 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1921 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1392 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1890 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1550 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1921 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1392 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1890 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/x11/gnome/controlcenter2 (line 1550 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/x11/gnome/controlcenter2 (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
===> Exiting x11/gnome/controlcenter2 with an error
*** Error code 1

Stop in /usr/ports/x11/gnome (line 124 of /usr/ports/infrastructure/mk/bsd.port.subdir.mk).
#
So I tried to "make install" once more, now the error message is a bit more elaborate: (Newlines are created by me to highlight the new information created by ports)

Code:
# make install
===> x11/gnome/alacarte
===> x11/gnome/applets2
===> x11/gnome/at-spi
===> x11/gnome/audio
===> x11/gnome/backgrounds
===> x11/gnome/build
===> x11/gnome/controlcenter2
===>  control-center2-2.20.3p0 depends on: gstreamer-esd-* - not found
===>  Verifying install for gstreamer-esd-* in multimedia/gstreamer-0.10/plugins-good
===>  Checking files for gst-plugins-good-0.10.5
`/usr/ports/distfiles/gst-plugins-good-0.10.5.tar.bz2' is up to date.
>> (SHA256) gst-plugins-good-0.10.5.tar.bz2: OK
===>  gstreamer-esd-0.10.5p1 depends on: libcaca-* - not found
===>  Verifying install for libcaca-* in graphics/libcaca
===>  Checking files for libcaca-0.9p3


`/usr/ports/distfiles/libcaca-0.9.tar.gz' is up to date.
>> (SHA256) libcaca-0.9.tar.gz: FAILED
>> Checksum mismatch for libcaca-0.9.tar.gz. (sha256)
Make sure the Makefile and checksum file (/usr/ports/graphics/libcaca/distinfo)
are up to date.  If you want to fetch a good copy of this
file from the OpenBSD main archive, type
"make REFETCH=true [other args]".
*** Error code 1



Stop in /usr/ports/graphics/libcaca (line 1774 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1921 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1392 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1890 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1550 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1921 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1392 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1890 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/x11/gnome/controlcenter2 (line 1550 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/x11/gnome/controlcenter2 (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
===> Exiting x11/gnome/controlcenter2 with an error
*** Error code 1

Stop in /usr/ports/x11/gnome (line 124 of /usr/ports/infrastructure/mk/bsd.port.subdir.mk).
#
so I tried this command:

Code:
make REFETCH=true install
Now I get this error message:

Code:
# make REFETCH=true install
===> x11/gnome/alacarte
===> x11/gnome/applets2
===> x11/gnome/at-spi
===> x11/gnome/audio
===> x11/gnome/backgrounds
===> x11/gnome/build
===> x11/gnome/controlcenter2
===>  control-center2-2.20.3p0 depends on: gstreamer-esd-* - not found
===>  Verifying install for gstreamer-esd-* in multimedia/gstreamer-0.10/plugins-good
===>  Checking files for gst-plugins-good-0.10.5
`/usr/ports/distfiles/gst-plugins-good-0.10.5.tar.bz2' is up to date.
>> (SHA256) gst-plugins-good-0.10.5.tar.bz2: OK
===>  gstreamer-esd-0.10.5p1 depends on: libcaca-* - not found
===>  Verifying install for libcaca-* in graphics/libcaca
===>  Checking files for libcaca-0.9p3
`/usr/ports/distfiles/libcaca-0.9.tar.gz' is up to date.
>> (SHA256) libcaca-0.9.tar.gz: FAILED
>> Checksum mismatch for libcaca-0.9.tar.gz. (sha256)
>> libcaca-0.9.tar.gz doesn't seem to exist on this system.
>> Fetch ftp://ftp.openbsd.org/pub/OpenBSD/distfiles/sha256/Xkid/feH2njBqHANdfKXYLokKK+CsMhMDMx5GFUFcco=/libcaca-0.9.tar.gz.
Failed to change directory.
>> Fetch http://libcaca.zoy.org/files/libcaca-0.9.tar.gz.
100% |******************************************************************************************************************|  3531       00:00    
>> Size does not match for /usr/ports/distfiles/libcaca-0.9.tar.gz
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 2262 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1779 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1774 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1921 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1392 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1890 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/graphics/libcaca (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1550 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1921 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1392 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1890 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-0.10/plugins-good (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/x11/gnome/controlcenter2 (line 1550 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/x11/gnome/controlcenter2 (line 1422 of /usr/ports/infrastructure/mk/bsd.port.mk).
===> Exiting x11/gnome/controlcenter2 with an error
*** Error code 1

Stop in /usr/ports/x11/gnome (line 124 of /usr/ports/infrastructure/mk/bsd.port.subdir.mk).
#
Which pretty much leaves me back to where I was before using REFETCH=true flag.

Some additional information about my system:

Code:
$ df -h
Filesystem     Size    Used   Avail Capacity  Mounted on
/dev/wd0a      2.0G    103M    1.8G     5%    /
/dev/wd0h     11.5G    263M   10.6G     2%    /home
/dev/wd0d      2.0G   20.0K    1.9G     0%    /tmp
/dev/wd0g      7.9G    6.8G    717M    91%    /usr
/dev/wd0e      4.9G   35.8M    4.6G     1%    /var
$
Code:
$ uname -a
OpenBSD alpha 4.3 GENERIC#698 i386
$
Thank you guys for helping me out on this one, it is much appreciated!
Reply With Quote
  #2   (View Single Post)  
Old 2nd August 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,710
Thanked 214 Times in 189 Posts
Default

If you've read FAQ 15 carefully, you'll note that there is absolutely no reason to build gnome from ports. FAQ 15.4.6 discusses this in some detail. Ports are only needed if packages do not already exist, and they won't exist for a -release system only if there are licensing restrictions or you need a unique FLAVOR of an application.

Installing from packages would eliminate your problem.

As to the cause of the problem itself -- it appears that there is a mismatch between the libcaca tarball, created in 2005, and the checksums in ports/graphics/libcaca/distinfo. Some possibilities exist, including data corruption of the tarball, or perhaps corruption of the distinfo file. Odds are on the former.
Reply With Quote
  #3   (View Single Post)  
Old 2nd August 2008
Kilo1 Kilo1 is offline
New User
 
Join Date: Aug 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default

Ok I feel stupid now..

I will rather install gnome from the pre-compiled packages.

Thank you for your advice, and next time I will study the FAQ's more thoroughly.

Just one last question:

Since some elements of gnome has been installed via. ports, should I do a "make uninstall" in x11/gnome/ ?

Thank you for your help!
Reply With Quote
  #4   (View Single Post)  
Old 2nd August 2008
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by Kilo1 View Post
Since some elements of gnome has been installed via. ports, should I do a "make uninstall" in x11/gnome/ ?
No. Packages are pre-compiled ports. If you uninstall, you will be turning around & installing the same thing again.
Reply With Quote
Reply

Tags
gnome, openbsd 4.3, ports

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME st89 OpenBSD Packages and Ports 3 8th October 2009 07:13 AM
Problem with latest php5 from ports clevershark FreeBSD Ports and Packages 1 22nd July 2009 07:38 PM
New User - Ports Install and GNOME Pkg problems IronForge OpenBSD Packages and Ports 9 14th July 2009 08:34 PM
Broken ports in /usr/ports/x11 DNAeon FreeBSD Ports and Packages 3 5th July 2009 08:20 PM
Gnome PBI for PC-BSD s0xxx Other BSD and UNIX/UNIX-like 2 22nd July 2008 01:34 PM


All times are GMT. The time now is 08:27 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick