DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 9th May 2008
lil_elvis2000 lil_elvis2000 is offline
Port Guard
 
Join Date: May 2008
Location: The armpit of England
Posts: 21
Thanked 1 Time in 1 Post
Default SOLVED: Boot abort with gmirror problem

I'm new to FreeBSD. I chose it because from what I have read it is fast and solid. I wanted to build a RAID 1 file server for our office.
- I have managed after a couple of tries to get 7.0-RELEASE installed.
The system has
ad2s1b / approx 8G IDE
ad2s1c SWAP approx 1.5G
ad4s1e /home approx 300G SATA
ad6 approx 300G identical drive to SATA

I then followed instructions found on the internet
gmirror label -v -b round-robin gm0 /dev/ad4
gmirror load
gmirror insert gm0 /dev/ad6

I then altered the /boot/loader.conf
and /etc/fstab as instructed.

I checked the gmirror status which reported DEGRADED. I decided
at that point to reboot. I thought the syncing process would restart
after the reboot. I was soon to be mistaken.

Upon reboot BSD reported a error
Can't stat /dev/mirror/gm01sd : no such file or directory
and the boot aborted to be left to single user mode.

I did a gmirror status which reported nothing. So what have I done wrong?
it almost seems as if gmirror is not starting properly. I assumed the resync. would continue after boot..perhaps I was mistaken? I could not edit any files as it seems the file system was set to read-only. I don't know how to get around that.

So I :
gmirror unload
gmirror load
gmirror label -v -b round-robin gm0 /dev/ad4
gmirror insert gm0 /dev/ad6

I've let it resync. overnight as it was now 5pm. Find out in the morning if it works and if it will reboot.

So far I've spent two days getting FreeBSD to this point - I originally tried to create the mirror at install time like you can do with some Linux distros. That took a day for me to give up. Then when I did redid the install I forgot to mark a partition as boot (hello install team).

Any ideas what could be going wrong?

Last edited by lil_elvis2000; 9th May 2008 at 08:08 PM.
Reply With Quote
  #2   (View Single Post)  
Old 9th May 2008
lil_elvis2000 lil_elvis2000 is offline
Port Guard
 
Join Date: May 2008
Location: The armpit of England
Posts: 21
Thanked 1 Time in 1 Post
Default

I think I have solved this. I recreated the mirror using DAT as the name.
But it did not auto synchronise it..so when I did
gmirror configure -a dat
the mirror disconnected :
so I have to re-insert the disk. It then rebuilt and then I rebooted successfully.
And the RAID 1 is now up.

Now to get SAMBA going...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot problem. Geometry problem? gulanito FreeBSD Installation and Upgrading 0 3rd July 2009 03:03 AM
Can gmirror be used for this? PeterSteele FreeBSD General 12 8th November 2008 12:01 AM
FreeBSD boot problem kdi FreeBSD General 2 25th May 2008 07:09 AM
Installation cd boot problem michaela FreeBSD Installation and Upgrading 1 20th May 2008 07:47 PM
mount on boot problem topche FreeBSD General 7 11th May 2008 04:07 PM


All times are GMT. The time now is 10:20 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick