DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd August 2008
asemisldkfj's Avatar
asemisldkfj asemisldkfj is offline
Fdisk Soldier
 
Join Date: Aug 2008
Posts: 50
Thanked 1 Time in 1 Post
Default OpenBSD, Mac OS X, and NFS

hello everyone. I hope I recognize some of the names around here. (I posted on BSDforums a long time ago and am still around on BSDnexus forums.) anyway, on to my problem.

this is the configuration of my OpenBSD 4.3 NFS server:

rc.conf.local
Code:
portmap=YES
nfs_server=YES
mountd_flags="-n"
the -n mountd flag is supposed to "not require that clients make mount requests from reserved ports."

exports
Code:
/share 10.0.1.3
Code:
drwxrwxrwx   2 brain  brain      512 Aug 22 11:58 share/
I can mount the NFS share with mount_nfs -P crashoverride:/share /mnt on the OS X client, but without the -P flag it gives me mount_nfs: /mnt: Permission denied.

I'd like to be able to mount the share from the OS X Finder interface and I can't pass the -P flag from there. for some reason the -n flag to mountd doesn't seem to be working. there used to be a sysctl for this but it seems to be gone. any ideas?
Reply With Quote
  #2   (View Single Post)  
Old 22nd August 2008
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,886
Thanked 214 Times in 189 Posts
Default

Are you trying your NFS mount from OpenBSD? If so, note that the man page for mount_nfs(8) says (highlight mine):
Code:
HISTORY
     The -P flag historically informed the kernel to use a reserved port when
     communicating with clients.  In OpenBSD, a reserved port is always used.
Reply With Quote
  #3   (View Single Post)  
Old 23rd August 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

I believe the OP meant they could mount via mount_nfs(8) on OS X but not via the GUI front end.

Perhaps the GUI front end uses global defaults set in nfs.conf(5)?
Reply With Quote
  #4   (View Single Post)  
Old 23rd August 2008
asemisldkfj's Avatar
asemisldkfj asemisldkfj is offline
Fdisk Soldier
 
Join Date: Aug 2008
Posts: 50
Thanked 1 Time in 1 Post
Default

thanks for the suggestion, BSDfan, but it didn't seem to work. /etc/nfs.conf didn't seem to exist on my Mac (nor did the man page for it), but I created it an added the line nfs.client.mount.options = -P. I started up mountd on OpenBSD and tried to mount the NFS share both via the command line (without the -P option, because presumably nfs.conf should have taken care of that) and the GUI. neither worked . same error at the command line.
Reply With Quote
  #5   (View Single Post)  
Old 23rd August 2008
corey_james corey_james is offline
Uber Geek
 
Join Date: Apr 2008
Location: Brisbane, Australia
Posts: 238
Thanked 4 Times in 10 Posts
Default

nfs.conf must be an addition to 10.5

brian, have a look at net info manager, i'm pretty sure you'll find some mention of NFS there
__________________
"No, that's wrong, Cartman. But don't worry, there are no stupid answers, just stupid people." -- Mr. Garrison

Forum Netiquette
Reply With Quote
  #6   (View Single Post)  
Old 23rd August 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

According to that man page, it's been around since at least January 9, 2007... before 10.5.
Reply With Quote
  #7   (View Single Post)  
Old 23rd August 2008
asemisldkfj's Avatar
asemisldkfj asemisldkfj is offline
Fdisk Soldier
 
Join Date: Aug 2008
Posts: 50
Thanked 1 Time in 1 Post
Default

I still have 10.4.9 because anything newer breaks my MacBook's Airport Extreme card (it makes the reception really bad).

I remember reading a little about NetInfo Manager when I was looking around the web for stuff about this problem. maybe I'll be able to set the -P flag there somehow. thanks cj .
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick