DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 28th August 2008
disappearedng disappearedng is offline
Shell Scout
 
Join Date: May 2008
Posts: 128
Thanked 0 Times in 0 Posts
Default VNC not viewing correctly

Hi everyone
I have two freebsd servers in my home and I have a small trouble with VNC. First of all, I have one running on KDE and another running of Gnome. I have looked up a lot of tutorials online and it seems that I have done the "right" thing.

For my KDE Desktop, I have modified my xstartup to be:
Code:
#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &

#REMOVE TO RETURN TO DEFAULT
#twm &

#ADDED TO ALLOW KDE
exec startkde
I run the following command to start vnc
#vncserver
and when I connect to this computer, using
#vncviewer x.x.x.x:1,
I am only seeing a NEW kde environment. I thought VNC is supposed to bring you the CURRENT view. By current, I am referring to your current desktop so whatever files or folders you have opened during the vnc access should show up on the vnc viewer rather than a brand new fresh kde desktop. How do I modify my settings to allow this to happen? Note that I am using ktorrent and ktorrent doesn't allow multiple instances, so that I whenever I start up ktorrent under my current vnc sessions, it doesn't work.


Second this is my gnome xstartup:
Code:
#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &

#UNCOMMENT TO RETURN TO DEFAULTS
#twm &

#ADDED for Gnome laptop
gnome-session
but then when i do the following:

[disappearedng@home ~/.vnc]$ vncserver
I get the following error
xauth: (argv):1: bad "add" command line
xauth: (argv):1: bad "add" command line

Note that when i vncviewer my gnome desktop i CANNOT see anything. It's just a blank screen.

Why?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
startx not starting correctly - XOrg 7.4_2 Mantazz FreeBSD Ports and Packages 1 8th July 2009 04:17 PM
FBSD 7.2 installation not seeing partition table correctly Mantazz FreeBSD Installation and Upgrading 0 2nd July 2009 11:36 AM
Viewing DVD's, pictures, and ps/pdf without X JMJ_coder Other BSD and UNIX/UNIX-like 6 17th June 2008 02:43 PM
No 30 second wait for viewing new posts anomie Feedback and Suggestions 6 15th May 2008 01:48 PM
KDE (X-Server) in FreeBSD 7.0 doesn't work correctly louie FreeBSD General 6 7th May 2008 11:53 PM


All times are GMT. The time now is 01:41 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick