DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 8th September 2008
Nightweaver's Avatar
Nightweaver Nightweaver is offline
Fdisk Soldier
 
Join Date: May 2008
Location: Belgrade, Serbia
Posts: 47
Thanked 5 Times in 4 Posts
Default OpenBSD 4.4 and Intel DRM

Hi,

I've been playing with OpenBSD 4.4 snapshots for a while now on my Toshiba laptop. Support for 3d for my Intel graphic card was added recently. I'm using snapshot from 05.09.2008. with inteldrm enabled in my kernel. Yet, glxinfo says following:

Code:
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
When I try running GL screensaver with xscreensaver I get:

Code:
i915 DRI driver expected DDX version 1-1.5.x but got version 1.4.1
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering
This is my dmesg:

Code:
OpenBSD 4.4-current (GENERIC.MP) #864: Fri Sep  5 12:10:38 MDT 2008
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Genuine Intel(R) CPU T2080 @ 1.73GHz ("GenuineIntel" 686-class) 1.73 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,TM2,xTPR
real mem  = 1063350272 (1014MB)
avail mem = 1019691008 (972MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 04/26/07, BIOS32 rev. 0 @ 0xfdca4, SMBIOS rev. 2.4 @ 0xdc010 (22 entries)
bios0: vendor TOSHIBA version "V1.40" date 04/26/2007
bios0: TOSHIBA Satellite A200
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP SLIC APIC HPET MCFG BOOT APIC SSDT SSDT SSDT SSDT SSDT
acpi0: wakeup devices HDEF(S3) PXS3(S0) USB1(S3) USB2(S3) USB3(S3) USB7(S3) LANC(S0) MODM(S3) BT__(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 133MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Genuine Intel(R) CPU T2080 @ 1.73GHz ("GenuineIntel" 686-class) 1.73 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,TM2,xTPR
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
ioapic0: duplicate apic id, remapped to apid 2
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEGP)
acpiprt2 at acpi0: bus 2 (RP01)
acpiprt3 at acpi0: bus 4 (RP02)
acpiprt4 at acpi0: bus 5 (RP03)
acpiprt5 at acpi0: bus 6 (PCIB)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2
acpicpu1 at acpi0: C3, C2
acpibtn0 at acpi0: LID0
acpibtn1 at acpi0: PWRB
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT1 model "PA3465U " serial 3658Q type Li-Ion oem "TOSHIBA"
acpivideo at acpi0 not configured
acpivideo at acpi0 not configured
bios0: ROM list: 0xc0000/0xea00! 0xcf000/0x1000 0xdc000/0x4000! 0xe0000/0x1c00!
cpu0: unknown Enhanced SpeedStep CPU, msr 0x06190d2806000d28
cpu0: using only highest and lowest power states
cpu0: Enhanced SpeedStep 1733 MHz (1340 mV): speeds: 1733, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM Host" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82945GM Video" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
agp0 at vga1: aperture at 0xc0000000, size 0x10000000
inteldrm0 at vga1 Intel i945GM(0), 1.6.0 20080312
"Intel 82945GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x02: apic 2 int 22 (irq 11)
azalia0: codec[s]: Realtek/0x0862, AT&T/Lucent/0x1040, using Realtek/0x0862
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02: apic 2 int 17 (irq 10)
pci1 at ppb0 bus 2
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02: apic 2 int 16 (irq 10)
pci2 at ppb1 bus 4
ath0 at pci2 dev 0 function 0 "Atheros AR5424" rev 0x01: apic 2 int 17 (irq 10)
ath0: AR5424 10.0 phy 6.1 rf 10.2, WOR4W, address 00:19:7e:8f:f9:3c
ppb2 at pci0 dev 28 function 2 "Intel 82801GB PCIE" rev 0x02: apic 2 int 18 (irq 11)
pci3 at ppb2 bus 5
re0 at pci3 dev 0 function 0 "Realtek 8101E" rev 0x01: RTL8101E (0x3400), apic 2 int 18 (irq 11), address 00:1b:38:10:2a:9c
rlphy0 at re0 phy 7: RTL8201L 10/100 PHY, rev. 1
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: apic 2 int 23 (irq 11)
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: apic 2 int 19 (irq 11)
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: apic 2 int 18 (irq 11)
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: apic 2 int 16 (irq 10)
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: apic 2 int 23 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb3 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci4 at ppb3 bus 6
cbb0 at pci4 dev 4 function 0 "TI PCIXX12 CardBus" rev 0x00: apic 2 int 16 (irq 255), CardBus support disabled
"TI PCIXX12 FireWire" rev 0x00 at pci4 dev 4 function 1 not configured
"TI PCIXX12 Multimedia Card Reader" rev 0x00 at pci4 dev 4 function 2 not configured
sdhc0 at pci4 dev 4 function 3 "TI PCIXX12 Secure Data" rev 0x00: apic 2 int 18 (irq 10)
sdmmc0 at sdhc0
cardslot0 at cbb0 slot 0 flags 0
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GBM SATA" rev 0x02: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <Hitachi HTS541612J9SA00>
wd0: 16-sector PIO, LBA48, 114473MB, 234441648 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets, initiator 7
cd0 at scsibus0 targ 0 lun 0: <TSSTcorp, CD/DVDW TS-L632D, TO04> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: apic 2 int 19 (irq 11)
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
spdmem1 at iic0 addr 0x52: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
softraid0 at root
root on wd0a swap on wd0b dump on wd0b
It's not like I can't live without 3d screensaver but I was just wondering what might be the problem. Any ideas appreciated.
__________________
If it moves, crypt it. Unless it's static - than you should double-crypt it.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wpi firmware Intel eula plouk NetBSD General 7 4th July 2009 04:14 AM
open bsd 4.3 on intel board ddocksta OpenBSD General 11 25th September 2008 06:50 AM
Intel 775 MB For 20$ revzalot OpenBSD General 2 22nd July 2008 06:17 AM
Intel 4965 Business_woman FreeBSD Installation and Upgrading 9 2nd July 2008 02:49 PM
Intel Mainboard Question Nameless FreeBSD Installation and Upgrading 1 12th June 2008 09:29 AM


All times are GMT. The time now is 09:20 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick