DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 23rd August 2008
revzalot's Avatar
revzalot revzalot is offline
Shell Scout
 
Join Date: May 2008
Posts: 123
Thanked 1 Time in 1 Post
Default OpenBSD = Awesome Laptop OS

I've been using 4.3 as my OS for an old HP laptop and it has never let me down. I've been using it with FLuxbox with all the office and administration apps installed and it never crashes with so many apps running at the same time. I'm using an old P3 laptop with 640MB of RAM. I vnc, rdesktop, firefox, tons of aterms open, openoffice, all running on top of fluxbox at the same time and not one time did it crash with all these apps open in a 15 year old dinosaur laptop. I'm able to switch windows with no signs of slow down while doing mission critical work. I turn on xlock to take a break and when I log back in, it's a snap and I'm back to work in no time. I'm able to finish my work a day early and just want to say thanks to the Puffy crew. When I need a new app, Pkg_add -v and it's installed in no time and I'm back to work.
Reply With Quote
  #2   (View Single Post)  
Old 23rd August 2008
qmemo's Avatar
qmemo qmemo is offline
Shell Scout
 
Join Date: Jul 2008
Location: Egypt
Posts: 133
Thanked 0 Times in 0 Posts
Default

kindly make a screen shot along with dmesg output plus the lap model
Reply With Quote
  #3   (View Single Post)  
Old 24th August 2008
revzalot's Avatar
revzalot revzalot is offline
Shell Scout
 
Join Date: May 2008
Posts: 123
Thanked 1 Time in 1 Post
Default

Here you go. I'll take a pic of the actual laptop soon. It's an HP Pavillion N5445.

Code:
OpenBSD 4.3 (GENERIC) #698: Wed Mar 12 11:07:05 MDT 2008
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) III Mobile CPU 1066MHz ("GenuineIntel" 686-class) 1.07 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 259022848 (247MB)
avail mem = 242384896 (231MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 09/28/01, BIOS32 rev. 0 @ 0xfd852, SMBIOS rev. 2.3 @ 0xdf810 (38 entries)
bios0: vendor Phoenix Technologies LTD version "GF.M1.01" date 09/28/2001
bios0: Hewlett-Packard HP Pavilion Notebook PC
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
acpi at bios0 function 0x0 not configured
pcibios0 at bios0: rev 2.1 @ 0xfd820/0x7e0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdf10/208 (11 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB ISA" rev 0x00)
pcibios0: PCI bus #3 is the last bus
bios0: ROM list: 0xc0000/0xc400 0xdf800/0x800! 0xe0000/0x4000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82830M Host" rev 0x03
agp0 at pchb0: aperture at 0xe8000000, size 0x8000000
vga1 at pci0 dev 2 function 0 "Intel 82830M Video" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Intel 82830M Video" rev 0x00 at pci0 dev 2 function 1 not configured
uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x01: irq 9
uhci1 at pci0 dev 29 function 1 "Intel 82801CA/CAM USB" rev 0x01: irq 5
uhci2 at pci0 dev 29 function 2 "Intel 82801CA/CAM USB" rev 0x01: irq 5
ppb0 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x41
pci1 at ppb0 bus 1
"TI TSB43AB22 FireWire" rev 0x00 at pci1 dev 0 function 0 not configured
"ESS ES2838/2839 SuperLink Modem" rev 0x01 at pci1 dev 2 function 0 not configured
esa0 at pci1 dev 3 function 0 "ESS ES1989" rev 0x12: irq 5
ac97: codec id 0x45838308 (ESS Technology ES1921)
ac97: codec features 20 bit DAC, 20 bit ADC, ESS Technology
audio0 at esa0
cbb0 at pci1 dev 4 function 0 "O2 Micro OZ6933 CardBus" rev 0x01: irq 9
cbb1 at pci1 dev 4 function 1 "O2 Micro OZ6933 CardBus" rev 0x01: irq 9
fxp0 at pci1 dev 8 function 0 "Intel PRO/100 VE" rev 0x41, i82562: irq 9, address 00:02:3f:2e:51:5d
inphy0 at fxp0 phy 1: i82562ET 10/100 PHY, rev. 0
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 3 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
ichpcib0 at pci0 dev 31 function 0 "Intel 82801CAM LPC" rev 0x01: 24-bit timer at 3579545Hz: SpeedStep
pciide0 at pci0 dev 31 function 1 "Intel 82801CAM IDE" rev 0x01: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <FUJITSU MHT2040AT>
wd0: 16-sector PIO, LBA, 38154MB, 78140160 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, UJDA710, 1.50> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801CA/CAM SMBus" rev 0x01: irq 9
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 128MB SDRAM non-parity PC133CL2
usb0 at uhci0: USB revision 1.0
uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb1 at uhci1: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci2: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ef6d netmask ef6d ttymask ffef
mtrr: Pentium Pro MTRR support
softraid0 at root
root on wd0a swap on wd0b dump on wd0b
Reply With Quote
  #4   (View Single Post)  
Old 24th August 2008
qmemo's Avatar
qmemo qmemo is offline
Shell Scout
 
Join Date: Jul 2008
Location: Egypt
Posts: 133
Thanked 0 Times in 0 Posts
Default

that's sweet, I saw it's pics already on the net
Reply With Quote
  #5   (View Single Post)  
Old 24th August 2008
Nightweaver's Avatar
Nightweaver Nightweaver is offline
Fdisk Soldier
 
Join Date: May 2008
Location: Belgrade, Serbia
Posts: 47
Thanked 5 Times in 4 Posts
Default

Here is another happy OpenBSD laptop user. I'm running 4.4 current on Toshiba Satellite A200-1CR model. Everything works like a charm.

DMESG:
Code:
OpenBSD 4.4 (GENERIC.MP) #844: Tue Aug 12 17:24:39 MDT 2008
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Genuine Intel(R) CPU T2080 @ 1.73GHz ("GenuineIntel" 686-class) 1.73 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,TM2,xTPR
real mem  = 1063350272 (1014MB)
avail mem = 1019699200 (972MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 04/26/07, BIOS32 rev. 0 @ 0xfdca4, SMBIOS rev. 2.4 @ 0xdc010 (22 entries)
bios0: vendor TOSHIBA version "V1.40" date 04/26/2007
bios0: TOSHIBA Satellite A200
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP SLIC APIC HPET MCFG BOOT APIC SSDT SSDT SSDT SSDT SSDT
acpi0: wakeup devices HDEF(S3) PXS3(S0) USB1(S3) USB2(S3) USB3(S3) USB7(S3) LANC(S0) MODM(S3) BT__(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 133MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Genuine Intel(R) CPU T2080 @ 1.73GHz ("GenuineIntel" 686-class) 1.73 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,TM2,xTPR
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
ioapic0: duplicate apic id, remapped to apid 2
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEGP)
acpiprt2 at acpi0: bus 2 (RP01)
acpiprt3 at acpi0: bus 4 (RP02)
acpiprt4 at acpi0: bus 5 (RP03)
acpiprt5 at acpi0: bus 6 (PCIB)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2
acpicpu1 at acpi0: C3, C2
acpibtn0 at acpi0: LID0
acpibtn1 at acpi0: PWRB
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT1 model "PA3465U " serial 3658Q type Li-Ion oem "TOSHIBA"
acpivideo at acpi0 not configured
acpivideo at acpi0 not configured
bios0: ROM list: 0xc0000/0xea00! 0xcf000/0x1000 0xdc000/0x4000! 0xe0000/0x1c00!
cpu0: unknown Enhanced SpeedStep CPU, msr 0x06190d2806000d28
cpu0: using only highest and lowest power states
cpu0: Enhanced SpeedStep 1733 MHz (1340 mV): speeds: 1733, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM Host" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82945GM Video" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
agp0 at vga1: aperture at 0xc0000000, size 0x10000000
drm at vga1 unsupported
"Intel 82945GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x02: apic 2 int 22 (irq 11)
azalia0: codec[s]: Realtek/0x0862, AT&T/Lucent/0x1040, using Realtek/0x0862
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02: apic 2 int 17 (irq 10)
pci1 at ppb0 bus 2
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02: apic 2 int 16 (irq 10)
pci2 at ppb1 bus 4
ath0 at pci2 dev 0 function 0 "Atheros AR5424" rev 0x01: apic 2 int 17 (irq 10)
ath0: AR5424 10.0 phy 6.1 rf 10.2, WOR4W, address 00:19:7e:8f:f9:3c
ppb2 at pci0 dev 28 function 2 "Intel 82801GB PCIE" rev 0x02: apic 2 int 18 (irq 11)
pci3 at ppb2 bus 5
re0 at pci3 dev 0 function 0 "Realtek 8101E" rev 0x01: RTL8101E (0x3400), apic 2 int 18 (irq 11), address 00:1b:38:10:2a:9c
rlphy0 at re0 phy 7: RTL8201L 10/100 PHY, rev. 1
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: apic 2 int 23 (irq 11)
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: apic 2 int 19 (irq 11)
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: apic 2 int 18 (irq 11)
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: apic 2 int 16 (irq 10)
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: apic 2 int 23 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb3 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci4 at ppb3 bus 6
cbb0 at pci4 dev 4 function 0 "TI PCIXX12 CardBus" rev 0x00: apic 2 int 16 (irq 255), CardBus support disabled
"TI PCIXX12 FireWire" rev 0x00 at pci4 dev 4 function 1 not configured
"TI PCIXX12 Multimedia Card Reader" rev 0x00 at pci4 dev 4 function 2 not configured
sdhc0 at pci4 dev 4 function 3 "TI PCIXX12 Secure Data" rev 0x00: apic 2 int 18 (irq 10)
sdmmc0 at sdhc0
cardslot0 at cbb0 slot 0 flags 0
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GBM SATA" rev 0x02: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <Hitachi HTS541612J9SA00>
wd0: 16-sector PIO, LBA48, 114473MB, 234441648 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets, initiator 7
cd0 at scsibus0 targ 0 lun 0: <TSSTcorp, CD/DVDW TS-L632D, TO04> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: apic 2 int 19 (irq 11)
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
spdmem1 at iic0 addr 0x52: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
softraid0 at root
root on wd0a swap on wd0b dump on wd0b
__________________
If it moves, crypt it. Unless it's static - than you should double-crypt it.
Reply With Quote
  #6   (View Single Post)  
Old 24th August 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

If you enable inteldrm from UKC or config, you might even get DRM/DRI support Nightweaver.

Both inteldrm/radeondrm will be in GENEIRC/GENERIC.MP, they're simply disabled by default.

See the rev 1.633 commit log:
http://www.openbsd.org/cgi-bin/cvswe...6/conf/GENERIC
Reply With Quote
  #7   (View Single Post)  
Old 24th August 2008
Nightweaver's Avatar
Nightweaver Nightweaver is offline
Fdisk Soldier
 
Join Date: May 2008
Location: Belgrade, Serbia
Posts: 47
Thanked 5 Times in 4 Posts
Default

And I was wondering how to make that work. Thank you for the tip. How do you enable it exactly?

EDIT:

Forget that... the effect of Beer Fest that is being held in Belgrade these days. I've been asking dumb questions all day.
__________________
If it moves, crypt it. Unless it's static - than you should double-crypt it.

Last edited by Nightweaver; 24th August 2008 at 04:22 PM.
Reply With Quote
  #8   (View Single Post)  
Old 9th September 2008
avallach avallach is offline
New User
 
Join Date: May 2008
Posts: 4
Thanked 0 Times in 0 Posts
Default

Hey Maybe it's a good idea to create a brand new sticky thread, where we will gather all info and dmesg about OpenBSD running on Laptops...
I mean something alternative to this: http://www.openbsd.org/i386-laptop.html
Reply With Quote
  #9   (View Single Post)  
Old 9th September 2008
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Quote:
Originally Posted by avallach View Post
Hey Maybe it's a good idea to create a brand new sticky thread, where we will gather all info and dmesg about OpenBSD running on Laptops...
I mean something alternative to this: http://www.openbsd.org/i386-laptop.html
Here mates: http://daemonforums.org/showthread.php?t=1880
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Your FreeBSD Laptop vermaden FreeBSD General 67 6th June 2014 12:27 PM
Your OpenBSD Laptop vermaden OpenBSD General 97 11th May 2014 10:16 PM
Laptop Repair DrJ General Hardware 4 25th August 2008 02:30 PM
laptop cw_ FreeBSD General 21 14th August 2008 02:48 AM
Dual-boot laptop won't boot OpenBSD after upgrade to 4.3 kbeaucha OpenBSD Installation and Upgrading 17 30th May 2008 02:40 PM


All times are GMT. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick