DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 15th September 2008
sum sum is offline
New User
 
Join Date: Sep 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default X Radeon driver

Hey all, I've been searching for a few days now and I'm struggling with the radeon driver which comes with X.

Here's my GPU:

Code:
vgapci0@pci0:1:0:0:	class=0x030000 card=0x0490174b chip=0x5b621002 rev=0x00 hdr=0x00
    vendor     = 'ATI Technologies Inc'
    device     = 'RV380 RADEON X600 Series 265MB'
    class      = display
    subclass   = VGA
vgapci1@pci0:1:0:1:	class=0x038000 card=0x0491174b chip=0x5b721002 rev=0x00 hdr=0x00
    vendor     = 'ATI Technologies Inc'
    device     = 'Radeon X600 Series - Secondary'
    class      = display
Heres the moinitor. Xorg correctly identifies all of the monitors attributes.

Here's the Xorg log:
The warning in bold is what I think is the major problem, I don't know what it means fully though, or how I can fix it - any help or suggestions much appreciated.

Code:
X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 7.0-STABLE i386 
Current Operating System: FreeBSD sum.mix 7.0-RELEASE FreeBSD 7.0-RELEASE #0: Sun Feb 24 19:59:52 UTC 2008     root@logan.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386

(WW) OS did not count PCI devices, guessing wildly
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found
(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0):   MC_FB_LOCATION  was: 0xcfffc000 is: 0xcfffc000
(WW) RADEON(0):   MC_AGP_LOCATION was: 0xffffffc0 is: 0xffffffc0
(WW) RADEON(0): Failed to determine num pipes from DRM, falling back to manual look-up!
Reply With Quote
  #2   (View Single Post)  
Old 15th September 2008
adamk adamk is offline
Spam Deminer
 
Join Date: May 2008
Posts: 250
Thanked 5 Times in 8 Posts
Default

It's absolutely nothing to worry about. There were changed made to the DRI recently in how it determines the number of pipes available. Your DRM is older than those changes. That's all. It's just falling back to the previous method.
Reply With Quote
  #3   (View Single Post)  
Old 17th September 2008
sum sum is offline
New User
 
Join Date: Sep 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default

It is a big problem! X loads up like this when I use the radeon driver:



Haha, the mouse loads perfectly though and its at the correct resolution. (Things work ok when I use the vesa driver but it doesnt support 1680x1050 which is what I need).

If my DRM is older, maybe getting the newer version would be an idea? How would I do this, is it a part of X? So would I use packages-7-current when downloading X because I got this version of X from packages-7-stable. Cheers.
Reply With Quote
  #4   (View Single Post)  
Old 18th September 2008
adamk adamk is offline
Spam Deminer
 
Join Date: May 2008
Posts: 250
Thanked 5 Times in 8 Posts
Default

I doubt very much that this has anything to do with your DRM. Try disabling the dri module in /etc/X11/xorg.conf and see if you still have the problems.

Adam
Reply With Quote
  #5   (View Single Post)  
Old 24th September 2008
sum sum is offline
New User
 
Join Date: Sep 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default

Didn't work unfortunately. Only the 'vesa' driver will work at the highest possible resolution of 1280x1024, which is insufficient. Any other ideas? Perhaps this is not my fault and there is a problem with the radeon &/or ati drivers for X600.
Reply With Quote
  #6   (View Single Post)  
Old 28th September 2008
ninjatux's Avatar
ninjatux ninjatux is offline
Real Name: Baqir Majlisi
Spam Deminer
 
Join Date: May 2008
Location: Antarctica
Posts: 293
Thanked 15 Times in 15 Posts
Default

Post your xorg.conf.
__________________
"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity."
MacBook Pro (Darwin 9), iMac (Darwin 9), iPod Touch (Darwin 9), Dell Optiplex GX620 (FreeBSD 7.1-STABLE)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my radeon hd card is no longer working iacbsd OpenBSD General 8 17th July 2009 10:14 AM
openbsd 4.5 macppc radeon drive still broken gosha OpenBSD Installation and Upgrading 13 28th June 2009 03:14 PM
ATI Radeon 4870X2 NetBSD NetBSD General 6 11th June 2009 08:17 PM
Radeon HD 4780 X2 NetBSD FreeBSD General 0 19th February 2009 12:15 AM
FreeBSD 7.0 + ATI Radeon HD2600PRO + mplayer ... daemonFromHeaven FreeBSD Ports and Packages 4 5th September 2008 01:24 PM


All times are GMT. The time now is 08:39 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick