DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 11th May 2008
rex rex is offline
Real Name: Nikhil Rathod
Shell Scout
 
Join Date: May 2008
Location: Chicago
Posts: 114
Thanked 2 Times in 2 Posts
Default Want to get rid of ugly color of rox

I'm using fluxbox and my firefox and Rox windows uses some strange light shade of pink or orange. I want to get rid of it. Sorry was not able to post screenshot as so far I was not able to figure out how to take screenshot (if somebody knows please do let me know. I got no desktop env installed and also don’t want to install any app which are part of or depend on gnome or KDE) also most of you who are using fluxbox, rox might have seen this.

thanks
Reply With Quote
  #2   (View Single Post)  
Old 11th May 2008
Grogan's Avatar
Grogan Grogan is offline
Port Guard
 
Join Date: May 2008
Location: Ontario, Canada
Posts: 23
Thanked 3 Times in 3 Posts
Default

Possibly there's a gtkrc file causing the colour scheme. Both Firefox and Rox are gtk+ apps. For firefox itself you could just install a theme of your choice if desired.

Or, you could get a gtk+ theme which will install a gtkrc file.

Or, you can place a .gtkrc-2.0 file (with the dot) in your home directory to override settings. Google for a sample .gtkrc-2.0 file (or take a gtkrc file from a gtk theme and rename it) and customize it.

P.S. I use a dark theme for xfce4 and it uses a gtkrc file. What I do is take and copy that file as ~/.gtkrc-2.0 so that my gtk+ apps all use that theme even when I'm not running xfce4.

These are the kinds of settings you'll find in a gtkrc file:
http://www.mikeserv.org/temp/gtkrc.txt

Last edited by Grogan; 11th May 2008 at 11:40 PM.
Reply With Quote
  #3   (View Single Post)  
Old 11th May 2008
rex rex is offline
Real Name: Nikhil Rathod
Shell Scout
 
Join Date: May 2008
Location: Chicago
Posts: 114
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by Grogan View Post
Possibly there's a gtkrc file causing the color scheme. Both Firefox and Rox are gtk+ apps. For firefox itself you could just install a theme of your choice if desired.
It makes sense. But only thing annoying me is the color. Don't want to change other settings. If anyone can tell me which file to edit, would be very helpful.
Reply With Quote
  #4   (View Single Post)  
Old 11th May 2008
Grogan's Avatar
Grogan Grogan is offline
Port Guard
 
Join Date: May 2008
Location: Ontario, Canada
Posts: 23
Thanked 3 Times in 3 Posts
Default

If they are defaults, there is no file to edit yet, you'd have to create one. Otherwise search for a gtkrc file somewhere on your system (if you have /usr/local/share/themes and it's populated with themes you'll have lots of them in there but they won't likely be the one that's in use)

See if there's already a .gtkrc-2.0 file in your home dir. I've not had ROX file manager, possible it's customized your environment?
Reply With Quote
  #5   (View Single Post)  
Old 11th May 2008
rex rex is offline
Real Name: Nikhil Rathod
Shell Scout
 
Join Date: May 2008
Location: Chicago
Posts: 114
Thanked 2 Times in 2 Posts
Default

How can I apply one of the thems in /usr/local/share/themes/. I would like to apply clear looks.

Just copy gtk-2.0 to home directory.

thanks
Reply With Quote
  #6   (View Single Post)  
Old 11th May 2008
Grogan's Avatar
Grogan Grogan is offline
Port Guard
 
Join Date: May 2008
Location: Ontario, Canada
Posts: 23
Thanked 3 Times in 3 Posts
Default

Yes, copy it to ~/.gtkrc-2.0 with the dot and it should override your current gtk+ colours that you don't like.

This probably doesn't apply to you, but for the benefit of anyone else if you are using KDE you have to be sure to turn off "apply colours to non KDE apps" in Control Center, under appearances and themes/colors. Otherwise you'll get a partial mix of colours on gtk+ apps depending on which settings its enforcing.
Reply With Quote
  #7   (View Single Post)  
Old 12th May 2008
rex rex is offline
Real Name: Nikhil Rathod
Shell Scout
 
Join Date: May 2008
Location: Chicago
Posts: 114
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by Grogan View Post
Yes, copy it to ~/.gtkrc-2.0 with the dot and it should override your current gtk+ colours that you don't like.
Yup it worked thanks a lot.
Reply With Quote
Reply

Tags
fluxbox, screenshot

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Default terminal color disappearedng FreeBSD General 5 21st February 2012 01:28 AM
xterm color does not behave properly. pieterverberne OpenBSD General 2 19th August 2009 05:17 PM
Opera Font and Dialog Color Problem roddierod FreeBSD General 4 26th September 2008 02:39 PM
Color shell? giga FreeBSD General 3 14th August 2008 12:07 AM
How to change Fluxbox menu text color rex FreeBSD General 1 11th May 2008 02:40 AM


All times are GMT. The time now is 02:39 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick