DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 11th May 2008
cuongvt cuongvt is offline
New User
 
Join Date: May 2008
Posts: 7
Thanked 0 Times in 0 Posts
Cool netbeans 6.0.1 not run

Hi all!

full explanation:
FreeBSD 7.0-RELEASE (i386)
uid=1001(mak) gid=0(wheel) groups=0(wheel),69(network)

installed:
jdk-1.6.0.3p4_1
diablo-jdk-1.5.0.07.01_10
javavmwrapper-2.3.2

I'm using zsh so I set JAVA_HOME and PATH of java into in my .zshrc.
java -version:
java 16 jdku3p1 etc etc

Then I insralled netbeans from ports, firstly it warned:
JAVA_HOME should not be defined.

So i removed JAVA_HOME and PATH of java into in my .zshrc, reboot and reinstalled netbeans.
Installation went fine.

When I try run netbeans:
mak@lo0:~>netbeans
XIO: fatal IO error 0 (Unknown error: 0) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Any ideas?
P/S:All pkgs were installed via ports*
Reply With Quote
  #2   (View Single Post)  
Old 11th May 2008
Weaseal's Avatar
Weaseal Weaseal is offline
Package Pilot
 
Join Date: May 2008
Location: East Coast, US
Posts: 177
Thanked 7 Times in 7 Posts
Default

It's trying to load it in X, but can't determine which X server you're on. I don't know that program specifically but in many you can specify with -D 0 / --display 0

Check the --help flag.
Reply With Quote
  #3   (View Single Post)  
Old 12th May 2008
Mak-Di Mak-Di is offline
New User
 
Join Date: May 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Weaseal View Post
It's trying to load it in X, but can't determine which X server you're on.
Why can't? It's trying to load it in X:0.0

Quote:
XIO: fatal IO error 0 (Unknown error: 0) on X server ":0.0"
Quote:
Originally Posted by cuongvt View Post
I'm using zsh so I set JAVA_HOME and PATH of java into in my .zshrc.
java -version:
java 16 jdku3p1 etc etc

Then I insralled netbeans from ports, firstly it warned:
JAVA_HOME should not be defined.

So i removed JAVA_HOME and PATH of java into in my .zshrc, reboot and reinstalled netbeans.
Installation went fine.
I use default shell (tcsh), and I didn't define any path.
Reply With Quote
  #4   (View Single Post)  
Old 16th May 2008
wrightjj wrightjj is offline
New User
 
Join Date: May 2008
Posts: 1
Thanked 0 Times in 0 Posts
Default

For the plugin problem:

I had the same problem but got sorted out on the mailing lists. The plugin that is crashing firefox is that of diablo (because of some shared libraries issues) and so you want to use the plugin supplied by jdk16. To fix this, deinstall diablo, as it is only a build dependency for jdk16. Link the plugin supplied by jdk16 with this:

# ln -s /usr/local/jdk1.6.0/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/local/lib/browser_plugins/

Restart firefox and it should work.

I don't have JAVA_HOME variable set and with "java -version" I get:

java version "1.6.0_03-p4"
Java(TM) SE Runtime Environment (build 1.6.0_03-p4-root_13_may_2008_10_06-b00)
Java HotSpot(TM) Server VM (build 1.6.0_03-p4-root_13_may_2008_10_06-b00, mixed mode)
Reply With Quote
  #5   (View Single Post)  
Old 19th May 2008
Mak-Di Mak-Di is offline
New User
 
Join Date: May 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default

Thank you wrightjj!
Reply With Quote
  #6   (View Single Post)  
Old 6th June 2008
redwil redwil is offline
New User
 
Join Date: Jun 2008
Posts: 1
Thanked 0 Times in 0 Posts
Default

Hello all,

Just to let you know that I had the same problems w/ FreeBSD 7.0 and netbeans 6.1.

First I upgraded the whole system portupgrade -aP, then portinstall netbeans and make install clean from java/jdk16. no joy.

I noticed that netbeans-6.1 depends on diablo-jdk-1.5 so, i forced deinstalled diablo-jdk and voila! Netbeans works although it complains about profiler and soloaris.

It seems to me that even if jdk16 is installed netbeans port wants to install diablo-jdk.

Thanks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Netbeans running application problem. bsdnewbie999 Programming 4 12th June 2009 10:22 AM
Java SE and Netbeans on OpenBSD? SunSpyda OpenBSD Packages and Ports 7 17th May 2009 09:45 PM
[java] netbeans 6.0.1 and applets not work Mak-Di FreeBSD General 1 12th May 2008 06:04 PM


All times are GMT. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick