DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 8th October 2008
dejabu18 dejabu18 is offline
Port Guard
 
Join Date: May 2008
Posts: 16
Thanked 0 Times in 0 Posts
Default sendmail dont boot

hi guys I installed a mail server Im using sendmail all works well but the only problem is when I reboot the server the sendmail demon dont start I already see the boot files configuration in /etc/rc.conf

Code:
rc_debug="YES"
mta_start_script="/etc/rc.sendmail"
defaultrouter="192.168.0.1"
hostname="host.local"
ifconfig_fxp0="inet 192.168.0.239  netmask 255.255.255.0"
linux_enable="YES"
sendmail_submit_enable="NONE"
sendmail_enable="YES"
sendmail_outbound_enable="NONE"
sendmail_msp_queue_enable="NONE"
sshd_enable="YES"
usbd_enable="YES"
dhcpd_enable="YES"
dhcpd_ifaces="fxp0"
snmpd_enable="YES"
named_enable="YES"
on the /etc directory I have a file called rc.sendmail but the executable flag is not on for this file is that normal?

I check this file(rc.sendmail) and I think its the file whos start the service

I made some chenges to the /etc/defaults/rc.conf too
Code:
##############################################################
###  Mail Transfer Agent (MTA) options  ######################
##############################################################

mta_start_script="/etc/rc.sendmail"
                        # Script to start your chosen MTA, called by /etc/rc.
# Settings for /etc/rc.sendmail and /etc/rc.d/sendmail:
sendmail_enable="YES"   # Run the sendmail inbound daemon (YES/NO).
sendmail_pidfile="/var/run/sendmail.pid"        # sendmail pid file
sendmail_procname="/usr/sbin/sendmail"          # sendmail process name
sendmail_flags="-L sm-mta -bd -q30m" # Flags to sendmail (as a server)
sendmail_submit_enable="NO"     # Start a localhost-only MTA for mail submission
sendmail_submit_flags="-L sm-mta -bd -q30m -ODaemonPortOptions=Addr=localhost"
                                # Flags for localhost-only MTA
sendmail_outbound_enable="NO"   # Dequeue stuck mail (YES/NO).
sendmail_outbound_flags="-L sm-queue -q30m" # Flags to sendmail (outbound only)
sendmail_msp_queue_enable="NO"  # Dequeue stuck clientmqueue mail (YES/NO).
sendmail_msp_queue_flags="-L sm-msp-queue -Ac -q30m"
                                # Flags for sendmail_msp_queue daemon.
I dont have nothing in my log files /var/logs/messages and /var/logs/maillog

I already try to reinstall using Make in the instalation directory but nothing

do you know what wrong


thanks for help
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer dont take rights mururoa FreeBSD General 3 5th October 2009 12:54 PM
Sendmail Timmy66 OpenBSD General 11 19th October 2008 03:01 PM
Dual-boot laptop won't boot OpenBSD after upgrade to 4.3 kbeaucha OpenBSD Installation and Upgrading 17 30th May 2008 02:40 PM
Using sendmail in a cron job erehwon OpenBSD General 6 15th May 2008 09:03 PM
Sendmail, issues... pcfxer FreeBSD General 2 8th May 2008 10:07 AM


All times are GMT. The time now is 07:56 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick