DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 9th October 2008
edhunter's Avatar
edhunter edhunter is offline
Real Name: Georgi Iovchev
Port Guard
 
Join Date: May 2008
Location: Sofia, Bulgaria
Posts: 41
Thanked 0 Times in 0 Posts
Default can not wake on lan afer shutdown -p (may be acpi related)

Hello guys.
Recently I posted a mail to freebsd-stable list about my problem, but still no response. I'll post my problem here too:

"I have a shutdown problem. I have a machine with gigabyte GA-G33M-DS2R motherboard. Integrated network card is Realtek 8111B. I can not wake the computer after I shutdown it from FreeBSD.
It is a dualboot system - windows xp and freebsd. If I shutdown the computer from windows - later I can wake it up with magic packet. Even if I shutdown the machine on the boot menu with the power button - than later I can wake on lan. The only situation where I CANNOT wake it is when I shutdown the machine from freebsd (halt -p).

First I tested with 7.0-RELEASE-p5 amd64 (RELENG_7_0) and than I upgraded to 7.1 PRERELASE amd64 (RELENG_7). I also tested with two network cards - the integrated one Realtek 8111B and another one Intel PRO1000PT PCI-E with WOL enabled.

With both nics and both freebsd versions the situation is the same - after shutdown from bsd the computer is not able to wake on lan. The indication on the switch port says that after shut down there is active link.

Here is some information after last update:
Code:
[root at backup ~]# uname -a
FreeBSD backup.pulsar.bg 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #1: Mon Oct  6 17:01:26 EEST 2008     root at backup.pulsar.bg:/usr/obj/usr/src/sys/MYCONF  amd64

[root at backup ~]# pciconf -lv
...
re0 at pci0:3:0:0: class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x01 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
    class      = network
    subclass   = ethernet
...
em0 at pci0:1:0:0: class=0x020000 card=0x10838086 chip=0x10b98086 rev=0x06 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82572EI PRO/1000 PT Desktop Adapter (Copper)'
    class      = network
    subclass   = ethernet
...

[root at backup ~]# ifconfig re0 wol
[root at backup ~]# ifconfig em0 wol
[root at backup ~]# ifconfig
em0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
        ether 00:1b:21:22:52:cd
        media: Ethernet autoselect
        status: no carrier
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
        ether 00:1f:d0:24:19:e9
        inet 78.142.42.158 netmask 0xfffffff0 broadcast 78.142.42.159
        inet 192.168.0.6 netmask 0xffffff00 broadcast 192.168.0.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet 127.0.0.1 netmask 0xff000000
I suppose that I should post more info but I dont know what exactly is needed.

Need help!
10x in advance

Georgi Iovchev"
http://lists.freebsd.org/pipermail/f...er/045689.html


I hope that someone here can help me. This machine should be running 24/7. The reason I need wake on lan is because I have ups in my network, and I use wake on lan to wake up machines in case of shutdown.

Last edited by edhunter; 9th October 2008 at 06:04 PM.
Reply With Quote
  #2   (View Single Post)  
Old 9th October 2008
graudeejs's Avatar
graudeejs graudeejs is offline
Real Name: Aldis Berjoza
formerly killasmurf86
 
Join Date: Jul 2008
Location: Riga, Latvia
Posts: 588
Thanked 29 Times in 26 Posts
Default

dunno if it helps, but
Have you tried to shutdown freebsd with shutdown -h ?
it won't completely power down pc..... try it
Reply With Quote
  #3   (View Single Post)  
Old 9th October 2008
richardpl richardpl is offline
Spam Deminer
 
Join Date: May 2008
Location: Croatia
Posts: 284
Thanked 25 Times in 24 Posts
Default

Depends on driver. (Some drivers do not have wol implementation)

wol* can be enabled via ifconfig(8)
Reply With Quote
  #4   (View Single Post)  
Old 9th October 2008
edhunter's Avatar
edhunter edhunter is offline
Real Name: Georgi Iovchev
Port Guard
 
Join Date: May 2008
Location: Sofia, Bulgaria
Posts: 41
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by killasmurf86 View Post
dunno if it helps, but
Have you tried to shutdown freebsd with shutdown -h ?
it won't completely power down pc..... try it
...hmm I havent tried that way. Actually if pc can be waked up afeter shutdown -h -- it will be ok for me. 10x for the idea.


Quote:
Originally Posted by richardpl View Post
Depends on driver. (Some drivers do not have wol implementation)

wol* can be enabled via ifconfig(8)
Yes if_em doesn support it, but if_re support it... and in my first post i have tried it. It doesnt help.
Reply With Quote
  #5   (View Single Post)  
Old 9th October 2008
graudeejs's Avatar
graudeejs graudeejs is offline
Real Name: Aldis Berjoza
formerly killasmurf86
 
Join Date: Jul 2008
Location: Riga, Latvia
Posts: 588
Thanked 29 Times in 26 Posts
Default

Quote:
Originally Posted by edhunter View Post
...hmm I havent tried that way. Actually if pc can be waked up afeter shutdown -h -- it will be ok for me. 10x for the idea.
Let us know, if it works
Reply With Quote
  #6   (View Single Post)  
Old 10th October 2008
edhunter's Avatar
edhunter edhunter is offline
Real Name: Georgi Iovchev
Port Guard
 
Join Date: May 2008
Location: Sofia, Bulgaria
Posts: 41
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by killasmurf86 View Post
Let us know, if it works
It doesnt work ((

shutdown -h now
or
halt

cant wake up machine with wol
Reply With Quote
  #7   (View Single Post)  
Old 10th October 2008
richardpl richardpl is offline
Spam Deminer
 
Join Date: May 2008
Location: Croatia
Posts: 284
Thanked 25 Times in 24 Posts
Default

What happens if you just do all of this in single user mode. So that various rc scripts do not get executed.
Reply With Quote
  #8   (View Single Post)  
Old 10th October 2008
edhunter's Avatar
edhunter edhunter is offline
Real Name: Georgi Iovchev
Port Guard
 
Join Date: May 2008
Location: Sofia, Bulgaria
Posts: 41
Thanked 0 Times in 0 Posts
Default

havent tried it in single user mode ... monday will test.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
shutdown message Mr-Biscuit FreeBSD General 1 16th November 2008 11:59 PM
enable shutdown/reboot xfce4 rex FreeBSD General 16 17th October 2008 02:19 PM
Yahoo! related Pidgin problems... BSDfan666 General software and network 10 28th September 2008 02:39 AM
Shutdown problems radtek FreeBSD General 11 13th September 2008 12:42 AM
OpenBSD-related websites bienc OpenBSD General 7 12th May 2008 09:15 PM


All times are GMT. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick