DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th October 2008
harisman's Avatar
harisman harisman is offline
Fdisk Soldier
 
Join Date: May 2008
Location: Hellas (Greece)
Posts: 66
Thanked 5 Times in 4 Posts
Default Nautilus problem

Hi to all

I am using nautilus as my main file manager (with --no-desktop) from inside windowmaker and since a few days I cannot see the "Computer", "Trash" or any other gnome vfs specific locations and I got the message "Nautilus cannot handle computer: locations."

I also tried fluxbox with similar setup and I got exactly the same problem.

I also created a new clean user for testing purposes with the same results.

When switching from the windomaker session to gnome-session, the nautilus working without any problems!


My related windowmaker autostartup script:
Code:
496:haris@promitheas:~$ cat ~/GNUstep/Library/WindowMaker/autostart
#!/usr/local/bin/bash
#
xset m 20/10 4

ps aux | awk '
BEGIN { a=b=c=0 }
/gnome-vfs-daemon/      { ++a }
/kdeinit/               { ++b }
/gnome-settings-daemon/ { ++c }
/gpilotd/               { ++d }
END {
       if ( a==0 ) system("/usr/local/libexec/gnome-vfs-daemon &")
       if ( b==0 ) system("kdeinit")
       if ( c==0 ) system("/usr/local/libexec/gnome-settings-daemon&")
       if ( d==0 ) system("/usr/local/libexec/gpilotd &")
}'
The related gnome staff are loaded:
Code:
497:haris@promitheas:~$ ps aux | egrep -i 'vfs|settings'
haris       1518  0.0  0.5  9756  5308  ??  S     9:27PM   0:00.06 /usr/local/libexec/gnome-vfs
-daemon
haris       1549  0.0  2.7 36532 27416  ??  I     9:27PM   0:01.26 /usr/local/libexec/gnome-set
tings-daemon
The related installed versions:
Code:
502:haris@promitheas:~$ pkg_version -v | egrep -i 'vfs|settings|nautilus'
gnome-settings-daemon-2.22.2.1_1    =   up-to-date with port
gnome-vfs-2.22.0_2                  =   up-to-date with port
gstreamer-plugins-gnomevfs-0.10.20_1,3  =   up-to-date with port
gvfs-0.2.5                          =   up-to-date with port
nautilus-2.22.5.1_1                 =   up-to-date with port
nautilus-cd-burner-2.22.1_2         =   up-to-date with port
Any ideas?

Edit:
Note #1: I forgot to mention that I am using gdm as display manager.
Note #2: My policy is to update the ports collection and do a full portupgrade every 6 months on this desktop .

Thank you

Last edited by harisman; 19th October 2008 at 07:33 PM.
Reply With Quote
  #2   (View Single Post)  
Old 20th October 2008
graudeejs's Avatar
graudeejs graudeejs is offline
Real Name: Aldis Berjoza
formerly killasmurf86
 
Join Date: Jul 2008
Location: Riga, Latvia
Posts: 588
Thanked 29 Times in 26 Posts
Default

have you loaded
/usr/local/libexec/gnome-settings-daemon
I dunno, but might help
Reply With Quote
  #3   (View Single Post)  
Old 20th October 2008
harisman's Avatar
harisman harisman is offline
Fdisk Soldier
 
Join Date: May 2008
Location: Hellas (Greece)
Posts: 66
Thanked 5 Times in 4 Posts
Default

Yes, this is loaded, it shown on the process list
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hald(1) and nautilus(1) does not automount media vermaden FreeBSD Ports and Packages 3 2nd November 2009 06:17 PM
Boot problem. Geometry problem? gulanito FreeBSD Installation and Upgrading 0 3rd July 2009 03:03 AM


All times are GMT. The time now is 02:34 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick