DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th November 2008
r4e r4e is offline
New User
 
Join Date: Oct 2008
Posts: 1
Thanked 0 Times in 0 Posts
Default The Basics

Long story short. I've done the the following things.

1) port install clean for xemacs
2) port install clean for slime
3) slime pulled up emacs as a requirement and compiles it
4) emacs conflicts with xemacs and refuse to install
5) port uninstalled xemacs
6) reinstall slime
7) install complete

So my questions for basic unix:

When I get the compile conflict errors, could I have somehow found which packages were installed and removed each and every port that slime pulled in as dependencies?
Reply With Quote
  #2   (View Single Post)  
Old 14th November 2008
jb_daefo jb_daefo is offline
Package Pilot
 
Join Date: May 2008
Posts: 196
Thanked 5 Times in 5 Posts
Default

make build-depends-list; make run-depends-list
slime appears to have only emacs and gmake as dependencies.
You'd want to keep gmake...
..............
I advise aliasing "make build-depends-list" to something like "deps"
as you'd use that often
....................
__________________
using /LOOKAT/ with /var/db/pkg files and portmaster/aliases/pipes/find/grep to meteorically speedup port upgrades/installs...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick