DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 16th November 2008
Bubba_HoTep Bubba_HoTep is offline
New User
 
Join Date: Nov 2008
Posts: 6
Thanked 0 Times in 0 Posts
Default FreeBSD hangs on boot

Gidday FreeBSDers

I've a FreeBSD 7.0 64 bit server which has a boot problem that is driving me nuts.

It takes multiple gos to boot successfully. Most times it just hangs, always at the same point in the boot sequence -

firewire 0: bus manager 0 (me)

I have to kill the power and reboot and eventually I get lucky and it boots.

This didn't bother me so much cos once booted the server stayed on - but I'm testing an UPS with the box and need to reboot to test my shutdown scripts - and it's getting to be a real pain.

I also suspect that my hitting the power switch may be causing filesystem corruption - my first post on this board http://www.daemonforums.org/showthread.php?t=2342 was about this. I fixed that problem with a fsck - only for the problem to reappear.

The OS disk is a 4Gb CF card - and so I don't have a swap partition. The CF card I haven't set ro yet as I'm still messing about with bits and pieces.

All the hardware (apart from the CF card) is known to be good as this box was running problem free with Linux before i wiped it and put on FreeBSD.

When the server boots its runs fine (apart from the FS errors noted above)

dmesg doesn't throw up any errors that I can see either...


As I see it there's 3 possible causes:

1) Something wrong with my CF card (which would explain FS errors)

2) something wrong with my FreeBSD install

3) something that I haven't thought of


Can anyone shed any light?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD 4.6 i386 boot hangs with old gateway system - resolved comet--berkeley OpenBSD Installation and Upgrading 6 22nd July 2011 08:15 AM
make build hangs chill OpenBSD Installation and Upgrading 5 2nd April 2009 05:03 PM
openbsd hangs momentarily at boot bogd OpenBSD General 11 9th January 2009 02:53 PM
FreeBSD 7.0 hangs with USB disk drive. map7 FreeBSD General 7 9th August 2008 03:02 AM
FreeBSD boot problem kdi FreeBSD General 2 25th May 2008 07:09 AM


All times are GMT. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick