DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 17th November 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default connect to OpenBSD BOX with VNC

I use OpenBSD 4.4 with Gnome , I have another computer use FreeBSD and Windows XP , can someone guide me how I can connect to OpenBSD machine with VNC from another system.???

Please guide me step by step
Reply With Quote
  #2   (View Single Post)  
Old 17th November 2008
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 768
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by mfaridi View Post
I use OpenBSD 4.4 with Gnome , I have another computer use FreeBSD and Windows XP , can someone guide me how I can connect to OpenBSD machine with VNC from another system.???

Please guide me step by step
http://www.freebsddiary.org/tightvnc.php

Basic configuration of VNC server is the same on any Unix-like system.

Now the deeper problems are:

1. Proper PF rules which will enable you to get to your OpenBSD box?

2. DNS issues. Do you have static or Dynamic IP? Are you doing NAT or not?

Without knowing the topology of your network I can not help you with
1 and 2.

Cheers,
OKO
Reply With Quote
  #3   (View Single Post)  
Old 17th November 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

Step-by-step for mfaridi:
  1. Install tightvnc package.
  2. Open the appropriate ports on your network. By default, the port number for incoming connections from VNC clients to the server is 5900+display number. If you will be using VNC clients with -listen, open the appropriate ports as necessary.
  3. Run the server from the connect-to userid on your OpenBSD platform for the first time:
    $ vncserver
    Provide a connection password for normal connection.
    Optionally provide a display only password for restricted connection.
  4. Kill the server:
    $ pkill vnc
  5. Edit ~/.vnc/xstartup. Have it start gnome-session, rather than running the default fvwm window manager.
  6. Rerun the vncserver
  7. Connect from your VNC client(s).

Last edited by jggimi; 17th November 2008 at 08:00 PM.
Reply With Quote
  #4   (View Single Post)  
Old 18th November 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by jggimi View Post
Step-by-step for mfaridi:
  1. Install tightvnc package.
  2. Open the appropriate ports on your network. By default, the port number for incoming connections from VNC clients to the server is 5900+display number. If you will be using VNC clients with -listen, open the appropriate ports as necessary.
  3. Run the server from the connect-to userid on your OpenBSD platform for the first time:
    $ vncserver
    Provide a connection password for normal connection.
    Optionally provide a display only password for restricted connection.
  4. Kill the server:
    $ pkill vnc
  5. Edit ~/.vnc/xstartup. Have it start gnome-session, rather than running the default fvwm window manager.
  6. Rerun the vncserver
  7. Connect from your VNC client(s).
I would be grateful if you give more information about this line
Code:
Edit ~/.vnc/xstartup. Have it start gnome-session, rather than running the default fvwm window manager
I want connect to my OpenBSD BOX , and use Gnome or XFCE.
Reply With Quote
  #5   (View Single Post)  
Old 18th November 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

It's a shell script, mfaridi. Look at your the script, and compare it to the default xinitrc: /usr/X11/xinit/xinitrc. Then, look at your ~/.xinitrc or ~/.xsession script, and compare.

[spoon-feed]

To have it start gnome, it should look something like:
Code:
#!/bin/sh
/usr/local/bin/gnome-session
To have it start xfce, it should look something like:
Code:
#!/bin/sh
/usr/local/bin/startxfce4
[/spoon-feed]
Reply With Quote
  #6   (View Single Post)  
Old 18th November 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

I put
Code:
#!/bin/sh
/usr/local/bin/startxfce4
and

Code:
#!/bin/sh
/usr/local/bin/gnome-session
but when I connect to OpenBSD box with VNCviewer I login into very old windows manager and I can not connect with Gnome or XFCE
Reply With Quote
  #7   (View Single Post)  
Old 18th November 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

oh my GOD I can connect with XFCE , first I run this command
and kill vncserver and then start it agian

Code:
pkill vnc
thanks
Reply With Quote
  #8   (View Single Post)  
Old 12th April 2010
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

what I must do when I want vncserver run in startup ?
I vnc connection enough secure ?
what I must do for better secure connection ?
__________________
http://www.mfaridi.com
First site about FreeBSD and OpenBSD in persian or Farsi.
Reply With Quote
  #9   (View Single Post)  
Old 13th April 2010
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 768
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by mfaridi View Post
what I must do when I want vncserver run in startup ?
I vnc connection enough secure ?
what I must do for better secure connection ?
If it is a server it should run 24/7 If you want to run VNC server on your desktop
then you can put something like

Code:
exec vncserver
into your .xsession.

You could probable run it as a local daemon by editing rc.local.

TightVNC uses C, C++, and Java. You can imagine how secure is Java code.
On another hand you can enhance security by SSH tunneling and using SSL.
It kind of defeats purposes because you could as well run remote X clients on
your local X server with ssh -Y

For client side if you must use VNC I strongly recommend you to use SSVNC.

http://www.karlrunge.com/x11vnc/ssvnc.html

The only claim to fame of VNC is portability but even that is very questionable.
There are many more far more suitable protocols for desktop virtualization like
Ericom Blaze, OpenNX, Citrix, RDP...

What do you actually want to accomplish?
Reply With Quote
Old 14th April 2010
tetrodozombie tetrodozombie is offline
Real Name: bill slusser
Banned
 
Join Date: Dec 2009
Location: atlanta, ga
Posts: 82
Thanked 1 Time in 1 Post
Default Does anyone use a .xinitrc in the $HOME directory?

I find that I have no problems ever when I have an .xinitrc file that launches my window manager in my home directory. I can start X by "xinit" or "startx" and it will produce the same result, which is starting Fluxbox.

I don't know if you need to go through all that trouble. I didn't look it up, it's just a suggestion for you to try real quick when you get frustrated or you've exhausted other options.

Quick and painless is usually the way to go.

I might try putting VNC on this OpenBSD box and see what happens myself later today.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to connect Free VPN with OpenBSD mfaridi OpenBSD General 19 9th February 2009 12:52 PM
connect to openbsd box (ssh) milo974 Other BSD and UNIX/UNIX-like 4 3rd January 2009 02:44 AM
FTP-Proxy cannot connect plexter OpenBSD Packages and Ports 6 11th October 2008 05:59 PM
wpa_supplicant won't connect to AP adamk FreeBSD General 4 24th September 2008 08:09 AM


All times are GMT. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick