DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 19th November 2008
delboy's Avatar
delboy delboy is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 63
Thanked 0 Times in 0 Posts
Default KDE3 install stop error

KDE3 3.5.10 on FreeBSD 7.0

Code:
gmake[2]: Entering directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel'
Making all in common
gmake[3]: Entering directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel/common'
Making all in libgettext
gmake[4]: Entering directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel/common/libgettext'
/bin/sh /usr/local/bin/libtool --silent --tag=CXX   --mode=compile c++ -DHAVE_CONFIG_H -I. -I../../..   -D_THREAD_SAFE -pthread -DQT_THREAD_SUPPORT   -I/usr/local/include -I/usr/local/include  -I/usr/local/include -D_GETOPT_H -D_THREAD_SAFE   -Wno-long-long -Wundef -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -fno-strict-aliasing -pipe -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -MT pofiles.lo -MD -MP -MF .deps/pofiles.Tpo -c -o pofiles.lo pofiles.cc
pofiles.cc:450:5: warning: "YY_STACK_USED" is not defined
pofiles.cc:1518:5: warning: "YY_MAIN" is not defined
In file included from pofiles.cc:249:
/usr/local/include/FlexLexer.h:130: error: expected unqualified-id before numeric constant
pofiles.cc: In member function 'virtual int GettextBaseFlexLexer::yylex()':
pofiles.cc:575: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc:731: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc:754: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In constructor 'GettextBaseFlexLexer::GettextBaseFlexLexer(std::istream*, std::ostream*)':
pofiles.cc:871: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In destructor 'virtual GettextBaseFlexLexer::~GettextBaseFlexLexer()':
pofiles.cc:883: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'virtual void GettextBaseFlexLexer::switch_streams(std::istream*, std::ostream*)':
pofiles.cc:890: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'int GettextBaseFlexLexer::yy_get_next_buffer()':
pofiles.cc:943: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'void GettextBaseFlexLexer::yyunput(int, char*)':
pofiles.cc:1138: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'int GettextBaseFlexLexer::yyinput()':
pofiles.cc:1180: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'virtual void GettextBaseFlexLexer::yyrestart(std::istream*)':
pofiles.cc:1239: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc:1242: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'virtual void GettextBaseFlexLexer::yy_switch_to_buffer(yy_buffer_state*)':
pofiles.cc:1249: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc:1252: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc:1260: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'void GettextBaseFlexLexer::yy_load_buffer_state()':
pofiles.cc:1274: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'virtual void GettextBaseFlexLexer::yy_delete_buffer(yy_buffer_state*)':
pofiles.cc:1311: error: 'yy_current_buffer' was not declared in this scope
pofiles.cc: In member function 'void GettextBaseFlexLexer::yy_flush_buffer(yy_buffer_state*)':
pofiles.cc:1353: error: 'yy_current_buffer' was not declared in this scope
gmake[4]: *** [pofiles.lo] Error 1
gmake[4]: Leaving directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel/common/libgettext'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel/common'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/devel/kdesdk3.
*** Error code 1

Stop in /usr/ports/devel/kdesdk3.
Would be very grateful if some one could point me in the right direction on how to proceed with this install.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
bmake: don't know how to make install. Stop J05HYYY NetBSD Package System (pkgsrc) 5 10th October 2009 04:19 PM
Java install error delboy FreeBSD Ports and Packages 2 26th August 2009 09:34 AM
Package install error. delboy FreeBSD Ports and Packages 10 25th March 2009 05:54 PM
Does KDE4 require KDE3? troberts FreeBSD Ports and Packages 22 13th August 2008 07:55 PM
snort install error ijk FreeBSD Installation and Upgrading 1 11th August 2008 10:53 AM


All times are GMT. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick