DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th November 2008
beandip beandip is offline
Port Guard
 
Join Date: Jul 2008
Posts: 14
Thanked 0 Times in 0 Posts
Default Clientmqueue keeps filling /var and I don't know why

I have a simple BAMP server for our intranet with FreeBSD 6.3 64bit.

It has been running flawless for 2.5 years but suddenly now I am having to go clear /var/clientmqueue everyday because it keeps filling my /var up and causes havoc.

I am guessing it has something to do with sendmail but I don't have anything configured to send out to my knowledge. The only thing I can think of is that I recently changed email servers and maybe it was sending something out (but I don't know what and why so much).

Any ideas?
Reply With Quote
  #2   (View Single Post)  
Old 19th November 2008
anomie's Avatar
anomie anomie is offline
Local
 
Join Date: Apr 2008
Location: Texas
Posts: 446
Thanked 69 Times in 46 Posts
Default

Hi there,

I am not sure what /var/clientmqueue is used for exactly (and it does not exist on my FBSD 6.3 server). In any case, what I would do is start by seeing what is writing to it:
# lsof +D /var/clientmqueue

Install from sysutils/lsof if needed.
__________________
Kill your t.v.
Reply With Quote
  #3   (View Single Post)  
Old 19th November 2008
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

clientmqueue (which is usually under /var/spool rather than under /var) is the queue for locally generated outbound email (like system emails). If you don't have sendmail running to process the mails and empty the queue, it will just fill up. So either run sendmail's queue runner (which should be running anyway, because it's the default in /etc/defaults/rc.conf) or find out why your local queue fills up. You can view the df* and qf* files to see where these mesages come from. Do take it seriously: you may have a compromised website on your system, used to send out spam.
Reply With Quote
  #4   (View Single Post)  
Old 19th November 2008
beandip beandip is offline
Port Guard
 
Join Date: Jul 2008
Posts: 14
Thanked 0 Times in 0 Posts
Default

You are correct... the location is /var/spool/clientmqueue.

Looking at the files it looks like some tiny stuff related to a Joomla site on the server. The file typically are an email to 127.0.0.1 that gets rejected.

In /etc/rc.conf it says sendmail_enable="NO" and I have changed that to yes.

I'll see if that fixes it. Thanks!
Reply With Quote
  #5   (View Single Post)  
Old 19th November 2008
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

I don't think so. The sendmail_enable directive operates the SMTP daemon. In other words, it opens a mailserver on your port 25 accepting incoming smtp connections from the world. Probably not what you want

If you have no sendmail-related entries in rc.conf, the defaults in /etc/defaults/rc.conf will be used, and those defaults are that a local Sendmail queue runner will be started at boot time, and that local mail will be processed every 15 minutes.

Code:
grep sendmail /etc/defaults/rc.conf
will reveal all.

Your process list should show:

Code:
   970  ??  Is     0:00.17 sendmail: Queue runner@00:15:00 for /var/spool/clientmqueue (sendmail)

Last edited by DutchDaemon; 19th November 2008 at 10:20 PM.
Reply With Quote
  #6   (View Single Post)  
Old 19th November 2008
beandip beandip is offline
Port Guard
 
Join Date: Jul 2008
Posts: 14
Thanked 0 Times in 0 Posts
Default

Changed it back.

grep sendmail /etc/defaults/rc.conf

Quote:
mta_start_script="/etc/rc.sendmail"
# Settings for /etc/rc.sendmail and /etc/rc.d/sendmail:
sendmail_enable="NO" # Run the sendmail inbound daemon (YES/NO).
sendmail_pidfile="/var/run/sendmail.pid" # sendmail pid file
sendmail_procname="/usr/sbin/sendmail" # sendmail process name
sendmail_flags="-L sm-mta -bd -q30m" # Flags to sendmail (as a server)
sendmail_submit_enable="YES" # Start a localhost-only MTA for mail submission
sendmail_submit_flags="-L sm-mta -bd -q30m -ODaemonPortOptions=Addr=localhost"
sendmail_outbound_enable="YES" # Dequeue stuck mail (YES/NO).
sendmail_outbound_flags="-L sm-queue -q30m" # Flags to sendmail (outbound only)
sendmail_msp_queue_enable="YES" # Dequeue stuck clientmqueue mail (YES/NO).
sendmail_msp_queue_flags="-L sm-msp-queue -Ac -q30m"
# Flags for sendmail_msp_queue daemon.
Reply With Quote
  #7   (View Single Post)  
Old 19th November 2008
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Based on that, sendmail should be running in your process list (as shown above). If not, try
Code:
/etc/rc.d/sendmail start
by hand and watch /var/log/maillog for any activity or errors. You can also take a look at
Code:
/etc/rc.d/sendmail rcvar
to see whether the correct settings are in place.

Last edited by DutchDaemon; 19th November 2008 at 10:46 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:55 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick