DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 20th December 2008
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default Mount DVD - invalid argument.

I have two DVD drives on my machine.

/dev looks like this:

Code:
acd0            cuad0.init      mdctl           random          ttyv7
acd0t01         cuad0.lock      mem             sndstat         ttyv8
acd1            dcons           midistat        stderr          ttyv9
acpi            devctl          mixer0          stdin           ttyva
ad0             devstat         net             stdout          ttyvb
ad0s1           dgdb            net1            sysmouse        ttyvc
ad0s1a          dsp0.0          net2            ttyd0           ttyvd
ad0s1b          dumpdev         net3            ttyd0.init      ttyve
ad0s1c          fd              network         ttyd0.lock      ttyvf
ad0s1d          fido            nfs4            ttyp0           ugen0
ad0s1e          geom.ctl        nfslock         ttyp1           ugen0.1
ad0s1f          io              null            ttyp2           ums0
ata             kbd0            nvidia0         ttyp3           urandom
atkbd0          kbd1            nvidiactl       ttyv0           usb
audit           kbdmux0         pci             ttyv1           usb0
bpf0            klog            ppi0            ttyv2           usb1
console         kmem            ptyp0           ttyv3           xpt0
consolectl      log             ptyp1           ttyv4           zero
ctty            lpt0            ptyp2           ttyv5
cuad0           lpt0.ctl        ptyp3           ttyv6
acd0 is my burner, acd1 is my non-burner/rom drive.

/etc/fstab looks like this:
Code:
# Device		Mountpoint	FStype	Options		Dump	Pass#
/dev/ad0s1b		none		swap	sw		0	0
/dev/ad0s1a		/		ufs	rw		1	1
/dev/ad0s1e		/tmp		ufs	rw		2	2
/dev/ad0s1f		/usr		ufs	rw		2	2
/dev/ad0s1d		/var		ufs	rw		2	2
/dev/acd0		/cdrom		cd9660	ro,noauto	0	0
/dev/acd1		/cdrom		cd9660	ro,noauto	0	0
/dev/da0s1		/mnt/flash	msdosfs	rw,noauto	0	0
I have enabled the atapi support in /boot/loader.conf

snd_hda_load="YES"
loader_logo="beastiebw"
nvidia_load="YES"
hw.ata.atapi_dma="1"

however mounting still fails -
sudo mount /dev/acd0 /cdrom
mount: /dev/acd0 : Invalid argument

I've tried using (what seems to me) a more appropriate mount point, creating /dvdburner and /dvdrom respectively.

I've also tried variations on the mount command.

Where am I going wrong please?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mount-msdosfs /dev/dao: : Invalid argument harold FreeBSD General 5 12th December 2010 06:59 AM
Pidgin MSN connection issues, invalid SSL Certificate chain TerryP Guides 5 8th December 2010 01:06 AM
how to mount ext3 guitarscn FreeBSD General 2 26th August 2009 07:31 PM
Cannot mount (NTFS) IIMarckus OpenBSD General 4 11th August 2008 08:44 PM
Invalid capture filter: "not ip host "! ccc FreeBSD General 2 19th June 2008 08:12 PM


All times are GMT. The time now is 08:08 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick