DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th December 2008
nico_h nico_h is offline
Port Guard
 
Join Date: Jun 2008
Posts: 23
Thanked 0 Times in 0 Posts
Default amarok doesn't compile

hi, I tried to make install clean in /usr/ports/audio/amarok but it stopps at an error :

Code:
Making all in mtp
gmake[5]: Entering directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/mtp'
/bin/sh /usr/local/bin/libtool --silent --tag=CXX   --mode=compile c++ -DHAVE_CONFIG_H -I. -I../../../.. -I../../../../amarok/src -I../../../../amarok/src -I../../../../amarok/src/amarokcore -I../../../../amarok/src/amarokcore -I../../../../amarok/src/engine -I../../../../amarok/src/engine -I../../../../amarok/src/mediadevice -I/usr/local/include/taglib   -I/usr/local/include  -I/usr/local/include  -D_THREAD_SAFE -pthread -DQT_THREAD_SUPPORT   -I/usr/local/include -I/usr/local/include  -I/usr/local/include -D_GETOPT_H -D_THREAD_SAFE   -Wno-long-long -Wundef -Wall -W -Wpointer-arith -O2 -fno-strict-aliasing -pipe -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -MT mtpmediadevice.lo -MD -MP -MF .deps/mtpmediadevice.Tpo -c -o mtpmediadevice.lo mtpmediadevice.cpp
/usr/local/include/libmtp.h: In member function 'virtual MediaItem* MtpMediaDevice::copyTrackToDevice(const MetaBundle&)':
/usr/local/include/libmtp.h:489: error: too many arguments to function 'int LIBMTP_Send_Track_From_File(LIBMTP_mtpdevice_t*, const char*, LIBMTP_track_t*, int (*)(uint64_t, uint64_t, const void*), const void*)'
mtpmediadevice.cpp:302: error: at this point in file
mtpmediadevice.cpp: In member function 'uint32_t MtpMediaDevice::getDefaultParentId()':
mtpmediadevice.cpp:383: warning: deprecated conversion from string constant to 'char*'
/usr/local/include/libmtp.h: In member function 'LIBMTP_album_t* MtpMediaDevice::getOrCreateAlbum(QPtrList<MediaItem>*)':
/usr/local/include/libmtp.h:533: error: too many arguments to function 'int LIBMTP_Create_New_Album(LIBMTP_mtpdevice_t*, LIBMTP_album_t*)'
mtpmediadevice.cpp:532: error: at this point in file
/usr/local/include/libmtp.h: In member function 'uint32_t MtpMediaDevice::createFolder(const char*, uint32_t)':
/usr/local/include/libmtp.h:508: error: too few arguments to function 'uint32_t LIBMTP_Create_Folder(LIBMTP_mtpdevice_t*, char*, uint32_t, uint32_t)'
mtpmediadevice.cpp:611: error: at this point in file
/usr/local/include/libmtp.h: In member function 'void MtpMediaDevice::playlistFromItem(MtpMediaItem*)':
/usr/local/include/libmtp.h:521: error: too many arguments to function 'int LIBMTP_Create_New_Playlist(LIBMTP_mtpdevice_t*, LIBMTP_playlist_t*)'
mtpmediadevice.cpp:916: error: at this point in file
gmake[5]: *** [mtpmediadevice.lo] Error 1
gmake[5]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/mtp'
gmake[4]: *** [all-recursive] Error 1
gmake[4]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/audio/amarok.
*** Error code 1

Stop in /usr/ports/audio/amarok.
[root@xochipilli /usr/ports/audio/amarok]#
There are not much results in google when looking for /usr/local/include/libmtp.h:489: error
but there's a solved bug in gentoo, for instance :
http://bugs.gentoo.org/230885

As it seems to be related to mtp device support, I did make config to uncheck this option.

Code:
[root@xochipilli /usr/ports/audio/amarok]# make showconfig
===> The following configuration options are available for amarok-1.4.10:
     GPOD=on "iPod support"
     NJB=on "Creative Nomad and Dell support"
     MTP=off "MTP device support"
     LIBVISUAL=off "libvisual support"
     OPENGL=on "OpenGL support"
     AMAZON=on "Amazon cover fetching support"
     MYSQL=off "Use MySQL as collection backend"
     POSTGRESQL=off "Use PostgreSQL as collection backend"
     HIDEMENUBAR=off "Revert the 'Hide Menubar' feature"
===> Use 'make config' to modify these settings
[root@xochipilli /usr/ports/audio/amarok]#
But if I rerun make install clean or make reinstall, the compiler still wants to try to compile in that directory, as if I didn't change anything to the options :
Code:
gmake[6]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/daap'
gmake[5]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/daap'
Making all in ipod
gmake[5]: Entering directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/ipod'
gmake[5]: Nothing to be done for `all'.
gmake[5]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/ipod'
Making all in njb
gmake[5]: Entering directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/njb'
gmake[5]: Nothing to be done for `all'.
gmake[5]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/njb'
Making all in mtp
gmake[5]: Entering directory `/usr/ports/audio/amarok/work/amarok-1.4.10/amarok/src/mediadevice/mtp'
and ends up with the same error.

How can I change that ?
Reply With Quote
  #2   (View Single Post)  
Old 21st December 2008
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

As it is, Amarok is not compatible with audio/libmtp 0.3.x which just recently hit the ports tree.

Your options:
1) Disable MTP support and restart the build from the beginning:
# make clean && make install clean

2) If you need MTP support, downgrade audio/libmtp to 0.2.6.1 until a patch comes out.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amarok post 7.2 update maxrussell FreeBSD Ports and Packages 12 23rd June 2009 08:13 PM
ln -f at boot doesn't work lordyan OpenBSD General 3 19th February 2009 03:50 PM
FreeBSD doesn't boot purak FreeBSD Installation and Upgrading 7 9th October 2008 05:24 PM
sshd doesn't time out arch FreeBSD Security 4 6th September 2008 12:23 PM
/dev/ulpt0 doesn't respond Shagbag OpenBSD General 3 7th July 2008 03:50 PM


All times are GMT. The time now is 04:15 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick