DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 9th January 2009
troberts troberts is offline
Port Guard
 
Join Date: May 2008
Posts: 27
Thanked 2 Times in 1 Post
Default Can't compile gcc-4.3.3_20090101 [SOLVED]

The following ports:
  • blas-1.0_2
  • lapack-3.1.1_1
  • py25-numpy-1.2.0,1
need to be updated but gcc-4.3.3_20090101 will not compile in the presence of lang/gcc295. The error message displayed is:
Code:
===>   gcc-4.3.3_20090101 depends on file: /usr/local/bin/perl5.8.8 - found

This port will not build in the presence of lang/gcc295.

*** Error code 1



Stop in /usr/ports/lang/gcc43.



===>>> make failed for lang/gcc43

===>>> Aborting update



===>>> Update for /usr/ports/lang/gcc43 failed

===>>> Aborting update



Terminated

#
I did a pkg_info for 'gcc' and the three things displayed are:
Code:
gcc-3.4.6_3,1       GNU Compiler Collection 3.4
gcc-4.2.5_20081126  GNU Compiler Collection 4.2
gccmakedep-1.0.2    Create dependencies in makefiles using 'gcc -M'
What confuses me is the message, "This port will not build in the presence of lang/gcc295.". The only reason I can come up with for gcc295 having a "presence" is because of ccache. I installed it, as is, and gcc295 is mentioned in the following section of its Makefile
Code:
.if !defined(WITHOUT_COMPILER_LINKS)
.if ${ARCH}=="i386" || ${ARCH}=="alpha"
GNU_COMPILERS+=		295
.endif
.if ${ARCH}=="i386"
CCACHE_COMPILERS+=      icc icpc
.endif
GNU_COMPILERS+=		32 33 34 40 41 42 43 44 -ooo
CCACHE_COMPILERS+=	cc c++ gcc g++ ${GNU_COMPILERS:S|^|gcc|} ${GNU_COMPILERS:S|^|g++|}
.if defined(EXTRA_COMPILERS)
CCACHE_COMPILERS+=	${EXTRA_COMPILERS}
.endif
WORLD_COMPILERS=	world-cc world-c++
PLIST_FILES+=	${CCACHE_COMPILERS:S|^|${CCLINKDIR}/|} \
		${WORLD_COMPILERS:S|^|${CCLINKDIR}/|}
SUB_FILES+=	${WORLD_COMPILERS}
SUB_LIST+=	CCACHE_COMPILERS="${CCACHE_COMPILERS}" \
		CCLINKDIR="${CCLINKDIR}" \
		ICCPREFIX="${LOCALBASE}/intel_cc_80/bin" \
		HOWTO="${HOWTO}"
.endif
If this is the problem, could I just delete the if statement that adds the gcc295 compiler to GNU_COMPILERS+=? Can I just delete the gcc295 link located in /usr/local/libexec/ccache? I was going to rename the link, but the 'Rename' option was inactive.

Any suggestions will be greatly appreciated.

Last edited by troberts; 10th January 2009 at 04:45 PM. Reason: Attempting to provide more information to make the question clearer.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't compile autoconf262 Sunsawe FreeBSD Ports and Packages 2 26th August 2008 07:53 PM
firefox3 will not compile map7 FreeBSD Ports and Packages 8 14th July 2008 11:23 PM
gio-fam-backend will not compile map7 FreeBSD Ports and Packages 0 2nd July 2008 01:59 AM
How come gnome2 won't compile? Damien787 FreeBSD Ports and Packages 10 16th June 2008 05:20 PM
Why wont this compile? Johnny2Bad FreeBSD General 10 19th May 2008 11:30 PM


All times are GMT. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick