DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Package System (pkgsrc)

NetBSD Package System (pkgsrc) Installation and upgrading of packages on NetBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th January 2009
Cloud Cloud is offline
New User
 
Join Date: Jun 2008
Posts: 9
Thanked 0 Times in 0 Posts
Default wip/kdebindings4-python errors

Trying to install kde4 and everytime I get up to kdebindings4-python it spits out a nice error
Quote:
Linking CXX shared module ../../lib/krosspython.so
ld: cannot find -lpython2.5
*** Error code 1
python2.5 is installed and all the cmake files are pointing to the right place so I'm a bit lost as to what to do. Oh and I'm running NetBSD 5.0 BETA, any help would be greatly appreciated
Reply With Quote
  #2   (View Single Post)  
Old 15th January 2009
JMJ_coder JMJ_coder is offline
VPN Cryptographer
 
Join Date: May 2008
Posts: 464
Thanked 8 Times in 8 Posts
Default

Two quick questions:

1) Did you install python before you upgraded to 5.0_BETA?

2) Have you tried uninstalling and then re-installing python?
__________________
And the WORD was made flesh, and dwelt among us. (John 1:14)
Reply With Quote
  #3   (View Single Post)  
Old 15th January 2009
Cloud Cloud is offline
New User
 
Join Date: Jun 2008
Posts: 9
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JMJ_coder View Post
Two quick questions:

1) Did you install python before you upgraded to 5.0_BETA?

2) Have you tried uninstalling and then re-installing python?
1) It's a fresh 5.0 install

2) Yes, and I also tried switching between python versions 2.5 and 2.4 since the package can use either one but it still didn't work.
Reply With Quote
  #4   (View Single Post)  
Old 16th January 2009
JMJ_coder JMJ_coder is offline
VPN Cryptographer
 
Join Date: May 2008
Posts: 464
Thanked 8 Times in 8 Posts
Default

Which version of pkgsrc are you using? I had many compilation issues with 5.0_BETA and pkgsrc-Q32008, so I used pkgsrc-current and all was well (I haven't tried Q4 yet).
__________________
And the WORD was made flesh, and dwelt among us. (John 1:14)
Reply With Quote
  #5   (View Single Post)  
Old 16th January 2009
Cloud Cloud is offline
New User
 
Join Date: Jun 2008
Posts: 9
Thanked 0 Times in 0 Posts
Default

Using pkgsrc-current but how would that effect kde4 if its from pkgsrc-wip and python is installing without a problem? I've also tried setting LD_FLAGS in the environment as suggested on another forum but that didn't do anything to help either.
Reply With Quote
  #6   (View Single Post)  
Old 16th January 2009
JMJ_coder JMJ_coder is offline
VPN Cryptographer
 
Join Date: May 2008
Posts: 464
Thanked 8 Times in 8 Posts
Default

Sorry I can't be of more help.

The only thing I can suggest is since kdebindings4-python won't compile from source, install the binary package via pkg_add and move on from there.
__________________
And the WORD was made flesh, and dwelt among us. (John 1:14)
Reply With Quote
  #7   (View Single Post)  
Old 16th January 2009
Cloud Cloud is offline
New User
 
Join Date: Jun 2008
Posts: 9
Thanked 0 Times in 0 Posts
Default

Quote:
Sorry I can't be of more help.

The only thing I can suggest is since kdebindings4-python won't compile from source, install the binary package via pkg_add and move on from there.
That's alright, thanks for the attempt I really appreciate it. I thought only kde3 is available through pkg_add & ftp.netbsd.org and kde4 was only available through pkgsrc-wip. However if there's a server that has more up to date binary packages I'd more than happy to install them instead of staring at the same error coming up again and again
Reply With Quote
  #8   (View Single Post)  
Old 17th January 2009
Cloud Cloud is offline
New User
 
Join Date: Jun 2008
Posts: 9
Thanked 0 Times in 0 Posts
Default

Since I don't know of any available binary packages for kdebindings4-python would it work if I had someone else running NetBSD 5.0 i386 compile and make a package that I could install?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
devel/kdebindings4-python-pykde4 Mantazz FreeBSD Ports and Packages 1 9th September 2009 06:54 PM
apache with python deadeyes FreeBSD Ports and Packages 1 27th August 2009 01:31 PM
py-yaml - Python 2.5 and 2.6 iGloo FreeBSD Ports and Packages 0 20th December 2008 08:36 PM
scribes configure error : python + D-bus nORKy FreeBSD Ports and Packages 0 7th October 2008 02:25 PM
How to vectorize a function for numpy arrays in Python kasse Programming 0 26th August 2008 12:12 PM


All times are GMT. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick