DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th January 2009
Nk2Network Nk2Network is offline
Port Guard
 
Join Date: Jan 2009
Posts: 43
Thanked 0 Times in 0 Posts
Default ServerName

Hello

tape the command /usr/local/sbin/apachectl restart


Code:
sd-12706# /usr/local/sbin/apachectl restart
httpd: apr_sockaddr_info_get() failed for sd-12706
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
httpd not running, trying to start
[Fri Jan 16 20:26:31 2009] [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter
sd-12706#
Reply With Quote
  #2   (View Single Post)  
Old 16th January 2009
glenbarber glenbarber is offline
Real Name: Glen Barber
/dev/urandom
 
Join Date: Nov 2008
Location: Philadelphia, PA, USA
Posts: 10
Thanked 0 Times in 0 Posts
Default

Try this:
Code:
ping -c1 `hostname` >/dev/null && echo "success" || echo "You dont have your hostname in /etc/hosts"
Reply With Quote
  #3   (View Single Post)  
Old 16th January 2009
Nk2Network Nk2Network is offline
Port Guard
 
Join Date: Jan 2009
Posts: 43
Thanked 0 Times in 0 Posts
Default

hello

By defaut in my file hosts (127.0.0.1 localhost localhost.my.domain) I have just looked in my httpd.conf file at ServerName 12.34.56.78:80


Code:
sd-12706# vi /etc/hosts
# $FreeBSD: src/etc/hosts,v 1.16 2003/01/28 21:29:23 dbaker Exp $
#
# Host Database
#
# This file should contain the addresses and aliases for local hosts that
# share this file.  Replace 'my.domain' below with the domainname of your
# machine.
#
# In the presence of the domain name service or NIS, this file may
# not be consulted at all; see /etc/nsswitch.conf for the resolution order.
#
#
::1                     localhost localhost.my.domain
127.0.0.1               localhost localhost.my.domain
#
# Imaginary network.
#10.0.0.2               myname.my.domain myname
#10.0.0.3               myfriend.my.domain myfriend
#
# According to RFC 1918, you can use the following IP networks for
# private nets which will never be connected to the Internet:
#
#       10.0.0.0        -   10.255.255.255
/etc/hosts: unmodified: line 1

Last edited by Nk2Network; 16th January 2009 at 08:51 PM.
Reply With Quote
  #4   (View Single Post)  
Old 16th January 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,135
Thanked 182 Times in 149 Posts
Default

Next time please use 'I typed" instead of 'tape'

What is the output of?
Code:
$ hostname
What is the output of?
Code:
$ dig $(hostname)
BTW please use [code] and [/code] tags instead of [php] and [/php]
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #5   (View Single Post)  
Old 16th January 2009
Nk2Network Nk2Network is offline
Port Guard
 
Join Date: Jan 2009
Posts: 43
Thanked 0 Times in 0 Posts
Default

Hello

Hostname: sd-12706
Adresse IP 1: 88.191.63.15


Code:
sd-12706# dig $ sd-12706

; <<>> DiG 9.4.2 <<>> $ sd-12706
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 37158
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;\$.                            IN      A

;; AUTHORITY SECTION:
.                       10800   IN      SOA     a.root-servers.net. nstld.verisi                                                                                                 gn-grs.com. 2009011601 1800 900 604800 86400

;; Query time: 11 msec
;; SERVER: 88.191.254.60#53(88.191.254.60)
;; WHEN: Fri Jan 16 21:54:14 2009
;; MSG SIZE  rcvd: 94

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 59926
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;sd-12706.                      IN      A

;; AUTHORITY SECTION:
.                       10800   IN      SOA     a.root-servers.net. nstld.verisi                                                                                                 gn-grs.com. 2009011601 1800 900 604800 86400

;; Query time: 10 msec
;; SERVER: 88.191.254.60#53(88.191.254.60)
;; WHEN: Fri Jan 16 21:54:14 2009
;; MSG SIZE  rcvd: 101

sd-12706#
Reply With Quote
  #6   (View Single Post)  
Old 16th January 2009
glenbarber glenbarber is offline
Real Name: Glen Barber
/dev/urandom
 
Join Date: Nov 2008
Location: Philadelphia, PA, USA
Posts: 10
Thanked 0 Times in 0 Posts
Default

The problem is that you don't have 'sd-12706' in /etc/hosts as localhost. Append that hostname to the end of the '::1' and '127.0.0.1' address lines.
Reply With Quote
  #7   (View Single Post)  
Old 16th January 2009
Nk2Network Nk2Network is offline
Port Guard
 
Join Date: Jan 2009
Posts: 43
Thanked 0 Times in 0 Posts
Default

hello,

adds as like this


Code:
::1                     localhost localhost.my.domain sd-12706 
127.0.0.1            localhost localhost.my.domain sd-12706
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:42 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick