DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 20th January 2009
whispersGhost's Avatar
whispersGhost whispersGhost is offline
Real Name: heather
Package Pilot
 
Join Date: May 2008
Location: ny
Posts: 168
Thanked 1 Time in 1 Post
Default problem installing linux comat ((Fixed))

Nevermind its fixed now

i had to remove linux_base-fc4
and do distclean install
then i was able to do the rest




hi

i have tried installing these required files


#cd /usr/ports/x11-toolkits/linux-gtk2/ && make install clean
#cd /usr/ports/devel/linux-sdl12/ && make install clean
#cd /usr/ports/graphics/linux-libGLU/ && make install clean


heer is the error i get for the first one

liquid-skiez# pkg_info | grep automake
automake-1.9.6_3 GNU Standards-compliant Makefile generator (1.9)
automake-wrapper-20071109 Wrapper script for GNU automake
liquid-skiez# cd /usr/ports/x11-toolkits/linux-gtk2/ && make install clean
===> Vulnerability check disabled, database not found
===> Extracting for linux-gtk2-2.6.10
=> MD5 Checksum OK for rpm/i386/fedora/4/gtk2-2.6.10-2.fc4.4.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/gtk2-2.6.10-2.fc4.4.i386.rpm.
=> MD5 Checksum OK for rpm/i386/fedora/4/gtk2-engines-2.6.3-2.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/gtk2-engines-2.6.3-2.i386.rpm.
===> linux-gtk2-2.6.10 depends on file: /usr/local/bin/rpm2cpio - not found
===> Verifying install for /usr/local/bin/rpm2cpio in /usr/ports/archivers/rpm
===> Building for rpm-3.0.6_14
gmake all-recursive
gmake[1]: Entering directory `/usr/ports/archivers/rpm/work/rpm-3.0.6'
Making all in intl
gmake[2]: Entering directory `/usr/ports/archivers/rpm/work/rpm-3.0.6/intl'
gmake[2]: Nothing to be done for `all'.
gmake[2]: Leaving directory `/usr/ports/archivers/rpm/work/rpm-3.0.6/intl'
Making all in po
gmake[2]: Entering directory `/usr/ports/archivers/rpm/work/rpm-3.0.6/po'
gmake[2]: Nothing to be done for `all'.
gmake[2]: Leaving directory `/usr/ports/archivers/rpm/work/rpm-3.0.6/po'
Making all in lib
gmake[2]: Entering directory `/usr/ports/archivers/rpm/work/rpm-3.0.6/lib'
/bin/sh /usr/local/bin/libtool --mode=link cc -O2 -fno-strict-aliasing -pipe -D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -o librpm.la -rpath /usr/local/lib cpio.lo dbindex.lo depends.lo falloc.lo formats.lo fprint.lo fs.lo hash.lo header.lo install.lo lookup.lo macro.lo md5.lo md5sum.lo messages.lo misc.lo package.lo problems.lo query.lo rebuilddb.lo rpmchecksig.lo rpmdb.lo rpmerr.lo rpminstall.lo rpmio.lo rpmlead.lo rpmlibprov.lo rpmmalloc.lo rpmrc.lo signature.lo stringbuf.lo stubs.lo tagName.lo tagtable.lo transaction.lo uninstall.lo url.lo verify.lo -L/usr/local/lib -lintl -liconv -L/usr/local/lib -lz -lbz2
libtool: link: `rpmio.lo' is not a valid libtool object
gmake[2]: *** [librpm.la] Error 1
gmake[2]: Leaving directory `/usr/ports/archivers/rpm/work/rpm-3.0.6/lib'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/archivers/rpm/work/rpm-3.0.6'
gmake: *** [all-recursive-am] Error 2
*** Error code 2

Stop in /usr/ports/archivers/rpm.
*** Error code 1

Stop in /usr/ports/x11-toolkits/linux-gtk2.


i had followed some old instruction to remove automake conflicts
and install version 19 of automake and still i get same errors

can someone please help me

Thank You
__________________
The journey is better then the destination

Last edited by whispersGhost; 20th January 2009 at 01:45 AM.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Installing From External DVD Drive jimnms OpenBSD Installation and Upgrading 8 16th July 2009 07:12 PM
linux compat and linux-only drivers fbsduser FreeBSD General 9 22nd January 2009 05:42 PM
installing linux on freeBSD freddybaker Other BSD and UNIX/UNIX-like 4 17th October 2008 03:40 PM
Problem with installing FreeBSD 7.0 Stable likemandrake FreeBSD General 2 5th October 2008 08:16 AM
Problem installing PHP5 DrKrall OpenBSD Packages and Ports 8 23rd May 2008 12:10 AM


All times are GMT. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick