DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 20th January 2009
stukov's Avatar
stukov stukov is offline
Real Name: Jean-Michel Philippon-Nadeau
Package Pilot
 
Join Date: May 2008
Location: Sherbrooke, Qc, Canada
Posts: 167
Thanked 6 Times in 6 Posts
Default Problems with wireless client

Hello,

It is my first time installing a FreeBSD wireless client to a network. I've got a D-Link adapter with the Atheros chipset. I've setuped the whole thing following the Handbook.

My setup is fairly relatively simple. It's a common D-Link AP with WPA2.

My box can connect to the AP but looses "carrier" very often resulting in packet loss.

My laptop is in the same room, but connects everywhere without any packet loss.

Here is my ifconfig output:
Code:
%ifconfig ath0
ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:1e:58:a3:08:91
        inet 192.168.0.100 netmask 0xffffff00 broadcast 192.168.0.255
        media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
        status: associated
        ssid ssid_name channel 1 (2412 Mhz 11g) bssid 00:1e:58:3f:de:6b
        authmode WPA2/802.11i privacy ON deftxkey UNDEF TKIP 2:128-bit
        txpower 31.5 bmiss 7 scanvalid 60 bgscan bgscanintvl 300
        bgscanidle 250 roam:rssi11g 7 roam:rate11g 5 protmode CTS burst
        roaming MANUAL
And here is my /etc/wpa_supplicant.conf:
Code:
network={
  ssid="ssid_name"
  psk="passphrase"
}
And my /etc/rc.conf:
Code:
ifconfig_ath0="WPA DHCP"
hostname="pfeil"
Thanks for the help,
__________________
"Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Server-Client c0mrade Programming 3 18th March 2009 05:22 PM
ipsec with client nat sicute OpenBSD General 0 30th October 2008 05:39 PM
IM Client schrodinger OpenBSD Packages and Ports 6 16th September 2008 02:09 PM
DDNS Client revzalot OpenBSD Installation and Upgrading 3 12th August 2008 02:21 AM
Client torrent ! gnowar OpenBSD General 10 3rd June 2008 10:50 AM


All times are GMT. The time now is 11:12 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick