DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 21st January 2009
whispersGhost's Avatar
whispersGhost whispersGhost is offline
Real Name: heather
Package Pilot
 
Join Date: May 2008
Location: ny
Posts: 168
Thanked 1 Time in 1 Post
Default the specified library screensaver can not be found

hi


The nvidia driver i installed is the correct version

but i do not see the gui screensaver manager

i not sure what wrong but i also looked in process manager for


the specified library screensaver can not be found

the diagnostics is:
shared object libm.s0.3 not found

it also mentions during my last kde upgrade thsi coud have happened
i never upgraded this.

is there a work around

or should i installed kde4 instead?

thank you
__________________
The journey is better then the destination

Last edited by whispersGhost; 21st January 2009 at 07:30 PM.
Reply With Quote
  #2   (View Single Post)  
Old 22nd January 2009
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

Which version of FreeBSD are you running?

Which version of the x11/nvidia-driver port do you have installed?

What produces this error? i.e. Which command did you use?

Is the misc/compat5x port installed?
If it is, make sure ldconfig finds the compat libraries, check with:
% ldconfig -r | grep libm

Add a path with:
# ldconfig -m /usr/local/lib/compat
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #3   (View Single Post)  
Old 22nd January 2009
whispersGhost's Avatar
whispersGhost whispersGhost is offline
Real Name: heather
Package Pilot
 
Join Date: May 2008
Location: ny
Posts: 168
Thanked 1 Time in 1 Post
Default hi

Sorry for taking so long i so sleepy lol

i am using FreeBSD 7.0

i did not use the port for nvidia this time as i was told they
are not supported for nvidia on the newer BSD versions so i
downloaded the NVIDIA-FreeBSD-x86-173.14.12

i notice everytime i reboot m machine i have to keep
installing nvidia all over again or x wont start

make setup

i have read the read me and as far as i know all i had to do was do
make setup and then from there change some things liek enable
glx and change nv to nvidia in the xorg.conf file

add these lines in the loader.conf

agp_load="YES"
nvidia_load="YES"
linux_load="YES"

i aslo have these in my xorg.conf

Section "Module"
Load "extmod"
Load "glx"
Load "dri"
Load "dbe"
Load "extmod"
Load "record"
Load "xtrap"
Load "type1"
Load "freetype"
Load "vbe"
EndSection

Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
Option "UseEDID" "FALSE"


EndSection



Section "Extensions"
Option "Composite" "Enable"
EndSection




ldconfig -r | grep libm
3:-lm.5 => /lib/libm.so.5
4:-lmd.4 => /lib/libmd.so.4
38:-lmenu.4 => /usr/lib/libmenu.so.4
41:-lmenuw.4 => /usr/lib/libmenuw.so.4
57:-lmagic.3 => /usr/lib/libmagic.so.3
58:-lmemstat.2 => /usr/lib/libmemstat.so.2
59:-lmilter.4 => /usr/lib/libmilter.so.4
60:-lmp.6 => /usr/lib/libmp.so.6
201:-lmng.1 => /usr/local/lib/libmng.so.1
314:-lmad.2 => /usr/local/lib/libmad.so.2
336:-lmcop.1 => /usr/local/lib/libmcop.so.1
337:-lmcop_mt.1 => /usr/local/lib/libmcop_mt.so.1
483:-lmimelib.1 => /usr/local/lib/libmimelib.so.1
619:-lmpeg2.0 => /usr/local/lib/libmpeg2.so.0
620:-lmpeg2convert.0 => /usr/local/lib/libmpeg2convert.so.0
635:-lmono-profiler-aot.0 => /usr/local/lib/libmono-profiler-aot.so.0
636:-lmono-profiler-cov.0 => /usr/local/lib/libmono-profiler-cov.so.0
637:-lmono.0 => /usr/local/lib/libmono.so.0
640:-lglibmm-2.4.1 => /usr/local/lib/libglibmm-2.4.so.1
641:-lglibmm_generate_extra_defs-2.4.1 => /usr/local/lib/libglibmm_generate_extra_defs-2.4.so.1
651:-lmusicbrainz.4 => /usr/local/lib/libmusicbrainz.so.4
682:-lmetacity-private.0 => /usr/local/lib/libmetacity-private.so.0
738:-lmenus.0 => /usr/local/lib/evolution/2.12/libmenus.so.0
739:-lmysqlclient.15 => /usr/local/lib/mysql/libmysqlclient.so.15
740:-lmysqlclient_r.15 => /usr/local/lib/mysql/libmysqlclient_r.so.15
$


-skiez# ldconfig -m /usr/local/lib/compat
ldconfig: warning: /usr/local/lib/compat: No such file or directory



Anyways first let me say i was so happy when i came back to BSD
its so customizable and fun to install.

i did not feel like waiting around for 2 days installng kde frpm ports this time so i did a pkg_add -r kde

i have kde 3 on my machine not kde 4 and im still not sure which one i like anyways since i played with both of them'

i do not even know if i had my path set right for
the most recent for the pkg_installs


What am i doing wrong

i can run second lfie perfectly and my screensavers works
ir i type in xscreensaver-demo
__________________
The journey is better then the destination
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
multibooting OpenBSD 4.4 through Vista's boot manager ocicat Guides 12 8th June 2010 04:28 PM
download manager graudeejs General software and network 11 16th October 2008 04:23 AM
window manager troubles techmarks FreeBSD General 3 29th September 2008 10:19 PM
What's the deal with /proc? JMJ_coder NetBSD General 17 11th July 2008 10:12 PM
Which file manager for fvwm? aleunix General software and network 5 8th June 2008 08:01 AM


All times are GMT. The time now is 12:18 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick