DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th October 2008
casteld73 casteld73 is offline
New User
 
Join Date: Oct 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default Broken Apache 2.2 Port

I have been playing around with various FTP servers. Uninstalled all of them. Went to reisntall apache22 and got the following error:

configure: WARNING: Unrecognized options: --with-perl, --with-expat, --with-iconv, --with-dbm, --with-mysql, --without-pgsql, --without-sqlite3, --enable-threads, --enable-nonportable-atomics
sed: 1: "s,%%FTPUSERS%%,$FreeBSD ...": bad flag in substitute command: 'v'
*** Error code 1

Stop in /usr/ports/www/apache22.
*** Error code 1

Stop in /usr/ports/www/apache22.

I did a make deinstall clean && make config install distclean

Keeps failing. Anyone have a clue what it is looknig for?
Reply With Quote
  #2   (View Single Post)  
Old 27th October 2008
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,069
Thanked 198 Times in 156 Posts
Default

Incidently, I updated the FreeBSD ports tree and built www/apache22 last evening ... Didn't have any problems.

So try updating your ports tree if you haven't already.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #3   (View Single Post)  
Old 27th October 2008
tad1214 tad1214 is offline
Real Name: Thomas Donnelly
Fdisk Soldier
 
Join Date: Jun 2008
Location: Houston, TX
Posts: 60
Thanked 0 Times in 0 Posts
Default

^
What he said, I just installed Apache +/- 12 minutes ago. Worked great.
Reply With Quote
  #4   (View Single Post)  
Old 27th October 2008
casteld73 casteld73 is offline
New User
 
Join Date: Oct 2008
Posts: 3
Thanked 0 Times in 0 Posts
Default

running cvsup.

The killer is that it was working. I recompiled apache and broke it.
Reply With Quote
  #5   (View Single Post)  
Old 21st January 2009
tehsu tehsu is offline
New User
 
Join Date: Jan 2009
Posts: 1
Thanked 0 Times in 0 Posts
Default

I still have this issue.. I know its a few month old topic, but is there any fix anyone has found?
Reply With Quote
  #6   (View Single Post)  
Old 23rd January 2009
windependence's Avatar
windependence windependence is offline
Real Name: Tim
Shell Scout
 
Join Date: May 2008
Location: Phoenix, Arizona
Posts: 116
Thanked 4 Times in 3 Posts
Default

Try make rmconfig in the port directory, then

make reinstall FORCE_PKG_REGISTER=yes

This will OVERWRITE your install so make sure that is OK with what you are doing and use the same version of the port.


-Tim
__________________
www.windependence.org
Get your Windependence today!

Last edited by windependence; 23rd January 2009 at 12:07 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade Apache 1.3 mod_ssl to Apache 2.2 beandip FreeBSD Ports and Packages 11 26th March 2009 09:12 PM
Apache Port Question / MYSQL casteld73 FreeBSD Ports and Packages 2 2nd November 2008 05:12 PM
squidGuard port marked broken chavez243 FreeBSD Ports and Packages 0 17th September 2008 12:55 PM
Passing args to port / make while installing apache robot FreeBSD Ports and Packages 2 27th August 2008 01:55 PM
Upgrading application not installed in default port directory APACHE ijk FreeBSD Ports and Packages 5 13th July 2008 04:34 PM


All times are GMT. The time now is 04:50 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick