DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD General

NetBSD General Other questions regarding NetBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th January 2009
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default fluxbox-generate_menu doesn't work

Hi there!

One of my favorite apps in fluxbox is the "fluxbox-generate_menu" script. It generates the menu with all the apps on your PC and if there are new packages the script adds them to the menu.

Indeed, on my new NetBSD 4.0.1 it doesn't work. This is the relevant output:

Quote:
nihonto@sushi:~> fluxbox-generate_menu
touch: ${HOME}/.fluxbox/menuconfig: No such file or directory
Warning: I couldn't create ${HOME}/.fluxbox/menuconfig
Fatal error: can't create or write to ${HOME}/.fluxbox/menu
As far as I can see it looks like some mess with the rights or the ownership:

Quote:
nihonto@sushi:~> ls -l .fluxbox/
total 20
-rw------- 1 nihonto users 3502 Jan 25 12:13 init
-rw-r--r-- 1 nihonto users 458 Jan 21 23:40 keys
-rw-r--r-- 1 nihonto users 1439 Jan 25 11:51 menu
-rw-r--r-- 1 nihonto users 0 Jan 25 12:14 slitlist
-rw-r--r-- 1 nihonto users 1101 Jan 23 22:08 startup
But when I look at /usr/pkg/bin/fluxbox-generate_menu:

Quote:
nihonto@sushi:~> ls -l /usr/pkg/bin/fluxbox-generate_menu
-r-xr-xr-x 1 root wheel 66586 Jan 21 21:49 /usr/pkg/bin/fluxbox-generate_menu
Do I have to change the ownership of /usr/pkg/bin/fluxbox-generate_menu? Or should it run without changing the ownership, because my user is in the "wheel"-Group?

Quote:
nihonto@sushi:~> userinfo nihonto
login nihonto
passwd *
uid 1000
groups users wheel
change NEVER
class
gecos
dir /home/nihonto
shell /bin/ksh
expire NEVER
Reply With Quote
  #2   (View Single Post)  
Old 25th January 2009
JMJ_coder JMJ_coder is offline
VPN Cryptographer
 
Join Date: May 2008
Posts: 464
Thanked 8 Times in 8 Posts
Default

It looks like it is having difficulty creating the file - menuconfig -. Try manually creating it with touch ~/.fluxbox/menuconfig and then re-run the fluxbox-generate-menu command.
__________________
And the WORD was made flesh, and dwelt among us. (John 1:14)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Marvell 88E8038 ethernet adaptor doesn't work with NetBSD 5, even with ACPI disabled GullibleJones NetBSD General 2 13th December 2009 10:55 AM
Fluxbox don't start Artur FreeBSD General 4 3rd September 2009 01:04 PM
ln -f at boot doesn't work lordyan OpenBSD General 3 19th February 2009 03:50 PM
New Kernel: "make depend" doesn't work nihonto NetBSD General 9 23rd January 2009 09:02 PM
KDE (X-Server) in FreeBSD 7.0 doesn't work correctly louie FreeBSD General 6 7th May 2008 11:53 PM


All times are GMT. The time now is 10:38 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick