DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th February 2009
clevershark clevershark is offline
Port Guard
 
Join Date: May 2008
Posts: 11
Thanked 0 Times in 0 Posts
Unhappy Amavisd-new -- is it usable?

I'm running into a frustrating problem after a recent system upgrade. Basically I went from 5.5 to 6.4 and things seem to be going pretty well except for amavisd-new. The upgrade included, among other things, moving from an old perl (5.8.6 I think) to 5.8.9. I use perl-threaded as the server is a dual-processor box.

Basically when I try and start the amavisd daemon program I get this message:

--------------------------
Starting amavisd.
fetch_modules: error loading required module Compress/Zlib.pm:
is only avaliable with the XS version at /usr/local/lib/perl5/site_perl/5.8.9/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.8.9/Compress/Zlib.pm line 9.
Compilation failed in require at /usr/local/sbin/amavisd line 195.
ERROR: MISSING REQUIRED BASIC MODULES:
Compress::Zlib
BEGIN failed--compilation aborted at /usr/local/sbin/amavisd line 234.
--------------------------

From what I've been able to see on the internet the real problem perl package is not compress::zlib, but scalar::util (?)

Also it was recommended that perl-after-upgrade -f be run, which I did, but in the end I got the message "Fixed 0 packages", so that didn't resolve the issue.

Any suggestions? Should I just reconfigure my web server to run without amavisd-new?

Edit: To specify, I installed both perl and amavisd-new from the current port.

Last edited by clevershark; 19th February 2009 at 05:48 AM. Reason: Added some detail
Reply With Quote
Reply

Tags
amavisd-new, compress::zlib, perl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed with installing usable GUI wellis82 FreeBSD Installation and Upgrading 10 22nd September 2008 03:57 PM


All times are GMT. The time now is 01:06 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick