DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th April 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default K3b cannot find growisofs

I've followed the guide on k3b as a non-privileged user, although K3b still complains that it can't find an optical device.

I've got devfs.conf looking like this:
Code:
own     acd0    root:users
perm    acd0    0660
link	acd0    dvdburner

own     cd0     root:users
perm    cd0     0660


own     acd1    root:users
perm    acd1    0660

own     cd1     root:users
perm    cd1     0660

own     pass1   root:users
perm    pass1   0660

own     pass0   root:users
perm    pass0   0666
perm	xpt0	0666
However, when I run it as sudo, it can't find growisofs. It is installed in /usr/local/bin and I've upped it to first in the searched paths in k3b's config.

I'd like to burn backup DVDs. What should I do?
Reply With Quote
  #2   (View Single Post)  
Old 26th April 2009
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Check that your devices maintain those permissions. Most people use devfs.rules instead of devfs.conf, because devfs.conf only affects devices that are detected at boot time. It only needs a process to reset a device (and I think that K3B does this!), and your devfs.conf permissions are gone.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
  #3   (View Single Post)  
Old 26th April 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Okay, ta. How do I set devfs.rules? It has different format to .conf
Reply With Quote
  #4   (View Single Post)  
Old 26th April 2009
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Yes: One thing that dev* needs is a good man page. That said, the handbook has a good chapter on it. Anything I could say would be a poor imitation of that.
Edit: AArgh! Sorry, it doesn't! Then I hope there is a how-to here.
Nope, there isn't. The best I can do you is this quote from the handbook page on usb disks.
Quote:
Originally Posted by handbook
First, the devices that are created when a USB storage device is connected need to be accessible by the user. A solution is to make all users of these devices a member of the operator group. This is done with pw(8). Second, when the devices are created, the operator group should be able to read and write them. This is accomplished by adding these lines to /etc/devfs.rules:

[localrules=5]
add path 'da*' mode 0660 group operator

Note: If there already are SCSI disks in the system, it must be done a bit different. E.g., if the system already contains disks da0 through da2 attached to the system, change the second line as follows:

add path 'da[3-9]*' mode 0660 group operator

This will exclude the already existing disks from belonging to the operator group.

You also have to enable your devfs.rules(5) ruleset in your /etc/rc.conf file:

devfs_system_ruleset="localrules"
You will need to alter the 'path' string to match, and add additional lines for pass* etc. Note that you can have as many items in a ruleset as you like, and, if you already have a ruleset set there for something else, all you need to do is enter you new entries at the end of the others.

You can enter rules at run-time with the devfs(1) program. "/etc/rc.d/devfs reload" /should/ do it, but I am not sure if it does.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.

Last edited by robbak; 26th April 2009 at 12:00 PM.
Reply With Quote
  #5   (View Single Post)  
Old 26th April 2009
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Ta. Will investigate that. You must be burning the midnight oil in QLD! (I'm not saying burn Midnight Oil, some of their tunes were alright.... )

Reply With Quote
  #6   (View Single Post)  
Old 26th April 2009
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Not that I have any on my computer to burn! (Seekers: Wreck of the Old 97 is playing right now!)
And It's only 10:30pm. Not midnight yet!
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pkg_add g95;g95 x.f95: cannot find g95 enpey OpenBSD Packages and Ports 8 27th August 2008 12:48 AM
How to find available IP addresses? bigb89 Programming 16 20th August 2008 07:32 PM
How do I find out what the latest release is? troberts FreeBSD Installation and Upgrading 3 16th August 2008 06:01 PM
where might I find 'libcamel'? Damien787 FreeBSD Ports and Packages 16 17th June 2008 11:35 PM
There is an alternative way to find a packages? aleunix OpenBSD Packages and Ports 23 6th June 2008 07:18 AM


All times are GMT. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick