DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th February 2009
terryd terryd is offline
Port Guard
 
Join Date: Nov 2008
Posts: 22
Thanked 0 Times in 0 Posts
Default pppoe help

Hi I have openbsd 4.4 and I am trying to set it up as a gateway firewall using pppoe.
I have two nics rl0 internal and fxp0 external and plugged into the router which is a Netgear DG632 set as a modem which from what I read is the required setting.

To get things going I followed this guide here
http://www.openbsd-wiki.org/index.ph...r_and_Firewall

My ifconfig gives me

Code:
# ifconfig
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 33204
        groups: lo
        inet 127.0.0.1 netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:90:27:bf:c4:5f
        media: Ethernet autoselect (100baseTX full-duplex)
        status: active
        inet6 fe80::290:27ff:febf:c45f%fxp0 prefixlen 64 scopeid 0x1
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:01:29:09:1c:dd
        media: Ethernet autoselect (100baseTX full-duplex)
        status: active
        inet 192.168.2.3 netmask 0xffffff00 broadcast 192.168.2.255
        inet6 fe80::201:29ff:fe09:1cdd%rl0 prefixlen 64 scopeid 0x2
enc0: flags=0<> mtu 1536
pppoe0: flags=8851<UP,POINTOPOINT,RUNNING,SIMPLEX,MULTICAST> mtu 1492
        dev: fxp0 state: PADI sent
        sid: 0x0 PADI retries: 5 PADR retries: 0
        sppp: phase establish authproto chap authname "user@plusdsl.net"
        groups: pppoe egress
        inet6 fe80::290:27ff:febf:c45f%pppoe0 ->  prefixlen 64 scopeid 0x5
        inet 0.0.0.0 --> 0.0.0.1 netmask 0xffffffff
I am not too sure where to go next.

Code:
# more /etc/hostname.pppoe0
inet 0.0.0.0 255.255.255.255 NONE pppoedev fxp0 \
        authproto chap authname user@plusdsl.net authkey passwd up
dest 0.0.0.1
!/sbin/route add  default 0.0.0.1
at this point pf is disabled
Any info welcome

The modem seems to have died so its not an issue at the moment

Last edited by terryd; 14th February 2009 at 10:05 AM.
Reply With Quote
  #2   (View Single Post)  
Old 27th April 2009
alekid's Avatar
alekid alekid is offline
Real Name: Alekid
Alekid
 
Join Date: Nov 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default

your adsl is chap or pap? (authproto chap) check this... and enable the net.inet.ip.forwarding=1 in /etc/sysctl.conf.
check you resov.conf in /etc

Try this

1- vi etc/ppp/ppp.conf

2-
default:
set log Phase Chat IPCP CCP tun command
set redial 15 0
set reconnect 15 10000

pppoe:
set device "!/usr/sbin/pppoe -i fxp0"
disable acfcomp protocomp
deny acfcomp
set mtu max 1454
set speed sync
enable lqr
set lqrperiod 5
set cd 5
set dial
set login
set timeout 0
set authname user@plusdsl.net #user
set authkey passwd_isp #passwd ISP
add! default HISADDR
enable dns
enable mssfixup

3-# vi /etc/hostname.fxp0
up
! /bin/test -f /etc/ppp/ppp.conf && /usr/sbin/ppp -ddial pppoe


#enjoy
__________________
http://www.openbsdsupport.com.ar/
The OpenBSD Support Argentina
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick