DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default wireless not working.

I configured the wpi0 as follow, to connect to network ABC for example.

Code:
# ifconfig wpi0 nwid ABC wpa wpapsk \
> $(wpa-psk ABC ABCpass)
then i do dhclient wpi0 and i keep get this messages.
Code:
# dhclient wpi0
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 9
link state up -> down
link state down -> up
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 5
link state up -> down
link state down -> up
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 13
link state up -> down
link state down -> up
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wpi0 to 255.255.255.255 port 67 interval 14
Reply With Quote
  #2   (View Single Post)  
Old 5th May 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

Does a scan for access points show your "ABC" SSID?

If you're running 4.4-release:

# ifconfig -M wpi0

If you're running 4.5-release:

# ifconfig wpi0 scan
Reply With Quote
  #3   (View Single Post)  
Old 5th May 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,834
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by bsdnewbie999 View Post
Code:
# ifconfig wpi0 nwid ABC wpa wpapsk \
> $(wpa-psk ABC ABCpass)
Is your access point configured as WPA or WPA2? The ifconfig command above states that the assumption that it is WPA.
Reply With Quote
  #4   (View Single Post)  
Old 5th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default

Yes. My AP is WPA encryption.
Reply With Quote
  #5   (View Single Post)  
Old 6th May 2009
pik pik is offline
Port Guard
 
Join Date: May 2009
Posts: 12
Thanked 0 Times in 0 Posts
Default

I've just thrown an intel 3945 nic into my aspire one and I'm having trouble with a similar issue. In my reading of the man page for ifconfig, I've come to think that the

Quote:
> $(wpa-psk ABC ABCpass)
is actually generating a passkey from the phrase 'ABCpass', as opposed to specifying the pass 'ABCpass'.

My network is currently set for a 256 bit ASCII key, which OpenBSD doesn't seem to support (bash plays up a bit when I try). Once I'm able to temporarily change the key for my network, I think I'll have to try something along the lines of:

Quote:
sudo ifconfig wpi0 nwid NETWORK_NAME wpa wpapsk 0x64_CHAR_HEX_KEY
Hopefully I haven't misinterpreted the man page .

[update]: Can confirm that this works . It's been a long road to get wifi working on this laptop, the default atheros card is very poorly supported but this intel 3945 card works a treat.

Last edited by pik; 6th May 2009 at 08:55 AM.
Reply With Quote
  #6   (View Single Post)  
Old 6th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default

What if the AP is WEP encryption? I put
Code:
dhcp NONE NONE NONE nwkey example chan 6
in the hostname.wpi0 file. but at bootup the system said the nwkey string is too long(because my Uni has 26 characters).
How do i connect to the WEP connection by issuing the command(if i don't know the gateway)?
Reply With Quote
  #7   (View Single Post)  
Old 6th May 2009
pik pik is offline
Port Guard
 
Join Date: May 2009
Posts: 12
Thanked 0 Times in 0 Posts
Default

I don't claim to understand any of this (my exposure to wlans under openbsd began tonight) but I think you'd need something along the lines of:

Quote:
ifconfig wpi0 nwid AP_NAME nwkey WEP_KEY
taking note of this particular section in the ifconfig man page

Quote:
nwkey key
Enable WEP encryption for IEEE 802.11-based wireless network interfaces using the specified key. The key can either be a string, a series of hexadecimal digits (preceded by `0x')....
You may also want to fiddle with the "newkey persist" option, but I'm not sure.

Of course, after all of this you still need to

Quote:
dhclient wpi0
Reply With Quote
  #8   (View Single Post)  
Old 6th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default

I got this error message when i connect to the WPA's AP
Code:
ifconfig: wpapsk: bad pre-shared key length
I use the command
ifconfig wpi0 nwid NETWORK_NAME wpa wpapsk 0x64_CHAR_HEX_KEY
Reply With Quote
  #9   (View Single Post)  
Old 6th May 2009
pik pik is offline
Port Guard
 
Join Date: May 2009
Posts: 12
Thanked 0 Times in 0 Posts
Default

The password on my AP is a 256 bit (64 char) hex string, and was generated by https://www.grc.com/passwords.htm. ifconfig will only allow you to set a hex WPA key if it's the right length.

What you need to do is outline exactly the specifics of the network you're trying to connect to - ie which type of encryption (WEP, WPA, WPA2?)...
Reply With Quote
Old 6th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default

Its WPA encryption.
Reply With Quote
Old 9th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default

I tried to put 0x at the beginning of the password but i got the same error. The password is a combination of 26 numbers and alphabeticals. How do i connect to my Uni(WEP encryption) with these 26 characters under nwid of my Uni? Can i use the following code?
Code:
dhcp My_Uni nwkey 26characters chan 6
Reply With Quote
Old 9th May 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,834
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by bsdnewbie999 View Post
Can i use the following code?
Code:
dhcp My_Uni nwkey 26characters chan 6
The manpage to wpi(4) states:
Code:
EXAMPLES
     The following hostname.if(5) example configures wpi0 to join whatever
     network is available on boot, using WEP key ``0x1deadbeef1'', channel 11,
     obtaining an IP address using DHCP:

           dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11
So, it appears that your syntax is wrong. "NONE NONE NONE" is required.
Reply With Quote
Old 10th May 2009
bsdnewbie999 bsdnewbie999 is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 0 Times in 0 Posts
Default

I know it uses "NONE NONE NONE" to connect to a AP which is using the certain nwkey at bootup. But what if i just want to connect to a AP without matching the nwkey to each AP in the detected networks. I have tried
Code:
dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11
But it doesn't work for my Uni, i just got the error for the nwkey it saids nwkey string too long.
Reply With Quote
Old 18th July 2009
iacbsd's Avatar
iacbsd iacbsd is offline
Port Guard
 
Join Date: Jul 2009
Posts: 13
Thanked 0 Times in 0 Posts
Default

Then your Oxblahblahblah string is to long. I know you have probably solved this by now also i never have to put the channel or nwid to get my wifi interface to work. Also to get wpa to work you need madwifi driver and the wpa_supplicant i believe due to the licensing of wpa.
Reply With Quote
Old 18th July 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

That is totally inaccurate information about WPA iacbsd.. OpenBSD doesn't use "madwifi" or "wpa_supplicant", it has it's own implementation.. and there are no licencing issues, it is fully standardized.
Reply With Quote
Old 18th July 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

Well, there *were* licensing issues, but it was the other-way-'round, an apparent misuse of reyk@'s ISC-licensed code developed for OpenBSD. The gory details can be found on misc@ and on the linux-kernel mailing list, mid-September, 2007.
Reply With Quote
Old 19th July 2009
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 734
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by iacbsd View Post
Then your Oxblahblahblah string is to long. I know you have probably solved this by now also i never have to put the channel or nwid to get my wifi interface to work. Also to get wpa to work you need madwifi driver and the wpa_supplicant i believe due to the licensing of wpa.
Nonsense. Please refrain from giving any "help" if you do not know what are you talking about. We are talking about OpenBSD not about FreeBSD. wpa-supplicant port from OpenBSD tree has only wire support. OpenBSD has completely different implementation of WPA for WiFi devices.

Last edited by Oko; 19th July 2009 at 03:05 PM.
Reply With Quote
Old 19th July 2009
iacbsd's Avatar
iacbsd iacbsd is offline
Port Guard
 
Join Date: Jul 2009
Posts: 13
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Oko View Post
Nonsense. Please refrain from giving any "help" if you do not know what are you talking about. We are talking about OpenBSD not about FreeBSD. wpa-supplicant port from OpenBSD three has only wire support. OpenBSD has completely different implementation of WPA for WiFi devices.
yeah your right madwifi and wpa suplicant was for linux my bad its been along time since i got wpa2 working on openbsd but wpa2 i think did require some configuration file if i am not mistaken as far wep however the network key is to long i know because i have done this before too :P
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
atheros wireless card not working guitarscn FreeBSD General 0 26th August 2009 05:50 PM
BSDAnywhere wireless Q tony333 OpenBSD General 12 5th April 2009 02:15 AM
Wireless Network Config working -- almost JMJ_coder General software and network 4 20th November 2008 05:10 PM
Wireless Card on T61 disappearedng FreeBSD General 1 13th July 2008 12:54 AM
Gui for Wireless LAN? PatrickBaer FreeBSD General 2 13th June 2008 12:25 AM


All times are GMT. The time now is 03:48 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick