DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 1st May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default ffmpeg

Hello, i am trying to ffmpeg install on my server FBSD 6.3 but am having some issues.

tried
Code:
cd /usr/ports/multimedia/ffmpeg/ && make install clean 

===>   ffmpeg-2008.07.27_7 depends on executable: texi2html - found
===>   ffmpeg-2008.07.27_7 depends on executable: gmake - found
===>   ffmpeg-2008.07.27_7 depends on shared library: a52.0 - found
===>   ffmpeg-2008.07.27_7 depends on shared library: faac.0 - not found
===>    Verifying install for faac.0 in /usr/ports/audio/faac
===>   faac-1.26_1 depends on executable: gmake - found
===>   faac-1.26_1 depends on file: /usr/local/bin/automake-1.9 - not found
===>    Verifying install for /usr/local/bin/automake-1.9 in /usr/ports/devel/automake19
===>  Building for automake-1.9.6_3
Making all in .
 cd . && perllibdir=/usr/ports/devel/automake19/work/automake-1.9.6"/lib:./lib" /usr/ports/devel/automake19/work/automake-1.9.6/automake --libdir=lib --gnu
/usr/ports/devel/automake19/work/automake-1.9.6/automake: not found
*** Error code 1

Stop in /usr/ports/devel/automake19/work/automake-1.9.6.
*** Error code 1

Stop in /usr/ports/devel/automake19/work/automake-1.9.6.
*** Error code 1

Stop in /usr/ports/devel/automake19.
*** Error code 1

Stop in /usr/ports/audio/faac.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
but as you can see i have issue with automake.

Automake appears not to be installed
Code:
pkg_info automake
pkg_info: can't find package 'automake' installed or in a file
so tried
Code:
cd /usr/ports/devel/automake19/ && make install clean
===>  Building for automake-1.9.6_3
Making all in .
 cd . && perllibdir=/usr/ports/devel/automake19/work/automake-1.9.6"/lib:./lib" /usr/ports/devel/automake19/work/automake-1.9.6/automake --libdir=lib --gnu
/usr/ports/devel/automake19/work/automake-1.9.6/automake: not found
*** Error code 1

Stop in /usr/ports/devel/automake19/work/automake-1.9.6.
*** Error code 1

Stop in /usr/ports/devel/automake19/work/automake-1.9.6.
*** Error code 1

Stop in /usr/ports/devel/automake19.
trying pkg_add for both returns
Code:
kg_add -r automake19
Error: FTP Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.3-release/Latest/automake19.tbz: File unavailable (e.g., file not found, no access)
pkg_add: unable to fetch 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.3-release/Latest/automake19.tbz' by URL

any ideas?

cheers
Reply With Quote
  #2   (View Single Post)  
Old 1st May 2009
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 764
Thanked 36 Times in 32 Posts
Default

FreeBSD ports do support only Current Branch 8.0 and stable 7.2 or 6.4. You obviously missing the specific version of Automake probably due to the fact that you are using outdated version of the system with newer ports three. The problem is fixable but probably not worth of your time.
Reply With Quote
  #3   (View Single Post)  
Old 1st May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Oko View Post
FreeBSD ports do support only Current Branch 8.0 and stable 7.2 or 6.4. You obviously missing the specific version of Automake probably due to the fact that you are using outdated version of the system with newer ports three. The problem is fixable but probably not worth of your time.
I could upgrade to 6.4 if i need to and i do need to get ffmpeg installed as it is a requirement for a web script.

I may even look into updating to 7.2

cheers
Reply With Quote
  #4   (View Single Post)  
Old 3rd May 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

It looks like when you tried to build automake19, there was a leftover build because it went straight to building instead of extracting. Try cleaning out the work directory and try again: # cd /usr/ports/devel/automake19/ && make clean && make install clean
Reply With Quote
  #5   (View Single Post)  
Old 4th May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Hello and thanks for replies, ok i have moved forward and have got automake installed plus some other deps but is borking at 'faac'?

Code:
cd /usr/ports/multimedia/ffmpeg/ && make install clean
===>   ffmpeg-2008.07.27_10 depends on executable: texi2html - found
===>   ffmpeg-2008.07.27_10 depends on executable: gmake - found
===>   ffmpeg-2008.07.27_10 depends on shared library: a52.0 - found
===>   ffmpeg-2008.07.27_10 depends on shared library: faac.0 - not found
===>    Verifying install for faac.0 in /usr/ports/audio/faac
===>   faac-1.28 depends on executable: gmake - found
===>   faac-1.28 depends on file: /usr/local/bin/automake-1.10 - found
===>   faac-1.28 depends on file: /usr/local/bin/autoconf-2.62 - found
===>   faac-1.28 depends on file: /usr/local/bin/libtool - found
===>   faac-1.28 depends on shared library: mp4v2.0 - found
===>  Configuring for faac-1.28
cd: can't cd to /usr/ports/audio/faac/work/faac-1.28
*** Error code 2

Stop in /usr/ports/audio/faac.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1
I tried creating the dir faac-1.28 and ran install again:

Code:
cd /usr/ports/audio/faac/ && make install clean
===>   faac-1.28 depends on executable: gmake - found
===>   faac-1.28 depends on file: /usr/local/bin/automake-1.10 - found
===>   faac-1.28 depends on file: /usr/local/bin/autoconf-2.62 - found
===>   faac-1.28 depends on file: /usr/local/bin/libtool - found
===>   faac-1.28 depends on shared library: mp4v2.0 - found
===>  Configuring for faac-1.28
libtoolize: `configure.ac' does not exist
Try `libtoolize --help' for more information.
*** Error code 1

Stop in /usr/ports/audio/faac.
Although it got further with this dir created it did not write anything to it and install files are just in faac:
Code:
ls /usr/ports/audio/faac/work/faac/
.cvsignore              INSTALL                 TODO                    configure.in.orig       include
AUTHORS                 Makefile.am             bootstrap               docs                    libfaac
COPYING                 NEWS                    common                  faac.dsw                plugins
ChangeLog               README                  configure.in            frontend                project

A google returned nothing so if you have any ideas it would be appreciated.

cheers
Reply With Quote
  #6   (View Single Post)  
Old 5th May 2009
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

Semi-wild ass guess

if the DISTFILE 'faac-1.28.tar.bz2' extracts to faac rather then faac-1.28, then the port will need to set WRKSRC accordingly in the makefile: because it sounds like the tarball is not extracting to the expected work directory.

Maybe try adding WRKSRC=$(WRKDIR)/faac to the Makefile in audio/faac, make clean in that port dir, and try building it again either directly or via ffmpeg dep. If successful, maybe the faac people changed the archive and the portmaintainer for audio/faac didn't notice.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #7   (View Single Post)  
Old 5th May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TerryP View Post
Semi-wild ass guess

if the DISTFILE 'faac-1.28.tar.bz2' extracts to faac rather then faac-1.28, then the port will need to set WRKSRC accordingly in the makefile: because it sounds like the tarball is not extracting to the expected work directory.

Maybe try adding WRKSRC=$(WRKDIR)/faac to the Makefile in audio/faac, make clean in that port dir, and try building it again either directly or via ffmpeg dep. If successful, maybe the faac people changed the archive and the portmaintainer for audio/faac didn't notice.
Hello and thanks for reply, where about would i add this line?

Here is the current Makefile

/usr/ports/audio/faac/Makefile
Code:
# New ports collection makefile for:    faac
# Date created:                 Wed May  5 16:38:55 EDT 2004
# Whom:                         Michael Johnson <ahze@ahze.net>
#
# $FreeBSD: ports/audio/faac/Makefile,v 1.35 2009/03/24 16:58:55 mm Exp $
#

PORTNAME=       faac
PORTVERSION=    1.28
CATEGORIES=     audio
MASTER_SITES=   SFE

MAINTAINER=     multimedia@FreeBSD.org
COMMENT=        MPEG-2 and MPEG-4 AAC audio encoder

LIB_DEPENDS=    mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2

RESTRICTED=     Distribution in binary form is prohibited

USE_BZIP2=      yes
USE_DOS2UNIX=   yes
USE_GMAKE=      yes
MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS=  aclocal:110 autoheader:262 automake:110 autoconf:262 libtool:15
ACLOCAL_ARGS=   -I . -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS=  --add-missing
CONFIGURE_ENV=  CPPFLAGS="-I${LOCALBASE}/include" \
                LDFLAGS="-L${LOCALBASE}/lib" \
                LIBS="-lmp4v2"
USE_LDCONFIG=   yes

MAN1=           faac.1

.include <bsd.port.pre.mk>

post-patch:
        @${ECHO_CMD} "" >> ${WRKSRC}/libfaac/psych.h

pre-configure:
        @cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} --automake

.include <bsd.port.post.mk>

Cheers
Reply With Quote
  #8   (View Single Post)  
Old 6th May 2009
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

It shouldn't matter much for testing; above maintainer would be fine.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #9   (View Single Post)  
Old 6th May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Thanks that did it, it has now built fine, i have emailed the maintainer address in makefile with this issue.

cheers
Reply With Quote
Old 6th May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Ok this turning into a bit of struggle, now when trying to build the original app ffmpeg i get
Code:
License: unredistributable
Creating config.mak and config.h...
===>  Building for ffmpeg-2008.07.27_10
gmake: *** virtual memory exhausted.  Stop.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.

I find this is due to fact that ffmpeg needs gmake-3.81 and my system only 3.80, so update this but now get

cd /usr/ports/multimedia/ffmpeg/ && make install clean
Code:
===>  Building for ffmpeg-2008.07.27_10
cd ./libavutil/ && ln -sf libavutil.so.1 libavutil.so
cc -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I. -I"/usr/ports/multimedia/ffmpeg/work/ffmpeg-2008-07-27" -pipe -march=pentium3 -O3 -ffast-math -fno-finite-math-only -fomit-frame-pointer -fno-strict-aliasing -msse -I/usr/local/include -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wcast-qual -Wwrite-strings -O3 -fno-math-errno         -c -o libavcodec/libx264.o libavcodec/libx264.c
cc -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I. -I"/usr/ports/multimedia/ffmpeg/work/ffmpeg-2008-07-27" -pipe -march=pentium3 -O3 -ffast-math -fno-finite-math-only -fomit-frame-pointer -fno-strict-aliasing -msse -I/usr/local/include -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wcast-qual -Wwrite-strings -O3 -fno-math-errno         -c -o libavcodec/aac_ac3_parser.o libavcodec/aac_ac3_parser.c
libavcodec/libx264.c: In function `X264_init':
libavcodec/libx264.c:165: error: structure has no member named `b_bframe_adaptive'
libavcodec/libx264.c:230: error: structure has no member named `b_bidir_me'
libavcodec/libx264.c:231: error: structure has no member named `b_bframe_rdo'
libavcodec/libx264.c:256: error: structure has no member named `psz_rc_eq'
gmake: *** [libavcodec/libx264.o] Error 1
gmake: *** Waiting for unfinished jobs....
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
This has been harder to track down on google though!

any ideas

cheers
Reply With Quote
Old 6th May 2009
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

Curious, how much memory and SWAP do you have installed?
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
Old 6th May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TerryP View Post
Curious, how much memory and SWAP do you have installed?
2gb ram 2gb swap, but that is not the issue, that was cured by updating to gmake 3.81

it is the last one which is now problem.
Reply With Quote
Old 6th May 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Quote:
Originally Posted by carpman View Post
Code:
libavcodec/libx264.c: In function `X264_init':
libavcodec/libx264.c:165: error: structure has no member named `b_bframe_adaptive'
libavcodec/libx264.c:230: error: structure has no member named `b_bidir_me'
libavcodec/libx264.c:231: error: structure has no member named `b_bframe_rdo'
libavcodec/libx264.c:256: error: structure has no member named `psz_rc_eq'
Looks like you need to install multimedia/x264 it looks like the header file is missing. Either that or use the OPTIONS to disable X264.
Reply With Quote
Old 7th May 2009
carpman carpman is offline
Shell Scout
 
Join Date: Jul 2008
Posts: 94
Thanked 0 Times in 0 Posts
Default

Hello and thanks for reply, X264 is already installed!

I also tried un-setting X264 option

from /usr/ports/multimedia/ffmpeg/Makefile
Code:
OPTIONS=        AMR_NB  "AMR narrowband encoder" off \
                AMR_WB  "AMR wideband encoder" off \
                FAAC    "FAAC mp4/aac audio encoder" off \
                FAAD    "FAAD mp4/aac audio decoder" on \
                GSM     "gsm audio codec" off \
                IPV6    "IPV6 network support" on \
                LAME    "lame MP3 codec" off \
                LIBA52  "liba52 support"        on \
                OPTIMIZED_CFLAGS "Additional optimizations" off \
                SDL     "SDL support (build ffplay)" off \
                THEORA  "libtheora support (implies OGG)" on \
                VORBIS  "libvorbisenc support (implies OGG)" on \
                X264    "X.264 codec" off \
                XVID    "XVID codec" off
but still have error

Code:
/usr/ports/multimedia/ffmpeg]# make install clean
===>  Building for ffmpeg-2008.07.27_10
cc -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I. -I"/usr/ports/multimedia/ffmpeg/work/ffmpeg-2008-07-27" -pipe -march=pentium3 -O3 -ffast-math -fno-finite-math-only -fomit-frame-pointer -fno-strict-aliasing -msse -I/usr/local/include -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wcast-qual -Wwrite-strings -O3 -fno-math-errno         -c -o libavcodec/libx264.o libavcodec/libx264.c
cc -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I. -I"/usr/ports/multimedia/ffmpeg/work/ffmpeg-2008-07-27" -pipe -march=pentium3 -O3 -ffast-math -fno-finite-math-only -fomit-frame-pointer -fno-strict-aliasing -msse -I/usr/local/include -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wcast-qual -Wwrite-strings -O3 -fno-math-errno         -c -o libavcodec/dca_parser.o libavcodec/dca_parser.c
libavcodec/libx264.c: In function `X264_init':
libavcodec/libx264.c:165: error: structure has no member named `b_bframe_adaptive'
libavcodec/libx264.c:230: error: structure has no member named `b_bidir_me'
libavcodec/libx264.c:231: error: structure has no member named `b_bframe_rdo'
libavcodec/libx264.c:256: error: structure has no member named `psz_rc_eq'
gmake: *** [libavcodec/libx264.o] Error 1
gmake: *** Waiting for unfinished jobs....
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.

cheers
Reply With Quote
Old 7th May 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Quote:
Originally Posted by carpman View Post
Hello and thanks for reply, X264 is already installed!
Just because it is registered as installed, doesn't necessarily mean it is working properly. Make sure you have /usr/local/include/x264.h

Quote:
Originally Posted by carpman View Post
I also tried un-setting X264 option from /usr/ports/multimedia/ffmpeg/Makefile
That is not how you configure OPTIONS. Changing the Makefile does not alter the OPTIONS already stored in /var/db/ports. To change the OPTIONS run:
# cd /usr/ports/multimedia/ffmpeg && make config
That will bring up the blue OPTIONS screen again and you can uncheck X264.

Oh and be sure to run 'make clean' before each attempt at building.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick