DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 6th June 2009
asmo asmo is offline
Real Name: Marcin Górski
New User
 
Join Date: Jun 2008
Location: Rumia, Poland
Posts: 3
Thanked 0 Times in 0 Posts
Default FreeBSD 7.2@amd64 atheros problem ath0: stuck beacon; resetting (bmiss count 4)

Hello,
I would like to use TL-WN550G/TL-WN551G (atheros) as hostap. This hardware used to work with FreeBSD 7.0@i386 out-of-box.

Following lines was added to /boot/loader.conf:
if_ath_load="YES"
wlan_xauth_load="YES"
wlan_scan_ap_load="YES"
wlan_scan_sta_load="YES"

margor# dmesg | grep ath
ath0: <Atheros 2413> mem 0xeffe0000-0xeffeffff irq 21 at device 1.0 on pci1
ath0: [ITHREAD]
ath0: WARNING: using obsoleted if_watchdog interface
ath0: Ethernet address: 00:1d:0f:b4:f0:f0
ath0: mac 7.8 phy 4.5 radio 5.6
ath0: device timeout

Well I tried to set up basic access point:
margor# ifconfig ath0 ssid freebsdap mode 11g mediaopt hostap
margor# ifconfig ath0
ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 00:1d:0f:b4:f0:f0
inet 10.1.1.1 netmask 0xffffff00 broadcast 10.1.1.255
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
status: no carrier
ssid freebsdap channel 8 (2447 Mhz 11g)
authmode OPEN privacy OFF txpower 31.5 scanvalid 60 bgscan
bgscanintvl 300 bgscanidle 250 roam:rssi11g 7 roam:rate11g 5
protmode CTS burst dtimperiod 1

I got in dmesg:
ath0: stuck beacon; resetting (bmiss count 4)
ath0: stuck beacon; resetting (bmiss count 4)
ath0: stuck beacon; resetting (bmiss count 4)
ath0: stuck beacon; resetting (bmiss count 4)

When I reapeated the last activity:
margor# ifconfig ath0
ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 00:1d:0f:b4:f0:f0
inet 10.1.1.1 netmask 0xffffff00 broadcast 10.1.1.255
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
status: associated
ssid freebsdap channel 1 (2412 Mhz 11g) bssid 00:1d:0f:b4:f0:f0
authmode OPEN privacy OFF txpower 31.5 scanvalid 60 bgscan
bgscanintvl 300 bgscanidle 250 roam:rssi11g 7 roam:rate11g 5
protmode CTS burst dtimperiod 1

However, the new ath0: stuck beacon; resetting (bmiss count 4) are present in dmesg.

The access point is now avaliable on the list of networks. It impossible to join it.
Amount of errors ath0: stuck beacon; resetting (bmiss count 4) increases a lot when I try to join it.

It would be nice if you give me a tip. Thanks in advance. Is atheros not fully supported on amd64? Is that 7. 2 issue?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd Ath0 mode monitor mateusrico FreeBSD General 3 8th April 2009 09:34 AM
apache: data stuck in socket? goertzenator FreeBSD General 8 16th February 2009 04:01 PM
Atheros 5214 will it work on Freebsd 7 businessgeeks FreeBSD Installation and Upgrading 1 26th December 2008 10:58 AM
strange load problem on freebsd 7.0 amd64 skynet_tech FreeBSD General 3 11th September 2008 09:49 PM


All times are GMT. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick