DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd June 2009
kaschei kaschei is offline
New User
 
Join Date: May 2009
Posts: 3
Thanked 0 Times in 0 Posts
Default OpenBSD xfce4

Hi to all. I just compile xfce4 and xdm on my openbsd box (4.4). So my question is how I can run it on boot time as my default window manager because I want starting BSD with GUI? I have been try to put startxfce4 in .xinitrc and then edit rc.conf (xdm_flags=YES) but this do not work

Thanks in advance.
Reply With Quote
  #2   (View Single Post)  
Old 22nd June 2009
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 803
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by kaschei View Post
Hi to all. I just compile xfce4 and xdm on my openbsd box (4.4). So my question is how I can run it on boot time as my default window manager because I want starting BSD with GUI? I have been try to put startxfce4 in .xinitrc and then edit rc.conf (xdm_flags=YES) but this do not work

Thanks in advance.
To start xdm on the boot
Code:
echo "xdm_flags=    " /etc/rc.conf.local
To start xfce4 as your default WM you have to edit ~/.xsession as

Code:
#! /usr/bin
exec xfce4
.xinitrc is used when you start X server with startx!
Reply With Quote
  #3   (View Single Post)  
Old 22nd June 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Double whammy Oko?

He meant you have to put xdm_flags= into /etc/rc.conf.local, and a window manager invocation in a ~/.xsession shell script.
Reply With Quote
  #4   (View Single Post)  
Old 22nd June 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,906
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by kaschei View Post
I have been try to put startxfce4 in .xinitrc and then edit rc.conf (xdm_flags=YES)...
For more context, see the following sections in the FAQ:
Reply With Quote
  #5   (View Single Post)  
Old 28th June 2009
kaschei kaschei is offline
New User
 
Join Date: May 2009
Posts: 3
Thanked 0 Times in 0 Posts
Default

No this solutions not working for me. Any suggestions ?
Reply With Quote
  #6   (View Single Post)  
Old 28th June 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,814
Thanked 214 Times in 189 Posts
Default

For xdm: post the contents of your /etc/rc.conf and /etc/rc.conf.local files. We're interested in the value of xdm_flags.

For XFCE: post the contents ofthe user's .xsession file. We're interested in seeing if you have the file, and what's in it.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg + Xfce4 resolution problem sniper007 FreeBSD General 4 30th April 2009 04:38 PM
enable shutdown/reboot xfce4 rex FreeBSD General 16 17th October 2008 02:19 PM
Xfce4 and desktop update [gamin problem] daemonFromHeaven FreeBSD Ports and Packages 7 7th September 2008 08:20 AM
XFCE4 on 7.0 TMD3 FreeBSD Ports and Packages 3 26th July 2008 03:22 AM


All times are GMT. The time now is 07:54 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick