DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 5th July 2009
Albright Albright is offline
Port Guard
 
Join Date: Apr 2009
Posts: 14
Thanked 0 Times in 0 Posts
Default Diagnosing a segfault error

I've set up a web server on a RootBSD VPS with Lighttpd and PHP via FastCGI to operate a site with the Drupal CMS. When I take a certain, repeatable series of steps in Drupal, I'm causing the PHP process to exit on signal 11, a segmentation fault.

I've already spent several hours over the past couple of weeks diagnosing this through trial and error, but haven't been able to figure out what's causing this or how to work around it. Even more flummoxing is that my company also has a RootBSD VPS account which is not having this problem. Their account is a step above mine and has a larger memory allocation, so I suspect that might be the problem or at least part of it, but I'm not sure.

I guess what I'm asking is, is there a way to get more information on what is causing such an error, or perhaps even where in Drupal's codebase it's occurring?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox segfault in windowmaker and icewm davidgurvich FreeBSD General 4 25th August 2008 02:58 PM


All times are GMT. The time now is 07:19 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick