DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 8th July 2009
Mantazz Mantazz is offline
Shell Scout
 
Join Date: Oct 2008
Posts: 90
Thanked 0 Times in 0 Posts
Default startx not starting correctly - XOrg 7.4_2

I just finished installing XOrg 7.4_2 from the ports tree, but it does not seem to start correctly.

When I run startx, I see three xterm windows. However, I have an unresponsive mouse and I cannot alt-tab to get to any of the windows. None seem selected when XOrg starts, so my typing is not recognized. I can tell the keyboard is still responsive, however, as the caps lock still sets the light on my keyboard.

My mouse is active when I am at the regular shell (before starting XOrg), I added
Code:
moused_enable="YES"
To /etc/rc.conf to start it. The mouse works before starting XOrg and after killing it, but it does not work when XOrg is running.
Reply With Quote
  #2   (View Single Post)  
Old 8th July 2009
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,088
Thanked 198 Times in 156 Posts
Default

Try adding:
AllowEmptyInput "False"

To the ServerFlags serction in /etc/X11/xorg.conf or /etc/xorg.conf

As a sidenote, xinit usually works better than startx, both do the same but startx also does xauth stuff, which no one uses anyway and often causes problems.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Reply

Tags
7.2-release, ports, startx, x11, xorg

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FBSD 7.2 installation not seeing partition table correctly Mantazz FreeBSD Installation and Upgrading 0 2nd July 2009 11:36 AM
Startx executes as root, "startx:not found" as user Mr-Biscuit NetBSD Installation and Upgrading 4 27th May 2009 08:44 AM
VNC not viewing correctly disappearedng FreeBSD General 6 30th August 2008 05:03 PM
Samba NOT STARTING pcfxer FreeBSD General 11 13th May 2008 09:29 AM
KDE (X-Server) in FreeBSD 7.0 doesn't work correctly louie FreeBSD General 6 7th May 2008 11:53 PM


All times are GMT. The time now is 06:17 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick